summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-13 11:01:55 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-13 11:01:55 +0000
commit3ca5cdd1dd6e46971deaa1d334de4a3d9f5aee0c (patch)
tree64d9459a5b169dcabc64c994a1e62daccdb877dc /app-crypt/chntpw/chntpw-100627.ebuild
parentFixed build failure against ghc-6.12.2+ (bug #327903) (diff)
downloadgentoo-2-3ca5cdd1dd6e46971deaa1d334de4a3d9f5aee0c.tar.gz
gentoo-2-3ca5cdd1dd6e46971deaa1d334de4a3d9f5aee0c.tar.bz2
gentoo-2-3ca5cdd1dd6e46971deaa1d334de4a3d9f5aee0c.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/chntpw/chntpw-100627.ebuild')
-rw-r--r--app-crypt/chntpw/chntpw-100627.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-crypt/chntpw/chntpw-100627.ebuild b/app-crypt/chntpw/chntpw-100627.ebuild
new file mode 100644
index 000000000000..2c0d9a27588b
--- /dev/null
+++ b/app-crypt/chntpw/chntpw-100627.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/chntpw/chntpw-100627.ebuild,v 1.1 2010/07/13 11:01:55 ssuominen Exp $
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="Offline Windows NT Password & Registry Editor"
+HOMEPAGE="http://pogostick.net/~pnh/ntpasswd/"
+SRC_URI="http://pogostick.net/~pnh/ntpasswd/${PN}-source-${PV}.zip"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static"
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_prepare() {
+ sed -i \
+ -e '/-o/s:$(CC):$(CC) $(LDFLAGS):' \
+ Makefile || die
+
+ emake clean || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -DUSEOPENSSL -Wall" \
+ LIBS="-lcrypto" || die
+}
+
+src_install() {
+ dobin chntpw cpnt reged || die
+
+ if use static; then
+ dobin {chntpw,reged}.static || die
+ fi
+
+ dodoc {HISTORY,README,regedit,WinReg}.txt || die
+}