summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-03 12:36:47 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-03 12:36:47 +0000
commite38e1019a87a5cc8577679155ba362fd778af48d (patch)
tree2135d0e517924913ef718b8533263663ca8010c6 /app-crypt/johntheripper/files
parentBump to 1.9.1. Small patch by Lorenz Quack. Fixes #280445 (diff)
downloadgentoo-2-e38e1019a87a5cc8577679155ba362fd778af48d.tar.gz
gentoo-2-e38e1019a87a5cc8577679155ba362fd778af48d.tar.bz2
gentoo-2-e38e1019a87a5cc8577679155ba362fd778af48d.zip
Small set of fixes, thanks to RB. Closes #277811
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/johntheripper/files')
-rw-r--r--app-crypt/johntheripper/files/johntheripper-1.7.3.1-all-5-stackdef.S.patch21
-rw-r--r--app-crypt/johntheripper/files/johntheripper-1.7.3.1-cflags.patch68
-rw-r--r--app-crypt/johntheripper/files/johntheripper-1.7.3.1-stackdef.S.patch71
3 files changed, 122 insertions, 38 deletions
diff --git a/app-crypt/johntheripper/files/johntheripper-1.7.3.1-all-5-stackdef.S.patch b/app-crypt/johntheripper/files/johntheripper-1.7.3.1-all-5-stackdef.S.patch
new file mode 100644
index 000000000000..1baced819820
--- /dev/null
+++ b/app-crypt/johntheripper/files/johntheripper-1.7.3.1-all-5-stackdef.S.patch
@@ -0,0 +1,21 @@
+diff -urpN john-1.7.3.1.orig/src/md5-mmx.S john-1.7.3.1/src/md5-mmx.S
+--- john-1.7.3.1.orig/src/md5-mmx.S 2009-06-26 14:03:21.073960144 -0600
++++ john-1.7.3.1/src/md5-mmx.S 2009-06-26 14:01:28.889959256 -0600
+@@ -306,3 +306,6 @@ mdfivemmx_noinit:
+
+ ret
+
++#ifdef __ELF__
++.section .note.GNU-stack,"",@progbits
++#endif
+diff -urpN john-1.7.3.1.orig/src/sha1-mmx.S john-1.7.3.1/src/sha1-mmx.S
+--- john-1.7.3.1.orig/src/sha1-mmx.S 2009-06-26 14:03:21.093949076 -0600
++++ john-1.7.3.1/src/sha1-mmx.S 2009-06-26 14:01:36.706958726 -0600
+@@ -558,3 +558,7 @@ endianity:
+ por tmp2, ctxd
+ por tmp4, ctxe
+ */
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",@progbits
++#endif
diff --git a/app-crypt/johntheripper/files/johntheripper-1.7.3.1-cflags.patch b/app-crypt/johntheripper/files/johntheripper-1.7.3.1-cflags.patch
new file mode 100644
index 000000000000..8c3bc0f49128
--- /dev/null
+++ b/app-crypt/johntheripper/files/johntheripper-1.7.3.1-cflags.patch
@@ -0,0 +1,68 @@
+* this is an incomplete patch, adding CFLAGS to some targets that we use
+ without this patch, one can't configure john via defines
+
+--- src/Makefile
++++ src/Makefile
+@@ -597,7 +597,7 @@
+ $(LN) ppc32.h arch.h
+ $(MAKE) $(PROJ) \
+ CC=cc \
+- CFLAGS="-c -qunroll=2 -qarch=ppc -qchars=signed" \
++ CFLAGS="$(CFLAGS) -c -qunroll=2 -qarch=ppc -qchars=signed" \
+ LDFLAGS="-s -lbsd" \
+ OPT_NORMAL="-O2" \
+ OPT_INLINE="-O3 -Q=99 -w"
+@@ -626,7 +626,7 @@
+ $(LN) ppc32alt.h arch.h
+ $(MAKE) $(PROJ) \
+ JOHN_OBJS="$(JOHN_OBJS) ppc-alti-macosx.o" \
+- CFLAGS="-c -Wall -fomit-frame-pointer" \
++ CFLAGS="$(CFLAGS) -c -Wall -fomit-frame-pointer" \
+ OPT_NORMAL="-fast -mcpu=7450" \
+ OPT_INLINE="-fast -mcpu=7450 -finline-limit=4000"
+
+@@ -637,7 +637,7 @@
+ $(LN) ppc32.h arch.h
+ $(MAKE) $(PROJ) \
+ CC=cc \
+- CFLAGS="-c -traditional-cpp" \
++ CFLAGS="$(CFLAGS) -c -traditional-cpp" \
+ OPT_NORMAL="-O2" \
+ OPT_INLINE="-O3"
+
+@@ -646,7 +646,7 @@
+ $(LN) ppc32.h arch.h
+ $(MAKE) $(PROJ) \
+ ASFLAGS="$(ASFLAGS) -arch ppc" \
+- CFLAGS="-c -Wall -arch ppc -fomit-frame-pointer" \
++ CFLAGS="$(CFLAGS) -c -Wall -arch ppc -fomit-frame-pointer" \
+ LDFLAGS="$(LDFLAGS) -arch ppc" \
+ OPT_NORMAL="-O2" \
+ OPT_INLINE="-O3 -finline-limit=4000"
+@@ -656,7 +656,7 @@
+ $(LN) ppc64alt.h arch.h
+ $(MAKE) $(PROJ) \
+ JOHN_OBJS="$(JOHN_OBJS) ppc-alti-macosx.o" \
+- CFLAGS="-c -m64 -Wall -fomit-frame-pointer" \
++ CFLAGS="$(CFLAGS) -c -m64 -Wall -fomit-frame-pointer" \
+ LDFLAGS="$(LDFLAGS) -m64" \
+ OPT_NORMAL="-fast" \
+ OPT_INLINE="-fast -finline-limit=4000"
+@@ -664,7 +664,7 @@
+ macosx-ppc64:
+ $(LN) ppc64.h arch.h
+ $(MAKE) $(PROJ) \
+- CFLAGS="-c -Wall -fomit-frame-pointer -m64" \
++ CFLAGS="$(CFLAGS) -c -Wall -fomit-frame-pointer -m64" \
+ LDFLAGS="$(LDFLAGS) -m64" \
+ OPT_NORMAL="-fast" \
+ OPT_INLINE="-fast -finline-limit=4000"
+@@ -698,7 +698,7 @@
+ $(MAKE) $(PROJ) \
+ JOHN_OBJS="$(JOHN_OBJS) ppc-alti-macosx.o" \
+ ASFLAGS="$(ASFLAGS) -arch ppc" \
+- CFLAGS="-c -Wall -arch ppc -fomit-frame-pointer" \
++ CFLAGS="$(CFLAGS) -c -Wall -arch ppc -fomit-frame-pointer" \
+ LDFLAGS="$(LDFLAGS) -arch ppc" \
+ OPT_NORMAL="-fast -mcpu=7450" \
+ OPT_INLINE="-fast -mcpu=7450 -finline-limit=4000"
diff --git a/app-crypt/johntheripper/files/johntheripper-1.7.3.1-stackdef.S.patch b/app-crypt/johntheripper/files/johntheripper-1.7.3.1-stackdef.S.patch
index 225e248e5764..8600b7d20e69 100644
--- a/app-crypt/johntheripper/files/johntheripper-1.7.3.1-stackdef.S.patch
+++ b/app-crypt/johntheripper/files/johntheripper-1.7.3.1-stackdef.S.patch
@@ -1,18 +1,17 @@
-Index: john-1.7.3.1/src/sha1-mmx.S
-===================================================================
---- john-1.7.3.1.orig/src/sha1-mmx.S
-+++ john-1.7.3.1/src/sha1-mmx.S
-@@ -558,3 +558,6 @@ endianity:
- por tmp2, ctxd
- por tmp4, ctxe
- */
-+#if defined(__linux__) && defined(__ELF__)
-+.section .note.GNU-stack,"",%progbits
+diff -urpN john-1.7.3.1.orig/src/alpha.S john-1.7.3.1/src/alpha.S
+--- john-1.7.3.1.orig/src/alpha.S 2002-04-10 08:13:25.000000000 -0600
++++ john-1.7.3.1/src/alpha.S 2009-06-26 13:56:10.635952569 -0600
+@@ -318,3 +318,7 @@ DES_KS_current:
+ .space 128
+
+ .comm DES_KS_table, (8 * 128 * 16 * 8), 128
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",@progbits
+#endif
-Index: john-1.7.3.1/src/sparc.S
-===================================================================
---- john-1.7.3.1.orig/src/sparc.S
-+++ john-1.7.3.1/src/sparc.S
+diff -urpN john-1.7.3.1.orig/src/sparc.S john-1.7.3.1/src/sparc.S
+--- john-1.7.3.1.orig/src/sparc.S 2002-04-10 08:13:25.000000000 -0600
++++ john-1.7.3.1/src/sparc.S 2009-06-26 13:54:31.388950767 -0600
@@ -410,3 +410,7 @@ DES_count:
.common DES_KS_table, (8 * 128 * 16 * 8), 32
@@ -21,11 +20,10 @@ Index: john-1.7.3.1/src/sparc.S
+#ifdef __ELF__
+.section .note.GNU-stack,"",@progbits
+#endif
-Index: john-1.7.3.1/src/x86-64.S
-===================================================================
---- john-1.7.3.1.orig/src/x86-64.S
-+++ john-1.7.3.1/src/x86-64.S
-@@ -1040,3 +1040,7 @@ DES_bs_crypt_LM_loop:
+diff -urpN john-1.7.3.1.orig/src/x86-64.S john-1.7.3.1/src/x86-64.S
+--- john-1.7.3.1.orig/src/x86-64.S 2008-07-13 15:35:12.000000000 -0600
++++ john-1.7.3.1/src/x86-64.S 2009-06-26 13:54:31.392950649 -0600
+@@ -1052,3 +1052,7 @@ DES_bs_crypt_LM_loop:
subl $1,rounds
jnz DES_bs_crypt_LM_loop
ret
@@ -33,11 +31,10 @@ Index: john-1.7.3.1/src/x86-64.S
+#ifdef __ELF__
+.section .note.GNU-stack,"",@progbits
+#endif
-Index: john-1.7.3.1/src/x86-mmx.S
-===================================================================
---- john-1.7.3.1.orig/src/x86-mmx.S
-+++ john-1.7.3.1/src/x86-mmx.S
-@@ -1302,3 +1302,7 @@ DES_bs_crypt_LM_loop:
+diff -urpN john-1.7.3.1.orig/src/x86-mmx.S john-1.7.3.1/src/x86-mmx.S
+--- john-1.7.3.1.orig/src/x86-mmx.S 2008-07-13 15:45:55.000000000 -0600
++++ john-1.7.3.1/src/x86-mmx.S 2009-06-26 13:54:31.396971552 -0600
+@@ -1314,3 +1314,7 @@ DES_bs_crypt_LM_loop:
emms
#endif
ret
@@ -45,25 +42,23 @@ Index: john-1.7.3.1/src/x86-mmx.S
+#ifdef __ELF__
+.section .note.GNU-stack,"",@progbits
+#endif
-Index: john-1.7.3.1/src/x86-sse.S
-===================================================================
---- john-1.7.3.1.orig/src/x86-sse.S
-+++ john-1.7.3.1/src/x86-sse.S
-@@ -1289,3 +1289,7 @@ DES_bs_crypt_LM_loop:
- jnz DES_bs_crypt_LM_loop
- popl %esi
+diff -urpN john-1.7.3.1.orig/src/x86.S john-1.7.3.1/src/x86.S
+--- john-1.7.3.1.orig/src/x86.S 2008-07-07 12:30:36.000000000 -0600
++++ john-1.7.3.1/src/x86.S 2009-06-26 13:54:31.404961468 -0600
+@@ -1366,3 +1366,7 @@ CPU_detect_ret:
+ movzbl %al,%eax
+ popl %ebx
ret
+
+#ifdef __ELF__
+.section .note.GNU-stack,"",@progbits
+#endif
-Index: john-1.7.3.1/src/x86.S
-===================================================================
---- john-1.7.3.1.orig/src/x86.S
-+++ john-1.7.3.1/src/x86.S
-@@ -1362,3 +1362,7 @@ CPU_detect_ret:
- movzbl %al,%eax
- popl %ebx
+diff -urpN john-1.7.3.1.orig/src/x86-sse.S john-1.7.3.1/src/x86-sse.S
+--- john-1.7.3.1.orig/src/x86-sse.S 2008-07-13 15:44:58.000000000 -0600
++++ john-1.7.3.1/src/x86-sse.S 2009-06-26 13:54:31.399949655 -0600
+@@ -1301,3 +1301,7 @@ DES_bs_crypt_LM_loop:
+ jnz DES_bs_crypt_LM_loop
+ popl %esi
ret
+
+#ifdef __ELF__