summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2003-07-15 09:21:17 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2003-07-15 09:21:17 +0000
commit0b32034658958af2072a644a69520178bd5c1fdf (patch)
tree1c4ece388d0bcdb2f88497ce7141a3e8e2b939a6 /app-crypt/newpg/newpg-0.9.4-r1.ebuild
parentAdded sparc stable keyword (diff)
downloadgentoo-2-0b32034658958af2072a644a69520178bd5c1fdf.tar.gz
gentoo-2-0b32034658958af2072a644a69520178bd5c1fdf.tar.bz2
gentoo-2-0b32034658958af2072a644a69520178bd5c1fdf.zip
Put sensible defaults
Diffstat (limited to 'app-crypt/newpg/newpg-0.9.4-r1.ebuild')
-rw-r--r--app-crypt/newpg/newpg-0.9.4-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-crypt/newpg/newpg-0.9.4-r1.ebuild b/app-crypt/newpg/newpg-0.9.4-r1.ebuild
new file mode 100644
index 000000000000..90e4c899a10c
--- /dev/null
+++ b/app-crypt/newpg/newpg-0.9.4-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/newpg/newpg-0.9.4-r1.ebuild,v 1.1 2003/07/15 09:21:06 pauldv Exp $
+
+DESCRIPTION="NewPG is the S/MIME variant of GnuPG which does also include the gpg-agent, useful even for GnuPG"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/alpha/aegypten/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+IUSE="nls"
+
+DEPEND="dev-lang/perl
+ >=dev-libs/libksba-0.4.6
+ >=dev-libs/libgcrypt-1.1.8
+ dev-libs/pth"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+
+ #set the default pinentry program to a sensible location
+ if [ -x /usr/bin/pinentry-qt ]; then
+ myconf="${myconf} --with-pinentry-pgm=/usr/bin/pinentry-qt"
+ else
+ if [ -x /usr/bin/pinentry-gtk ]; then
+ myconf="${myconf} --with-pinentry-pgm=/usr/bin/pinentry-gtk"
+ fi
+ fi
+
+ econf ${myconf} --disable-dependency-tracking \
+ --exec-prefix=/usr
+ make || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO VERSION
+
+ chmod +s "${D}/usr/bin/gpgsm"
+}
+
+pkg_postinst() {
+ einfo "gpgsm is installed SUID root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your passphrases,"
+ einfo "etc. at runtime but may make some sysadmins nervous"
+}