summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 16:27:51 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 16:27:51 +0000
commitcbb996084c1960986756b7d4644324d1dba56940 (patch)
tree289372c2f990a1a84843380631842baabd530661 /app-crypt
parentVersion bump for Gnome 3.8 (diff)
downloadgentoo-2-cbb996084c1960986756b7d4644324d1dba56940.tar.gz
gentoo-2-cbb996084c1960986756b7d4644324d1dba56940.tar.bz2
gentoo-2-cbb996084c1960986756b7d4644324d1dba56940.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gcr/ChangeLog7
-rw-r--r--app-crypt/gcr/gcr-3.8.0.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/app-crypt/gcr/ChangeLog b/app-crypt/gcr/ChangeLog
index 65d6fb0f65d4..02eda4871632 100644
--- a/app-crypt/gcr/ChangeLog
+++ b/app-crypt/gcr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/gcr
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gcr/ChangeLog,v 1.16 2013/02/25 08:49:57 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gcr/ChangeLog,v 1.17 2013/03/28 16:27:51 pacho Exp $
+
+*gcr-3.8.0 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org> +gcr-3.8.0.ebuild:
+ Version bump for Gnome 3.8
25 Feb 2013; Zac Medico <zmedico@gentoo.org> gcr-3.6.2.ebuild:
Add ~arm-linux keyword.
diff --git a/app-crypt/gcr/gcr-3.8.0.ebuild b/app-crypt/gcr/gcr-3.8.0.ebuild
new file mode 100644
index 000000000000..af1a134b7f9b
--- /dev/null
+++ b/app-crypt/gcr/gcr-3.8.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gcr/gcr-3.8.0.ebuild,v 1.1 2013/03/28 16:27:51 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 virtualx
+
+DESCRIPTION="Libraries for cryptographic UIs and accessing PKCS#11 modules"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0/1" # subslot = suffix of libgcr-3
+IUSE="debug gtk +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+
+COMMON_DEPEND="
+ >=app-crypt/gnupg-2
+ >=app-crypt/p11-kit-0.6
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libgcrypt-1.2.2:=
+ >=dev-libs/libtasn1-1:=
+ >=sys-apps/dbus-1.0
+ gtk? ( >=x11-libs/gtk+-3.0:3 )
+ introspection? ( >=dev-libs/gobject-introspection-1.34 )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gnome-keyring-3.3
+"
+# gcr was part of gnome-keyring until 3.3
+DEPEND="${COMMON_DEPEND}
+ dev-libs/gobject-introspection-common
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# eautoreconf needs:
+# dev-libs/gobject-introspection-common
+
+src_prepare() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+ G2CONF="${G2CONF}
+ $(use_with gtk)
+ $(use_enable introspection)
+ $(usex debug --enable-debug=yes --enable-debug=default)
+ --disable-update-icon-cache
+ --disable-update-mime"
+
+ # Disable stupid flag changes
+ sed -e 's/CFLAGS="$CFLAGS -g"//' \
+ -e 's/CFLAGS="$CFLAGS -O0"//' \
+ -i configure.ac configure || die
+
+ gnome2_src_prepare
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check
+}