summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavlos Ratis <dastergon@gentoo.org>2015-01-08 20:24:31 +0000
committerPavlos Ratis <dastergon@gentoo.org>2015-01-08 20:24:31 +0000
commite6d4d2e368746d5ff80e895d191646d1fd8c9d0e (patch)
treede8cdc1f4c3d84b6927eceac072f15882cd82c48 /app-crypt
parentamd64 stable wrt bug #536042 (diff)
downloadgentoo-2-e6d4d2e368746d5ff80e895d191646d1fd8c9d0e.tar.gz
gentoo-2-e6d4d2e368746d5ff80e895d191646d1fd8c9d0e.tar.bz2
gentoo-2-e6d4d2e368746d5ff80e895d191646d1fd8c9d0e.zip
initial release
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x3A051746)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gkeys-gen/ChangeLog8
-rw-r--r--app-crypt/gkeys-gen/gkeys-gen-0.1.ebuild40
2 files changed, 46 insertions, 2 deletions
diff --git a/app-crypt/gkeys-gen/ChangeLog b/app-crypt/gkeys-gen/ChangeLog
index 4344a023f142..9be8f4dce748 100644
--- a/app-crypt/gkeys-gen/ChangeLog
+++ b/app-crypt/gkeys-gen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/gkeys-gen
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gkeys-gen/ChangeLog,v 1.2 2015/01/01 20:28:44 dolsen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gkeys-gen/ChangeLog,v 1.3 2015/01/08 20:24:31 dastergon Exp $
+
+*gkeys-gen-0.1 (08 Jan 2015)
+
+ 08 Jan 2015; Pavlos Ratis <dastergon@gentoo.org> +gkeys-gen-0.1.ebuild:
+ initial release
01 Jan 2015; Brian Dolbec <dolsen@gentoo.org> gkeys-gen-9999.ebuild:
Forgot to edit the description. Corrected :)
@@ -10,4 +15,3 @@
01 Jan 2015; Brian Dolbec <dolsen@gentoo.org> +gkeys-gen-9999.ebuild,
+metadata.xml:
Initial ebuild added to the tree.
-
diff --git a/app-crypt/gkeys-gen/gkeys-gen-0.1.ebuild b/app-crypt/gkeys-gen/gkeys-gen-0.1.ebuild
new file mode 100644
index 000000000000..2ffed915e62e
--- /dev/null
+++ b/app-crypt/gkeys-gen/gkeys-gen-0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gkeys-gen/gkeys-gen-0.1.ebuild,v 1.1 2015/01/08 20:24:31 dastergon Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4})
+
+inherit distutils-r1
+
+DESCRIPTION="Tool for generating OpenPGP/GPG keys using a specifications file"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Gentoo-keys"
+SRC_URI="http://dev.gentoo.org/~dolsen/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+ dev-python/snakeoil[${PYTHON_USEDEP}]
+ dev-python/pygpgme[${PYTHON_USEDEP}]
+ =app-crypt/gkeys-0.1[${PYTHON_USEDEP}]
+ "
+
+pkg_postinst() {
+ einfo "This is experimental software."
+ einfo "The API's it installs should be considered unstable"
+ einfo "and are subject to change."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://bugs.gentoo.org"
+ einfo "We are also on IRC @ #gentoo-keys of the Freenode network"
+ einfo
+ ewarn "There may be some Python 3 compatibility issues still."
+ ewarn "Please help us debug, fix and report them in Bugzilla."
+}