summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2009-01-03 09:02:45 +0000
committerDaniel Black <dragonheart@gentoo.org>2009-01-03 09:02:45 +0000
commite9584c7ff5b8f6b95b6ae05f5e0434a553222861 (patch)
tree674c07503a3df44cca00b287e23b96fe8ad9f84d /app-crypt
parentversion bump as per bug #248434 thanks to 7v5w7go9ub0o. noting license chan... (diff)
downloadgentoo-2-e9584c7ff5b8f6b95b6ae05f5e0434a553222861.tar.gz
gentoo-2-e9584c7ff5b8f6b95b6ae05f5e0434a553222861.tar.bz2
gentoo-2-e9584c7ff5b8f6b95b6ae05f5e0434a553222861.zip
version bump. patch and ebuild cleanup byArfrever in bug #242572
(Portage version: 2.2_rc20/cvs/Linux 2.6.26-gentoo-r4 x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gpgme/ChangeLog10
-rw-r--r--app-crypt/gpgme/files/gpgme-1.1.7-_gpgme_cancel_with_err.patch22
-rw-r--r--app-crypt/gpgme/gpgme-1.1.7.ebuild42
3 files changed, 72 insertions, 2 deletions
diff --git a/app-crypt/gpgme/ChangeLog b/app-crypt/gpgme/ChangeLog
index b5ca0efec4ee..54afb22fa3ce 100644
--- a/app-crypt/gpgme/ChangeLog
+++ b/app-crypt/gpgme/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/gpgme
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/ChangeLog,v 1.149 2008/11/17 19:56:16 flameeyes Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/ChangeLog,v 1.150 2009/01/03 09:02:45 dragonheart Exp $
+
+*gpgme-1.1.7 (03 Jan 2009)
+
+ 03 Jan 2009; Daniel Black <dragonheart@gentoo.org>
+ +files/gpgme-1.1.7-_gpgme_cancel_with_err.patch, +gpgme-1.1.7.ebuild:
+ version bump. patch and ebuild cleanup byArfrever in bug #242572
17 Nov 2008; Diego E. Pettenò <flameeyes@gentoo.org>
files/gpgme3.m4.patch:
diff --git a/app-crypt/gpgme/files/gpgme-1.1.7-_gpgme_cancel_with_err.patch b/app-crypt/gpgme/files/gpgme-1.1.7-_gpgme_cancel_with_err.patch
new file mode 100644
index 000000000000..26f48b9e884f
--- /dev/null
+++ b/app-crypt/gpgme/files/gpgme-1.1.7-_gpgme_cancel_with_err.patch
@@ -0,0 +1,22 @@
+--- gpgme-1.1.7/gpgme/gpgme.h
++++ gpgme-1.1.7-fixed/gpgme/gpgme.h
+@@ -1117,6 +1117,8 @@
+
+ /* Crypto Operations. */
+
++gpgme_error_t _gpgme_cancel_with_err (gpgme_ctx_t ctx, gpg_error_t ctx_err);
++
+ /* Cancel a pending asynchronous operation. */
+ gpgme_error_t gpgme_cancel (gpgme_ctx_t ctx);
+
+--- gpgme-1.1.7/gpgme/wait-global.c
++++ gpgme-1.1.7-fixed/gpgme/wait-global.c
+@@ -202,7 +202,7 @@
+ if (err)
+ /* An error occured. Close all fds in this context, and
+ send the error in a done event. */
+- _gpgme_cancel_with_err (ctx, &err);
++ _gpgme_cancel_with_err (ctx, err);
+ }
+ break;
+
diff --git a/app-crypt/gpgme/gpgme-1.1.7.ebuild b/app-crypt/gpgme/gpgme-1.1.7.ebuild
new file mode 100644
index 000000000000..bee11e8f6682
--- /dev/null
+++ b/app-crypt/gpgme/gpgme-1.1.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/gpgme-1.1.7.ebuild,v 1.1 2009/01/03 09:02:45 dragonheart Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="GnuPG Made Easy is a library for making GnuPG easier to use"
+HOMEPAGE="http://www.gnupg.org/related_software/gpgme"
+SRC_URI="mirror://gnupg/gpgme/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="pth"
+
+DEPEND=">=dev-libs/libgpg-error-1.4
+ >=app-crypt/gnupg-1.9.20-r1
+ pth? ( >=dev-libs/pth-1.2 )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-_gpgme_cancel_with_err.patch
+ # We need to call elibtoolize so that we get sane .so versioning on
+ # fbsd.
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ --includedir=/usr/include/gpgme \
+ --with-gpg=/usr/bin/gpg \
+ --with-gpgsm=/usr/bin/gpgsm \
+ $(use_with pth) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}