summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-12-30 17:57:42 +0000
committerChristoph Mende <angelos@gentoo.org>2008-12-30 17:57:42 +0000
commiteda980f3ef8d45e397737b56d7dfb7c7aa9f3034 (patch)
tree034fcb00a3072483521c92e014dd19fb51da0242 /app-crypt
parentVersion bump, bug 252605 (diff)
downloadgentoo-2-eda980f3ef8d45e397737b56d7dfb7c7aa9f3034.tar.gz
gentoo-2-eda980f3ef8d45e397737b56d7dfb7c7aa9f3034.tar.bz2
gentoo-2-eda980f3ef8d45e397737b56d7dfb7c7aa9f3034.zip
QA: Respect CC (bug 243538)
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/chntpw/ChangeLog5
-rw-r--r--app-crypt/chntpw/chntpw-080526.ebuild14
2 files changed, 16 insertions, 3 deletions
diff --git a/app-crypt/chntpw/ChangeLog b/app-crypt/chntpw/ChangeLog
index e8b535d23fb5..734a5ffaeb2f 100644
--- a/app-crypt/chntpw/ChangeLog
+++ b/app-crypt/chntpw/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-crypt/chntpw
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/chntpw/ChangeLog,v 1.14 2008/06/29 03:17:18 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/chntpw/ChangeLog,v 1.15 2008/12/30 17:57:42 angelos Exp $
+
+ 30 Dec 2008; Christoph Mende <angelos@gentoo.org> chntpw-080526.ebuild:
+ QA: Respect CC (bug 243538)
*chntpw-080526 (29 Jun 2008)
diff --git a/app-crypt/chntpw/chntpw-080526.ebuild b/app-crypt/chntpw/chntpw-080526.ebuild
index b6b341e85f69..72cfc11bca7d 100644
--- a/app-crypt/chntpw/chntpw-080526.ebuild
+++ b/app-crypt/chntpw/chntpw-080526.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/chntpw/chntpw-080526.ebuild,v 1.2 2008/06/30 23:10:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/chntpw/chntpw-080526.ebuild,v 1.3 2008/12/30 17:57:42 angelos Exp $
+
+inherit toolchain-funcs
DESCRIPTION="Offline Windows NT Password & Registry Editor"
HOMEPAGE="http://home.eunet.no/~pnordahl/ntpasswd/"
@@ -14,6 +16,14 @@ IUSE="static"
RDEPEND="dev-libs/openssl"
DEPEND="app-arch/unzip"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "/^CC/s/gcc/$(tc-getCC)/" \
+ Makefile || die "sed failed"
+}
+
src_compile() {
#Makefile is hardcoded, override the defaults with the user's settings.
emake LIBS="-lcrypto" CFLAGS="${CFLAGS}" || die "emake failed"
@@ -23,5 +33,5 @@ src_install() {
dobin chntpw
use static && dobin chntpw.static
dobin cpnt
- dodoc *.txt
+ dodoc HISTORY.txt README.txt regedit.txt WinReg.txt
}