summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-08-30 23:07:15 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-08-30 23:07:15 +0000
commit0322ed181b951005d30e0edb282e0a7b864e05a6 (patch)
treef83214dd26994662dcb03835bada02dfbfcbefaa /app-dicts
parentRemove old; restore dependency on ncurses (diff)
downloadgentoo-2-0322ed181b951005d30e0edb282e0a7b864e05a6.tar.gz
gentoo-2-0322ed181b951005d30e0edb282e0a7b864e05a6.tar.bz2
gentoo-2-0322ed181b951005d30e0edb282e0a7b864e05a6.zip
Version bump to 3.0.2 (uses Gtk+ 3); add ncurses USE flag; remove static libraries and .la files. Closes bug #349270.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/gwaei/ChangeLog9
-rw-r--r--app-dicts/gwaei/files/gwaei-3.0.2-no-ncurses.patch20
-rw-r--r--app-dicts/gwaei/gwaei-3.0.2.ebuild75
-rw-r--r--app-dicts/gwaei/metadata.xml21
4 files changed, 116 insertions, 9 deletions
diff --git a/app-dicts/gwaei/ChangeLog b/app-dicts/gwaei/ChangeLog
index 469b7829046d..94e93fd8c502 100644
--- a/app-dicts/gwaei/ChangeLog
+++ b/app-dicts/gwaei/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-dicts/gwaei
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/gwaei/ChangeLog,v 1.22 2011/03/27 10:10:42 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/gwaei/ChangeLog,v 1.23 2011/08/30 23:07:15 flameeyes Exp $
+
+*gwaei-3.0.2 (30 Aug 2011)
+
+ 30 Aug 2011; Diego E. Pettenò <flameeyes@gentoo.org> +gwaei-3.0.2.ebuild,
+ +files/gwaei-3.0.2-no-ncurses.patch, metadata.xml:
+ Version bump to 3.0.2 (uses Gtk+ 3); add ncurses USE flag; remove static
+ libraries and .la files. Closes bug #349270.
27 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> gwaei-1.0.ebuild,
gwaei-1.1.ebuild:
diff --git a/app-dicts/gwaei/files/gwaei-3.0.2-no-ncurses.patch b/app-dicts/gwaei/files/gwaei-3.0.2-no-ncurses.patch
new file mode 100644
index 000000000000..b614c218d309
--- /dev/null
+++ b/app-dicts/gwaei/files/gwaei-3.0.2-no-ncurses.patch
@@ -0,0 +1,20 @@
+Index: gwaei-3.0.2/src/waei/waei.c
+===================================================================
+--- gwaei-3.0.2.orig/src/waei/waei.c
++++ gwaei-3.0.2/src/waei/waei.c
+@@ -195,6 +195,7 @@ int w_start_console (int argc, char* arg
+ }
+
+
++#ifdef WITH_NCURSES
+ //!
+ //! @brief Equivalent to the main function for many programs. This is what starts the program
+ //! @param argc Your argc from your main function
+@@ -219,6 +220,7 @@ int w_start_ncurses (int argc, char* arg
+
+ return TRUE;
+ }
++#endif
+
+
+ int main (int argc, char *argv[])
diff --git a/app-dicts/gwaei/gwaei-3.0.2.ebuild b/app-dicts/gwaei/gwaei-3.0.2.ebuild
new file mode 100644
index 000000000000..d56caccde170
--- /dev/null
+++ b/app-dicts/gwaei/gwaei-3.0.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/gwaei/gwaei-3.0.2.ebuild,v 1.1 2011/08/30 23:07:15 flameeyes Exp $
+
+EAPI="4"
+
+inherit gnome2-utils eutils
+
+DESCRIPTION="Japanese-English Dictionary for GNOME"
+HOMEPAGE="http://gwaei.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gwaei/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk nls unique test ncurses"
+
+RDEPEND=">=net-misc/curl-7.21.0
+ >=dev-libs/glib-2.25.0:2
+ gtk? (
+ x11-libs/gtk+:3
+ >=app-text/gnome-doc-utils-0.13.0
+ unique? ( dev-libs/libunique:3 )
+ )
+ ncurses? ( sys-libs/ncurses[unicode] )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ test? ( app-text/docbook-xml-dtd:4.1.2 )
+ gtk? (
+ >=app-text/gnome-doc-utils-0.13.0
+ app-text/scrollkeeper
+ )
+ nls? ( >=sys-devel/gettext-0.17 )
+ dev-util/pkgconfig"
+
+REQUIRED_USE="unique? ( gtk )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-ncurses.patch
+}
+
+src_configure() {
+ econf \
+ $(use_with gtk gnome) \
+ $(use_with ncurses) \
+ $(use_with unique libunique) \
+ $(use_enable nls) \
+ --disable-static \
+ --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ find "${D}" -name '*.la' -delete
+
+ dodoc AUTHORS README
+}
+
+pkg_preinst() {
+ if use gtk ; then
+ gnome2_schemas_savelist
+ fi
+}
+
+pkg_postinst() {
+ if use gtk ; then
+ gnome2_schemas_update
+ fi
+}
+
+pkg_postrm() {
+ if use gtk ; then
+ gnome2_schemas_update --uninstall
+ fi
+}
diff --git a/app-dicts/gwaei/metadata.xml b/app-dicts/gwaei/metadata.xml
index 077e55ccee9f..3a976493c3a4 100644
--- a/app-dicts/gwaei/metadata.xml
+++ b/app-dicts/gwaei/metadata.xml
@@ -1,12 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>cjk</herd>
-<longdescription lang="en">
- gWaei is a drop-in replacement for Gjiten. The main
- feature of this dictonary program is regular expression
- support. For example, you can use periods in place of
- unknown Kanji of a word to search for it.
-</longdescription>
+ <herd>cjk</herd>
+ <longdescription lang="en">
+ gWaei is a drop-in replacement for Gjiten. The main feature of
+ this dictonary program is regular expression support. For example,
+ you can use periods in place of unknown Kanji of a word to search
+ for it.
+ </longdescription>
+ <use>
+ <flag name='unique'>
+ Enable single instance support using
+ <pkg>dev-libs/libunique</pkg>.
+ </flag>
+ </use>
</pkgmetadata>
-