summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2005-12-21 03:30:53 +0000
committerSteve Arnold <nerdboy@gentoo.org>2005-12-21 03:30:53 +0000
commitb0c9e07e6a20549ea2350161449f38f2c5d688fd (patch)
treea51165b66192f539efe8e4da8c5c7c96dc6a1bed /app-doc/doxygen/doxygen-1.4.3-r1.ebuild
parentVersion bump. closes bug #115721 (diff)
downloadgentoo-2-b0c9e07e6a20549ea2350161449f38f2c5d688fd.tar.gz
gentoo-2-b0c9e07e6a20549ea2350161449f38f2c5d688fd.tar.bz2
gentoo-2-b0c9e07e6a20549ea2350161449f38f2c5d688fd.zip
patched all versions with fixes for bugs 112076 and 113420
(Portage version: 2.1_pre1)
Diffstat (limited to 'app-doc/doxygen/doxygen-1.4.3-r1.ebuild')
-rw-r--r--app-doc/doxygen/doxygen-1.4.3-r1.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/app-doc/doxygen/doxygen-1.4.3-r1.ebuild b/app-doc/doxygen/doxygen-1.4.3-r1.ebuild
index 4a8b9a4d94f0..80b6e3833902 100644
--- a/app-doc/doxygen/doxygen-1.4.3-r1.ebuild
+++ b/app-doc/doxygen/doxygen-1.4.3-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.3-r1.ebuild,v 1.7 2005/10/20 06:34:43 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.3-r1.ebuild,v 1.8 2005/12/21 03:30:53 nerdboy Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Documentation and analysis tool for C++, C, Java, IDL, PHP and C#"
HOMEPAGE="http://www.doxygen.org/"
@@ -11,7 +11,7 @@ SRC_URI="ftp://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 sparc x86 ~ppc-macos"
-IUSE="doc qt tetex"
+IUSE="doc qt tetex unicode"
RDEPEND="media-gfx/graphviz
qt? ( =x11-libs/qt-3* )
@@ -27,13 +27,23 @@ src_unpack() {
sed -i.orig -e "s:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= ${CFLAGS}:" \
-e "s:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= ${CXXFLAGS}:" \
tmake/lib/linux-g++/tmake.conf
+
epatch ${FILESDIR}/${P}-cp1251.patch
epatch ${FILESDIR}/${P}-nls.patch
+
if use userland_Darwin; then
epatch ${FILESDIR}/bsd-configure.patch
[[ "$MACOSX_DEPLOYMENT_TARGET" == "10.4" ]] && sed -i -e 's:-D__FreeBSD__:-D__FreeBSD__=5:' \
tmake/lib/macosx-c++/tmake.conf
fi
+
+ if use unicode; then
+ epatch ${FILESDIR}/${PN}-utf8-ru.patch.gz || die "utf8-ru patch failed"
+ fi
+
+ if [ $(gcc-major-version) -eq 4 ] ; then
+ epatch ${FILESDIR}/${PN}-gcc4.patch || die "gcc4 patch failed"
+ fi
}
src_compile() {