summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-09-29 11:32:40 +0000
committerUlrich Müller <ulm@gentoo.org>2007-09-29 11:32:40 +0000
commit026133078fc689b9c65a77174175bb5bbb8b6d90 (patch)
tree105e711c3f14415443874c01beac124d8e3d88d8 /app-doc
parentRemoving GStreamer 0.8. (diff)
downloadgentoo-2-026133078fc689b9c65a77174175bb5bbb8b6d90.tar.gz
gentoo-2-026133078fc689b9c65a77174175bb5bbb8b6d90.tar.bz2
gentoo-2-026133078fc689b9c65a77174175bb5bbb8b6d90.zip
Fix "argument list too long" error in image files installation, bug #193844.
(Portage version: 2.1.3.9)
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/gimp-help/ChangeLog7
-rw-r--r--app-doc/gimp-help/files/gimp-help-0.13-image-files.patch12
-rw-r--r--app-doc/gimp-help/gimp-help-0.13.ebuild13
3 files changed, 28 insertions, 4 deletions
diff --git a/app-doc/gimp-help/ChangeLog b/app-doc/gimp-help/ChangeLog
index f7519cb69b37..0fe14404085d 100644
--- a/app-doc/gimp-help/ChangeLog
+++ b/app-doc/gimp-help/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-doc/gimp-help
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/gimp-help/ChangeLog,v 1.39 2007/09/26 03:01:24 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/gimp-help/ChangeLog,v 1.40 2007/09/29 11:32:39 ulm Exp $
+
+ 29 Sep 2007; Ulrich Mueller <ulm@gentoo.org>
+ +files/gimp-help-0.13-image-files.patch, gimp-help-0.13.ebuild:
+ Fix "argument list too long" error in image files installation, bug #193844.
+ Remove "TODO" from dodoc since it no longer exists.
*gimp-help-0.13 (26 Sep 2007)
diff --git a/app-doc/gimp-help/files/gimp-help-0.13-image-files.patch b/app-doc/gimp-help/files/gimp-help-0.13-image-files.patch
new file mode 100644
index 000000000000..e9287c7dbb31
--- /dev/null
+++ b/app-doc/gimp-help/files/gimp-help-0.13-image-files.patch
@@ -0,0 +1,12 @@
+--- gimp-help-2-0.13-orig/Makefile.in 2007-07-25 11:23:30.000000000 +0200
++++ gimp-help-2-0.13/Makefile.in 2007-09-29 09:49:06.000000000 +0200
+@@ -627,7 +627,8 @@
+ @for dir in $(IMAGE_DIRS); do \
+ $(mkdir_p) "$(DESTDIR)$(helpdir)/$$dir" || exit; \
+ done
+- @for file in $(IMAGE_FILES); do \
++ @cd $(top_srcdir) && \
++ find images $(image_find_predicates) | while read file; do \
+ case "$$file" in \
+ *.gif) echo -n G ;; \
+ *.jpg) echo -n J ;; \
diff --git a/app-doc/gimp-help/gimp-help-0.13.ebuild b/app-doc/gimp-help/gimp-help-0.13.ebuild
index 23b433712eec..cd9c0db80f91 100644
--- a/app-doc/gimp-help/gimp-help-0.13.ebuild
+++ b/app-doc/gimp-help/gimp-help-0.13.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/gimp-help/gimp-help-0.13.ebuild,v 1.1 2007/09/26 03:01:24 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/gimp-help/gimp-help-0.13.ebuild,v 1.2 2007/09/29 11:32:39 ulm Exp $
+
+inherit eutils
MY_P=${P/gimp-help/gimp-help-2}
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
DESCRIPTION="GNU Image Manipulation Program help files"
HOMEPAGE="http://docs.gimp.org/"
@@ -20,6 +22,11 @@ DEPEND="=app-text/docbook-xml-dtd-4.3*
webinstall? ( media-gfx/imagemagick )"
RDEPEND="!<media-gfx/gimp-2.2.12"
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/${P}-image-files.patch"
+}
+
src_compile() {
local ALL_LINGUAS=""
@@ -50,5 +57,5 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog HACKING NEWS README TERMINOLOGY TODO
+ dodoc AUTHORS ChangeLog HACKING NEWS README TERMINOLOGY
}