summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-07-21 14:08:03 +0000
committerDan Armak <danarmak@gentoo.org>2002-07-21 14:08:03 +0000
commit12df13cbed7800acc31c56852b30c0154fde2ae0 (patch)
treecf0cf8da585cde1e15a5c2a91b561ff98e3d8b41 /app-doc
parentrepoman'd (diff)
downloadgentoo-2-12df13cbed7800acc31c56852b30c0154fde2ae0.tar.gz
gentoo-2-12df13cbed7800acc31c56852b30c0154fde2ae0.tar.bz2
gentoo-2-12df13cbed7800acc31c56852b30c0154fde2ae0.zip
new qt-docs to go with the qt 3.0.5 i'm unmasking
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/qt-docs/files/digest-qt-docs-3.0.51
-rw-r--r--app-doc/qt-docs/qt-docs-3.0.5.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-doc/qt-docs/files/digest-qt-docs-3.0.5 b/app-doc/qt-docs/files/digest-qt-docs-3.0.5
new file mode 100644
index 000000000000..5f44cde264ed
--- /dev/null
+++ b/app-doc/qt-docs/files/digest-qt-docs-3.0.5
@@ -0,0 +1 @@
+MD5 98dab506c55e50741e428c4cc43ac828 qt-x11-free-3.0.5.tar.gz 16057928
diff --git a/app-doc/qt-docs/qt-docs-3.0.5.ebuild b/app-doc/qt-docs/qt-docs-3.0.5.ebuild
new file mode 100644
index 000000000000..a3103bc35c3b
--- /dev/null
+++ b/app-doc/qt-docs/qt-docs-3.0.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-doc/qt-docs/qt-docs-3.0.5.ebuild,v 1.1 2002/07/21 14:08:03 danarmak Exp $
+
+S=${WORKDIR}/qt-x11-free-$PV
+SRC_URI="ftp://ftp.trolltech.com/qt/source/qt-x11-free-${PV}.tar.gz"
+HOMEPAGE="http://www.trolltech.com/"
+DESCRIPTION="Documentation for the QT ${PV} API"
+KEYWORDS="x86 sparc sparc64 ppc"
+SLOT="3"
+LICENSE="QPL-1.0"
+
+pkg_setup() {
+ QTBASE=/usr/qt/3
+ export QTDIR=${S}
+}
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ cd ${S}
+ # misc
+ insinto /etc/env.d
+ doins ${FILESDIR}/45qt-docs3
+
+ # docs
+ cd ${S}/doc
+ dodir ${QTBASE}/doc
+ for x in html flyers; do
+ cp -r $x ${D}/${QTBASE}/doc
+ done
+
+ # manpages
+ cp -r ${S}/doc/man ${D}/${QTBASE}
+ # examples
+ cp -r ${S}/examples ${D}/${QTBASE}
+ # tutorials
+ cp -r ${S}/tutorial ${D}/${QTBASE}
+
+}
+
+