summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-06-14 13:53:33 +0000
committerDan Armak <danarmak@gentoo.org>2002-06-14 13:53:33 +0000
commit15ba478954d015382786d9fbb3b575b0cd007b79 (patch)
treecc8ac5e07085c92779ebedefe427fb4163c779e9 /app-doc
parentcotinuing work on #2483 (diff)
downloadgentoo-2-15ba478954d015382786d9fbb3b575b0cd007b79.tar.gz
gentoo-2-15ba478954d015382786d9fbb3b575b0cd007b79.tar.bz2
gentoo-2-15ba478954d015382786d9fbb3b575b0cd007b79.zip
continuing #2483 work
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/wine-doc/ChangeLog9
-rw-r--r--app-doc/wine-doc/files/digest-wine-doc-200206051
-rw-r--r--app-doc/wine-doc/wine-doc-20020605.ebuild53
3 files changed, 63 insertions, 0 deletions
diff --git a/app-doc/wine-doc/ChangeLog b/app-doc/wine-doc/ChangeLog
new file mode 100644
index 000000000000..fe13c8b5c0ec
--- /dev/null
+++ b/app-doc/wine-doc/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-doc/wine-doc
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-doc/wine-doc/ChangeLog,v 1.1 2002/06/14 13:53:33 danarmak Exp $
+
+*wine-doc-20020605 (14 Jun 2002)
+
+ 14 Jun 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ First version - docs only (split from app-emulation/wine).
diff --git a/app-doc/wine-doc/files/digest-wine-doc-20020605 b/app-doc/wine-doc/files/digest-wine-doc-20020605
new file mode 100644
index 000000000000..70e8f9b2efd3
--- /dev/null
+++ b/app-doc/wine-doc/files/digest-wine-doc-20020605
@@ -0,0 +1 @@
+MD5 416ca5a002a3286953afc77bee20a9da Wine-20020605.tar.gz 7242801
diff --git a/app-doc/wine-doc/wine-doc-20020605.ebuild b/app-doc/wine-doc/wine-doc-20020605.ebuild
new file mode 100644
index 000000000000..ab44213d7562
--- /dev/null
+++ b/app-doc/wine-doc/wine-doc-20020605.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-doc/wine-doc/wine-doc-20020605.ebuild,v 1.1 2002/06/14 13:53:33 danarmak Exp $
+
+S=${WORKDIR}/wine-$PV
+DESCRIPTION="Wine is a free implementation of Windows on Unix."
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-${PV}.tar.gz"
+HOMEPAGE="http://www.winehq.com/"
+
+DEPEND=""
+
+src_compile() {
+
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+ # there's no configure flag for cups, it's supposed to be autodetected
+
+ # the folks at #winehq were really angry about custom optimization
+ export CFLAGS=""
+ export CXXFLAGS=""
+
+ ./configure --prefix=/usr \
+ --exec_prefix=/usr/wine \
+ --sysconfdir=/etc/wine \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --enable-curses \
+ ${myconf} || die
+
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ cd ${S}
+ make manpages || die
+
+}
+
+src_install () {
+
+ cd ${S}/documentation
+ DESTTREE=/usr/wine doman man3w/*
+ # sgml was being filtered without -a sgml
+ dohtml -a sgml *.sgml
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/80wine-doc
+}
+