summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWout Mertens <wmertens@gentoo.org>2002-06-02 22:41:06 +0000
committerWout Mertens <wmertens@gentoo.org>2002-06-02 22:41:06 +0000
commit1e01e9b3278d78b15ce7de3c28d34e20c870348e (patch)
treebc5a44504e3d945d7c8d4c0c0a383430c5ba62b4 /app-doc
parentpatch added to fix bug #3251 (diff)
downloadgentoo-2-1e01e9b3278d78b15ce7de3c28d34e20c870348e.tar.gz
gentoo-2-1e01e9b3278d78b15ce7de3c28d34e20c870348e.tar.bz2
gentoo-2-1e01e9b3278d78b15ce7de3c28d34e20c870348e.zip
See bug 3320. Didn't add SLOT=0 because I am unaware of the implications.
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/doxygen/ChangeLog9
-rw-r--r--app-doc/doxygen/doxygen-1.2.15-r1.ebuild26
2 files changed, 22 insertions, 13 deletions
diff --git a/app-doc/doxygen/ChangeLog b/app-doc/doxygen/ChangeLog
index fad7bdd46749..142c22e720cb 100644
--- a/app-doc/doxygen/ChangeLog
+++ b/app-doc/doxygen/ChangeLog
@@ -1,9 +1,16 @@
# ChangeLog for app-doc/doxygen
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.3 2002/05/11 15:58:09 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.4 2002/06/02 22:41:06 wmertens Exp $
*doxygen-1.2.15-r1 (11 May 2002)
+ 02 Jun 2002; Wout Mertens <wmertens@gentoo.org>:
+ Changed ebuild to depend on graphvis as per bug #3320.
+ While I was at it, changed it so lintool was happy. Therefore, the Author
+ field was removed, and copied to here:
+ Author Sean Mitchell <sean@arawak.on.ca>, updated Tom von Schwerdtner
+ <tvon@etria.org>
+
11 May 2002; pvdabeel <pvdabeel@gentoo.org> ChangeLog :
Doxygen compiles and runs perfectly with qt3 too. Both qt2 and qt3
are supported by the ebuild now
diff --git a/app-doc/doxygen/doxygen-1.2.15-r1.ebuild b/app-doc/doxygen/doxygen-1.2.15-r1.ebuild
index 3fccbb2b5b60..a71c2c4031ec 100644
--- a/app-doc/doxygen/doxygen-1.2.15-r1.ebuild
+++ b/app-doc/doxygen/doxygen-1.2.15-r1.ebuild
@@ -1,15 +1,17 @@
# Copyright 2001-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Sean Mitchell <sean@arawak.on.ca>, updated Tom von Schwerdtner <tvon@etria.org>
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.2.15-r1.ebuild,v 1.1 2002/05/11 15:58:09 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.2.15-r1.ebuild,v 1.2 2002/06/02 22:41:06 wmertens Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Doxygen is a documentation system for C++, Java, IDL (Corba, Microsoft and KDE-DCOP flavors) and C"
-
-SRC_URI="ftp://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz"
HOMEPAGE="http://www.doxygen.org"
+LICENSE=GPL-2
-DEPEND="qt? ( =x11-libs/qt-* )"
+RDEPEND="qt? ( =x11-libs/qt-* )
+ media-gfx/graphviz"
+DEPEND="$RDEPEND"
+
+S=${WORKDIR}/${P}
+SRC_URI="ftp://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz"
src_unpack() {
@@ -22,17 +24,17 @@ src_unpack() {
src_compile()
{
- use qt && CONFIGURE_OPTIONS="--with-doxywizard"
-
- ./configure --install install --prefix ${D}/usr ${CONFIGURE_OPTIONS} || die
- make all || die
+ use qt && CONFIGURE_OPTIONS="--with-doxywizard"
+
+ ./configure --install install --prefix ${D}/usr ${CONFIGURE_OPTIONS} || die
+ make all || die
}
src_install()
{
- make install || die
- dodoc README VERSION LICENSE LANGUAGE.HOWTO PLATFORMS
+ make install || die
+ dodoc README VERSION LICENSE LANGUAGE.HOWTO PLATFORMS
}