summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-07-29 17:42:33 +0000
committerTilman Klar <phoenix@gentoo.org>2002-07-29 17:42:33 +0000
commit7218b18739465ee04f33822eb16721117d874ae9 (patch)
treedef22410b3725d2133af25b2cafbb5a0f25a5a57 /app-doc
parentMasked new wine-doc (diff)
downloadgentoo-2-7218b18739465ee04f33822eb16721117d874ae9.tar.gz
gentoo-2-7218b18739465ee04f33822eb16721117d874ae9.tar.bz2
gentoo-2-7218b18739465ee04f33822eb16721117d874ae9.zip
Bumped to new version
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/wine-doc/ChangeLog11
-rw-r--r--app-doc/wine-doc/files/digest-wine-doc-200207101
-rw-r--r--app-doc/wine-doc/wine-doc-20020605.ebuild5
-rw-r--r--app-doc/wine-doc/wine-doc-20020710.ebuild55
4 files changed, 69 insertions, 3 deletions
diff --git a/app-doc/wine-doc/ChangeLog b/app-doc/wine-doc/ChangeLog
index fe13c8b5c0ec..a40f030fe37c 100644
--- a/app-doc/wine-doc/ChangeLog
+++ b/app-doc/wine-doc/ChangeLog
@@ -1,9 +1,16 @@
# ChangeLog for app-doc/wine-doc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-doc/wine-doc/ChangeLog,v 1.1 2002/06/14 13:53:33 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/wine-doc/ChangeLog,v 1.2 2002/07/29 17:42:33 phoenix Exp $
+
+*wine-doc-20020710 (29 Jul 2002)
+
+ 29 Jul 2002; phoen][x <phoenix@gentoo.org> wine-doc-20020710.ebuild :
+ Bumped to new version. This closes bug #4863.
*wine-doc-20020605 (14 Jun 2002)
- 14 Jun 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+ 29 Jul 2002; phoen][x <phoenix@gentoo.org> wine-doc-20020605.ebuild :
+ Added KEYWORDS, LICENSE, SLOT.
+ 14 Jun 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
First version - docs only (split from app-emulation/wine).
diff --git a/app-doc/wine-doc/files/digest-wine-doc-20020710 b/app-doc/wine-doc/files/digest-wine-doc-20020710
new file mode 100644
index 000000000000..29b97f441901
--- /dev/null
+++ b/app-doc/wine-doc/files/digest-wine-doc-20020710
@@ -0,0 +1 @@
+MD5 51cb48fbebd4d61b01d7cbb95de33d4c Wine-20020710.tar.gz 7371859
diff --git a/app-doc/wine-doc/wine-doc-20020605.ebuild b/app-doc/wine-doc/wine-doc-20020605.ebuild
index 4022167ca693..f1b6d8611d80 100644
--- a/app-doc/wine-doc/wine-doc-20020605.ebuild
+++ b/app-doc/wine-doc/wine-doc-20020605.ebuild
@@ -1,11 +1,14 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/wine-doc/wine-doc-20020605.ebuild,v 1.2 2002/07/11 06:30:11 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/wine-doc/wine-doc-20020605.ebuild,v 1.3 2002/07/29 17:42:33 phoenix Exp $
S=${WORKDIR}/wine-$PV
DESCRIPTION="Wine is a free implementation of Windows on Unix."
SRC_URI="ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-${PV}.tar.gz"
HOMEPAGE="http://www.winehq.com/"
+SLOT="0"
+KEYWORDS="x86"
+LICENSE="LGPL-2.1"
DEPEND=""
diff --git a/app-doc/wine-doc/wine-doc-20020710.ebuild b/app-doc/wine-doc/wine-doc-20020710.ebuild
new file mode 100644
index 000000000000..b796e6e576be
--- /dev/null
+++ b/app-doc/wine-doc/wine-doc-20020710.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/wine-doc/wine-doc-20020710.ebuild,v 1.1 2002/07/29 17:42:33 phoenix Exp $
+
+S=${WORKDIR}/wine-$PV
+DESCRIPTION="Wine is a free implementation of Windows on Unix."
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-${PV}.tar.gz"
+HOMEPAGE="http://www.winehq.com/"
+LICENSE="LPGL-2.1"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=""
+
+src_compile() {
+
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+ # there's no configure flag for cups, it's supposed to be autodetected
+
+ # the folks at #winehq were really angry about custom optimization
+ export CFLAGS=""
+ export CXXFLAGS=""
+
+ ./configure --prefix=/usr \
+ --exec_prefix=/usr/wine \
+ --sysconfdir=/etc/wine \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --enable-curses \
+ ${myconf} || die
+
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ cd ${S}
+ make manpages || die
+
+}
+
+src_install () {
+
+ cd ${S}/documentation
+ DESTTREE=/usr/wine doman man3w/*
+ # sgml was being filtered without -a sgml
+ dohtml -a sgml *.sgml
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/80wine-doc
+}
+