summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-02-10 11:47:38 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-02-10 11:47:38 +0000
commita4ea16e1a45853640788aae95f8e6e128abedc93 (patch)
treea63d4209e6640667f228201bbef6bfbcfd9cbee8 /app-editors/bluefish
parentIntroduce cmake-utils wrapper eclass for multilib. (diff)
downloadgentoo-2-a4ea16e1a45853640788aae95f8e6e128abedc93.tar.gz
gentoo-2-a4ea16e1a45853640788aae95f8e6e128abedc93.tar.bz2
gentoo-2-a4ea16e1a45853640788aae95f8e6e128abedc93.zip
Version bump to 2.2.3. Fixes bug#433123.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'app-editors/bluefish')
-rw-r--r--app-editors/bluefish/ChangeLog10
-rw-r--r--app-editors/bluefish/bluefish-1.0.7.ebuild48
-rw-r--r--app-editors/bluefish/bluefish-2.2.3.ebuild91
3 files changed, 99 insertions, 50 deletions
diff --git a/app-editors/bluefish/ChangeLog b/app-editors/bluefish/ChangeLog
index aa9ad61ccdd6..5638a8eb348d 100644
--- a/app-editors/bluefish/ChangeLog
+++ b/app-editors/bluefish/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/bluefish
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.88 2012/07/29 16:41:52 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.89 2013/02/10 11:47:38 scarabeus Exp $
+
+*bluefish-2.2.3 (10 Feb 2013)
+
+ 10 Feb 2013; Tomáš Chvátal <scarabeus@gentoo.org> +bluefish-2.2.3.ebuild,
+ -bluefish-1.0.7.ebuild:
+ Version bump to 2.2.3. Fixes bug#433123.
29 Jul 2012; Raúl Porcel <armin76@gentoo.org> bluefish-2.2.2.ebuild:
alpha/ia64/sparc stable wrt #408189
diff --git a/app-editors/bluefish/bluefish-1.0.7.ebuild b/app-editors/bluefish/bluefish-1.0.7.ebuild
deleted file mode 100644
index dd3b15eb597c..000000000000
--- a/app-editors/bluefish/bluefish-1.0.7.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-1.0.7.ebuild,v 1.8 2012/05/03 18:33:02 jdhore Exp $
-
-EAPI=1
-inherit eutils fdo-mime
-
-IUSE="nls spell gnome"
-
-DESCRIPTION="A GTK HTML editor for the experienced web designer or programmer."
-SRC_URI="http://www.bennewitz.com/bluefish/stable/source/${P}.tar.bz2"
-HOMEPAGE="http://bluefish.openoffice.nl/"
-
-LICENSE="GPL-2"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
-SLOT="0"
-
-RDEPEND="x11-libs/gtk+:2
- dev-libs/libpcre
- spell? ( app-text/aspell )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
- gnome? ( gnome-base/libgnomeui )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- sed -i -e 's/-s -m 755/-m 755/g' src/Makefile.in
-}
-
-src_compile() {
- econf --disable-update-databases \
- `use_enable nls` \
- `use_with gnome libgnomeui` || die
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
-}
diff --git a/app-editors/bluefish/bluefish-2.2.3.ebuild b/app-editors/bluefish/bluefish-2.2.3.ebuild
new file mode 100644
index 000000000000..f2eb2049ed6c
--- /dev/null
+++ b/app-editors/bluefish/bluefish-2.2.3.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-2.2.3.ebuild,v 1.1 2013/02/10 11:47:38 scarabeus Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2"
+
+inherit eutils fdo-mime python
+
+MY_P=${P/_/-}
+
+DESCRIPTION="A GTK HTML editor for the experienced web designer or programmer."
+SRC_URI="http://www.bennewitz.com/bluefish/stable/source/${MY_P}.tar.bz2"
+HOMEPAGE="http://bluefish.openoffice.nl/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="nls python spell"
+
+RDEPEND="
+ x11-libs/gtk+:3
+ gnome-extra/gucharmap:2.90
+ sys-libs/zlib
+ spell? ( app-text/enchant )"
+DEPEND="${RDEPEND}
+ >=dev-libs/glib-2.16:2
+ dev-libs/libxml2:2
+ virtual/pkgconfig
+ x11-libs/pango
+ nls? (
+ sys-devel/gettext
+ dev-util/intltool
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+# there actually is just some broken manpage checkup -> not bother
+RESTRICT="test"
+
+pkg_setup() {
+ if use python ; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+# Never eautoreconf this package as gettext breaks completely (no translations
+# even if it compiles afterwards)!
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --disable-dependency-tracking \
+ --disable-update-databases \
+ --disable-xml-catalog-update \
+ $(use_enable nls) \
+ $(use_enable spell spell-check) \
+ $(use_enable python)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+
+ einfo "Adding XML catalog entries..."
+ /usr/bin/xmlcatalog --noout \
+ --add 'public' 'Bluefish/DTD/Bflang' 'bflang.dtd' \
+ --add 'system' 'http://bluefish.openoffice.nl/DTD/bflang.dtd' 'bflang.dtd' \
+ --add 'rewriteURI' 'http://bluefish.openoffice.nl/DTD' '/usr/share/xml/bluefish-unstable' \
+ /etc/xml/catalog \
+ || ewarn "Failed to add XML catalog entries."
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ einfo "Removing XML catalog entries..."
+ /usr/bin/xmlcatalog --noout \
+ --del 'Bluefish/DTD/Bflang' \
+ --del 'http://bluefish.openoffice.nl/DTD/bflang.dtd' \
+ --del 'http://bluefish.openoffice.nl/DTD' \
+ /etc/xml/catalog \
+ || ewarn "Failed to remove XML catalog entries."
+}