summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-06-15 08:53:21 +0000
committerUlrich Müller <ulm@gentoo.org>2007-06-15 08:53:21 +0000
commitf45e7987a0ea3553ec8c279c73e0f31df3e59f1a (patch)
treec7459765fd0b37f80e9ab297dbcd3aba24e8c984 /app-editors/ersatz-emacs/ersatz-emacs-20060515.ebuild
parentInitial import sci-chemistry/jmol. (diff)
downloadgentoo-2-f45e7987a0ea3553ec8c279c73e0f31df3e59f1a.tar.gz
gentoo-2-f45e7987a0ea3553ec8c279c73e0f31df3e59f1a.tar.bz2
gentoo-2-f45e7987a0ea3553ec8c279c73e0f31df3e59f1a.zip
Initial import.
(Portage version: 2.1.2.9)
Diffstat (limited to 'app-editors/ersatz-emacs/ersatz-emacs-20060515.ebuild')
-rw-r--r--app-editors/ersatz-emacs/ersatz-emacs-20060515.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-editors/ersatz-emacs/ersatz-emacs-20060515.ebuild b/app-editors/ersatz-emacs/ersatz-emacs-20060515.ebuild
new file mode 100644
index 000000000000..e216dd2aaae3
--- /dev/null
+++ b/app-editors/ersatz-emacs/ersatz-emacs-20060515.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ersatz-emacs/ersatz-emacs-20060515.ebuild,v 1.1 2007/06/15 08:53:21 ulm Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A very minimal imitation of the famous GNU Emacs editor"
+HOMEPAGE="http://hunter.apana.org.au/~cjb/Code/"
+# taken from http://hunter.apana.org.au/~cjb/Code/ersatz.tar.gz
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+PROVIDE="virtual/editor"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i -e "s%/usr/local/share/%/usr/share/doc/${PF}/%" ee.1 \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="-Wall ${CFLAGS}" \
+ LFLAGS="-lncurses" || die "emake failed"
+}
+
+src_install() {
+ dobin ee
+ doman ee.1
+ dodoc ChangeLog ERSATZ.keys README || die "dodoc failed"
+}