summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-03-17 14:32:50 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-03-17 14:32:50 +0000
commit65f3ebf563d5101e4dfa7762694749f49577e82d (patch)
tree17b38b8f86b58c1ef2942ffe64dbf2520abcc151 /app-editors/fte/fte-20020324-r2.ebuild
parentFixing bug #42037 (Manifest recommit) (diff)
downloadgentoo-2-65f3ebf563d5101e4dfa7762694749f49577e82d.tar.gz
gentoo-2-65f3ebf563d5101e4dfa7762694749f49577e82d.tar.bz2
gentoo-2-65f3ebf563d5101e4dfa7762694749f49577e82d.zip
Fixing bug #21352
Diffstat (limited to 'app-editors/fte/fte-20020324-r2.ebuild')
-rw-r--r--app-editors/fte/fte-20020324-r2.ebuild93
1 files changed, 93 insertions, 0 deletions
diff --git a/app-editors/fte/fte-20020324-r2.ebuild b/app-editors/fte/fte-20020324-r2.ebuild
new file mode 100644
index 000000000000..cb4aad0b511f
--- /dev/null
+++ b/app-editors/fte/fte-20020324-r2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20020324-r2.ebuild,v 1.1 2004/03/17 14:32:49 phosphan Exp $
+
+inherit eutils
+
+IUSE="gpm slang X"
+
+DESCRIPTION="Lightweight text-mode editor"
+SRC_URI="mirror://sourceforge/fte/${P}-src.zip
+ mirror://sourceforge/fte/${P}-common.zip"
+HOMEPAGE="http://fte.sourceforge.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ gpm? ( >=sys-libs/gpm-1.20 )"
+
+DEPEND="${RDEPEND}
+ slang? ( sys-libs/slang )
+ app-arch/unzip
+ X? ( virtual/x11 )"
+
+TARGETS=""
+
+if [ "`use slang`" ] ; then
+ TARGETS="${TARGETS} sfte"
+fi
+
+if [ "`use X`" ] ; then
+ TARGETS="${TARGETS} xfte"
+fi
+
+if [ "`use gpm`" ] ; then
+ TARGETS="${TARGETS} vfte"
+fi
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack fte-20020324-src.zip
+ unpack fte-20020324-common.zip
+
+ mv fte fte-20020324
+
+ cd ${S}
+
+ epatch ${FILESDIR}/configpath.patch
+
+ sed \
+ -e "s:@targets@:${TARGETS}:" \
+ -e "s:@cflags@:${CFLAGS}:" \
+ -i src/fte-unix.mak
+}
+
+src_compile() {
+ DEFFLAGS="PREFIX=/usr CONFIGDIR=/usr/share/fte \
+ DEFAULT_FTE_CONFIG=../config/main.fte OPTIMIZE="
+
+ emake $DEFFLAGS TARGETS="$TARGETS" all || die
+}
+
+src_install () {
+ local files
+ into /usr
+
+ files="${TARGETS} cfte compkeys"
+
+ for i in ${files} ; do
+ dobin src/$i ;
+ done
+
+ dobin ${FILESDIR}/fte
+
+ dodoc Artistic CHANGES BUGS COPYING HISTORY README TODO
+
+ keepdir etc/fte
+
+ dodir usr/share/doc/${P}/html
+ cp doc/INDEX doc/*.html ${D}/usr/share/doc/${P}/html
+
+ dodir usr/share/fte
+ cp -R config/* ${D}/usr/share/fte
+ rm -rf ${D}/usr/share/fte/CVS
+}
+
+pkg_postinst() {
+ einfo "Compiling configuration..."
+ cd /usr/share/fte
+ /usr/bin/cfte main.fte /etc/fte/system.fterc
+}