summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2006-12-10 13:55:11 +0000
committerRyan Hill <dirtyepic@gentoo.org>2006-12-10 13:55:11 +0000
commit346ed34ef9d0a63eb5d84b863939701903ffdcd7 (patch)
treed207cdf2705a2b63931e55974c1001767af5e08b /app-editors/geresh/geresh-0.4.1.ebuild
parentChanged perl-core to virtual (diff)
downloadgentoo-2-346ed34ef9d0a63eb5d84b863939701903ffdcd7.tar.gz
gentoo-2-346ed34ef9d0a63eb5d84b863939701903ffdcd7.tar.bz2
gentoo-2-346ed34ef9d0a63eb5d84b863939701903ffdcd7.zip
Fix building with GCC 4.1. Bug #149758.
(Portage version: 2.1.2_rc3)
Diffstat (limited to 'app-editors/geresh/geresh-0.4.1.ebuild')
-rw-r--r--app-editors/geresh/geresh-0.4.1.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/app-editors/geresh/geresh-0.4.1.ebuild b/app-editors/geresh/geresh-0.4.1.ebuild
index 91be8cdbd5f0..357ac0c3d79d 100644
--- a/app-editors/geresh/geresh-0.4.1.ebuild
+++ b/app-editors/geresh/geresh-0.4.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/geresh/geresh-0.4.1.ebuild,v 1.8 2005/07/08 16:02:53 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/geresh/geresh-0.4.1.ebuild,v 1.9 2006/12/10 13:55:11 dirtyepic Exp $
+
+inherit eutils
DESCRIPTION="A simple multi-lingual console text editor with bidi & utf support"
HOMEPAGE="http://www.typo.co.il/~mooffie/geresh/"
@@ -18,6 +20,14 @@ DEPEND="dev-libs/fribidi
virtual/aspell-dict
)"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Bug #149758
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+}
+
src_install() {
make install DESTDIR="${D}" || die
}