summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2009-04-08 19:56:27 +0000
committerTiziano Müller <dev-zero@gentoo.org>2009-04-08 19:56:27 +0000
commit3d3458d279e32421c9fdbee1d5434d70301dbe02 (patch)
tree794fa17b479575904486c95a00249c4cd67071c9 /app-editors/gobby
parentInitial commit (ebuild written by me) for new version of gobby. (diff)
downloadgentoo-2-3d3458d279e32421c9fdbee1d5434d70301dbe02.tar.gz
gentoo-2-3d3458d279e32421c9fdbee1d5434d70301dbe02.tar.bz2
gentoo-2-3d3458d279e32421c9fdbee1d5434d70301dbe02.zip
Version bump (including p.masked pre-release). Dropped old.
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/gobby')
-rw-r--r--app-editors/gobby/ChangeLog9
-rw-r--r--app-editors/gobby/gobby-0.4.10.ebuild (renamed from app-editors/gobby/gobby-0.4.5.ebuild)28
-rw-r--r--app-editors/gobby/gobby-0.4.91.ebuild37
3 files changed, 57 insertions, 17 deletions
diff --git a/app-editors/gobby/ChangeLog b/app-editors/gobby/ChangeLog
index 045c8a281dbf..7be3e4ffae79 100644
--- a/app-editors/gobby/ChangeLog
+++ b/app-editors/gobby/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/gobby
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/ChangeLog,v 1.30 2009/03/08 22:02:42 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/ChangeLog,v 1.31 2009/04/08 19:56:27 dev-zero Exp $
+
+*gobby-0.4.91 (08 Apr 2009)
+*gobby-0.4.10 (08 Apr 2009)
+
+ 08 Apr 2009; Tiziano Müller <dev-zero@gentoo.org> -gobby-0.4.5.ebuild,
+ +gobby-0.4.10.ebuild, +gobby-0.4.91.ebuild:
+ Version bump (including p.masked pre-release). Dropped old.
08 Mar 2009; Markus Meier <maekke@gentoo.org> gobby-0.4.8.ebuild:
amd64/x86 stable, bug #225519
diff --git a/app-editors/gobby/gobby-0.4.5.ebuild b/app-editors/gobby/gobby-0.4.10.ebuild
index 0576cb5f47be..8eed892e7c50 100644
--- a/app-editors/gobby/gobby-0.4.5.ebuild
+++ b/app-editors/gobby/gobby-0.4.10.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/gobby-0.4.5.ebuild,v 1.8 2009/03/07 22:13:02 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/gobby-0.4.10.ebuild,v 1.1 2009/04/08 19:56:27 dev-zero Exp $
-EAPI=2
+EAPI="2"
inherit base eutils
@@ -11,16 +11,15 @@ HOMEPAGE="http://gobby.0x539.de/"
SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ppc x86"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
IUSE="avahi gnome"
-RDEPEND=">=dev-cpp/glibmm-2.6
- >=dev-cpp/gtkmm-2.6
- >=dev-libs/libsigc++-2.0
- >=net-libs/obby-0.4.4
- >=dev-cpp/libxmlpp-2.6
- x11-libs/gtksourceview:1.0
- avahi? ( >=net-libs/obby-0.4.4[avahi] )
+RDEPEND="dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ dev-libs/libsigc++:2
+ >=net-libs/obby-0.4.6[avahi?]
+ dev-cpp/libxmlpp:2.6
+ x11-libs/gtksourceview:2.0
gnome? ( gnome-base/gnome-vfs )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
@@ -28,13 +27,10 @@ DEPEND="${RDEPEND}
# There's only one test and it needs X
RESTRICT="test"
-PATCHES=( "${FILESDIR}/${PN}-0.4.5-gcc43.patch" )
-
-src_compile() {
+src_configure() {
econf \
- $(use_with gnome) \
- || die "econf failed"
- emake || die "make failed"
+ --with-gtksourceview2 \
+ $(use_with gnome)
}
src_install() {
diff --git a/app-editors/gobby/gobby-0.4.91.ebuild b/app-editors/gobby/gobby-0.4.91.ebuild
new file mode 100644
index 000000000000..b64bf719b034
--- /dev/null
+++ b/app-editors/gobby/gobby-0.4.91.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/gobby-0.4.91.ebuild,v 1.1 2009/04/08 19:56:27 dev-zero Exp $
+
+EAPI="2"
+
+inherit base eutils
+
+DESCRIPTION="GTK-based collaborative editor"
+HOMEPAGE="http://gobby.0x539.de/"
+SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0.5"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="avahi gnome"
+
+RDEPEND="dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ dev-libs/libsigc++:2
+ >=net-libs/libinfinity-0.2[gtk,avahi?]
+ dev-cpp/libxmlpp:2.6
+ x11-libs/gtksourceview:2.0
+ gnome? ( gnome-base/gnome-vfs )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+# There's only one test and it needs X
+RESTRICT="test"
+
+src_configure() {
+ econf $(use_with gnome)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ domenu contrib/gobby-0.5.desktop
+}