summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2008-11-07 19:05:56 +0000
committerGustavo Felisberto <humpback@gentoo.org>2008-11-07 19:05:56 +0000
commit8d2794daab9e07b380a95eaa0d26750561eb0d4c (patch)
tree09f002e4a012c8d4dfd9f4cc1c0bc65e8bfc6762 /app-editors/gobby
parentbump (diff)
downloadgentoo-2-8d2794daab9e07b380a95eaa0d26750561eb0d4c.tar.gz
gentoo-2-8d2794daab9e07b380a95eaa0d26750561eb0d4c.tar.bz2
gentoo-2-8d2794daab9e07b380a95eaa0d26750561eb0d4c.zip
bump
(Portage version: 2.2_rc11/cvs/Linux 2.6.27-gentoo-r1 i686)
Diffstat (limited to 'app-editors/gobby')
-rw-r--r--app-editors/gobby/ChangeLog7
-rw-r--r--app-editors/gobby/gobby-0.4.8.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/app-editors/gobby/ChangeLog b/app-editors/gobby/ChangeLog
index d638156d59a8..daeacff1d5e6 100644
--- a/app-editors/gobby/ChangeLog
+++ b/app-editors/gobby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/gobby
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/ChangeLog,v 1.24 2008/07/27 13:26:50 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/ChangeLog,v 1.25 2008/11/07 19:05:56 humpback Exp $
+
+*gobby-0.4.8 (07 Nov 2008)
+
+ 07 Nov 2008; Gustavo Felisberto <humpback@gentoo.org> +gobby-0.4.8.ebuild:
+ Bump
*gobby-0.4.6 (27 Jul 2008)
diff --git a/app-editors/gobby/gobby-0.4.8.ebuild b/app-editors/gobby/gobby-0.4.8.ebuild
new file mode 100644
index 000000000000..a8e8c17acb02
--- /dev/null
+++ b/app-editors/gobby/gobby-0.4.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/gobby-0.4.8.ebuild,v 1.1 2008/11/07 19:05:56 humpback Exp $
+
+EAPI=1
+
+inherit base eutils
+
+DESCRIPTION="GTK-based collaborative editor"
+HOMEPAGE="http://gobby.0x539.de/"
+SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="avahi gnome"
+
+RDEPEND=">=dev-cpp/glibmm-2.6
+ >=dev-cpp/gtkmm-2.6
+ >=dev-libs/libsigc++-2.0
+ >=net-libs/obby-0.4.6
+ >=dev-cpp/libxmlpp-2.6
+ x11-libs/gtksourceview:2.0
+ gnome? ( gnome-base/gnome-vfs )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+# There's only one test and it needs X
+RESTRICT="test"
+
+
+pkg_setup() {
+ if use avahi && ! built_with_use net-libs/obby avahi ; then
+ eerror "Please reinstall net-libs/obby with the avahi USE-flag enabled"
+ eerror "for zeroconf/DNS-SD support or disable it for this package."
+ die "Missing 'avahi' USE-flag for net-libs/obby"
+ fi
+}
+
+src_compile() {
+ econf \
+ --with-gtksourceview2 \
+ $(use_with gnome) \
+ || die "econf failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ domenu contrib/gobby.desktop
+}