summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-12-08 20:21:10 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-12-08 20:21:10 +0000
commitcfa0760fa30b6861f7e2ad0e750a3df29302b8e0 (patch)
tree97db8bfa0ef80aa039a9c586e6e08b3e6964673e /app-editors/gummi
parentVersion bump: 7.3.75 is released (diff)
downloadgentoo-2-cfa0760fa30b6861f7e2ad0e750a3df29302b8e0.tar.gz
gentoo-2-cfa0760fa30b6861f7e2ad0e750a3df29302b8e0.tar.bz2
gentoo-2-cfa0760fa30b6861f7e2ad0e750a3df29302b8e0.zip
Version bump. Thanks to Alexander van der Mey <alexvandermey@gmail.com>
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/gummi')
-rw-r--r--app-editors/gummi/ChangeLog7
-rw-r--r--app-editors/gummi/gummi-0.5.4.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/app-editors/gummi/ChangeLog b/app-editors/gummi/ChangeLog
index 9dc52ea7b54c..d1595900e31f 100644
--- a/app-editors/gummi/ChangeLog
+++ b/app-editors/gummi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/gummi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gummi/ChangeLog,v 1.11 2010/11/28 17:23:41 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gummi/ChangeLog,v 1.12 2010/12/08 20:21:10 hwoarang Exp $
+
+*gummi-0.5.4 (08 Dec 2010)
+
+ 08 Dec 2010; Markos Chandras <hwoarang@gentoo.org> +gummi-0.5.4.ebuild:
+ Version bump. Thanks to Alexander van der Mey <alexvandermey@gmail.com>
28 Nov 2010; Markus Meier <maekke@gentoo.org> gummi-0.5.3.ebuild:
x86 stable, bug #346677
diff --git a/app-editors/gummi/gummi-0.5.4.ebuild b/app-editors/gummi/gummi-0.5.4.ebuild
new file mode 100644
index 000000000000..5a79d15b8795
--- /dev/null
+++ b/app-editors/gummi/gummi-0.5.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gummi/gummi-0.5.4.ebuild,v 1.1 2010/12/08 20:21:10 hwoarang Exp $
+
+EAPI=2
+inherit base eutils
+
+DESCRIPTION="Simple LaTeX editor for GTK+ users"
+HOMEPAGE="http://gummi.midnightcoding.org"
+SRC_URI="http://dev.midnightcoding.org/redmine/attachments/download/110/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+LANGS="ca da de fr el es it nl pl pt_BR ro ru zh_TW"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND="app-text/gtkspell
+ >=dev-libs/glib-2.16:2
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ >=x11-libs/gtk+-2.16:2
+ x11-libs/gtksourceview"
+DEPEND="${RDEPEND}
+ app-text/poppler[cairo]
+ x11-libs/gtksourceview:2.0
+ x11-libs/pango"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_prepare() {
+ strip-linguas ${LANGS}
+}
+
+pkg_postinst() {
+ elog "Gummi >=0.4.8 supports spell-checking through gtkspell. Support for"
+ elog "additional languages can be added by installing myspell-** packages"
+ elog "for your language of choice."
+}