summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Kelly <pioto@gentoo.org>2007-05-14 10:16:15 +0000
committerMike Kelly <pioto@gentoo.org>2007-05-14 10:16:15 +0000
commite2a29160f9b1a9793544b10cd96f4affbcf0215c (patch)
tree91bf10d6c2853881d0e34e3f35a6a3c1ee91b819 /app-editors/gvim
parentRevision bump. Add a patch to fix the patch to fix the libintl compile error ... (diff)
downloadgentoo-2-e2a29160f9b1a9793544b10cd96f4affbcf0215c.tar.gz
gentoo-2-e2a29160f9b1a9793544b10cd96f4affbcf0215c.tar.bz2
gentoo-2-e2a29160f9b1a9793544b10cd96f4affbcf0215c.zip
Revision bump. Add a patch to fix the patch to fix the libintl compile error from Bug #176566.
(Portage version: 2.1.2.7)
Diffstat (limited to 'app-editors/gvim')
-rw-r--r--app-editors/gvim/ChangeLog8
-rw-r--r--app-editors/gvim/files/digest-gvim-7.1-r16
-rw-r--r--app-editors/gvim/gvim-7.1-r1.ebuild43
3 files changed, 56 insertions, 1 deletions
diff --git a/app-editors/gvim/ChangeLog b/app-editors/gvim/ChangeLog
index 10f04e3346dc..9bbbb75b6e9d 100644
--- a/app-editors/gvim/ChangeLog
+++ b/app-editors/gvim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/gvim
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.237 2007/05/13 13:32:03 pioto Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.238 2007/05/14 10:16:15 pioto Exp $
+
+*gvim-7.1-r1 (14 May 2007)
+
+ 14 May 2007; Mike Kelly <pioto@gentoo.org> +gvim-7.1-r1.ebuild:
+ Revision bump. Add a patch to fix the patch to fix the libintl compile error
+ from Bug #176566.
13 May 2007; Mike Kelly <pioto@gentoo.org> -gvim-7.0.17.ebuild:
Remove old version.
diff --git a/app-editors/gvim/files/digest-gvim-7.1-r1 b/app-editors/gvim/files/digest-gvim-7.1-r1
new file mode 100644
index 000000000000..d43ca7f738ba
--- /dev/null
+++ b/app-editors/gvim/files/digest-gvim-7.1-r1
@@ -0,0 +1,6 @@
+MD5 7a8e328ec3c925484d691dd2a4195f97 vim-7.1-gentoo-patches-r1.tar.bz2 6456
+RMD160 62a1d79fd5725c31bd2afa9762d10a36c730494c vim-7.1-gentoo-patches-r1.tar.bz2 6456
+SHA256 56f856055b9b9515f2922909e00924460d4d5b636c20a2d1feae8ca59eb3f063 vim-7.1-gentoo-patches-r1.tar.bz2 6456
+MD5 44c6b4914f38d6f9aa959640b89da329 vim-7.1.tar.bz2 6876053
+RMD160 470775e0d0219cafe7e04dd91199ed7441882456 vim-7.1.tar.bz2 6876053
+SHA256 7f0a5195db1981806090a46aa962f980edc68eba72ca5cfc8287aff612f1cf70 vim-7.1.tar.bz2 6876053
diff --git a/app-editors/gvim/gvim-7.1-r1.ebuild b/app-editors/gvim/gvim-7.1-r1.ebuild
new file mode 100644
index 000000000000..aa3d206cc253
--- /dev/null
+++ b/app-editors/gvim/gvim-7.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-7.1-r1.ebuild,v 1.1 2007/05/14 10:16:15 pioto Exp $
+
+inherit vim
+
+VIM_VERSION="7.1"
+VIM_GENTOO_PATCHES="vim-${VIM_VERSION}-gentoo-patches-r1.tar.bz2"
+#VIM_ORG_PATCHES="vim-patches-${PV}.tar.gz"
+GVIMRC_FILE_SUFFIX="-r1"
+
+SRC_URI="ftp://ftp.vim.org/pub/vim/unstable/unix/vim-${VIM_VERSION}.tar.bz2
+ mirror://gentoo/${VIM_GENTOO_PATCHES}"
+ #mirror://gentoo/${VIM_ORG_PATCHES}
+
+S="${WORKDIR}/vim${VIM_VERSION/.}"
+DESCRIPTION="GUI version of the Vim text editor"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="aqua gnome gtk motif nextaw"
+PROVIDE="virtual/editor"
+DEPEND="${DEPEND}
+ ~app-editors/vim-core-${PV}
+ || ( x11-libs/libXext virtual/x11 )
+ !aqua? (
+ gtk? (
+ >=x11-libs/gtk+-2.6
+ virtual/xft
+ gnome? ( >=gnome-base/libgnomeui-2.6 )
+ )
+ !gtk? (
+ motif? (
+ x11-libs/openmotif
+ )
+ !motif? (
+ nextaw? (
+ x11-libs/neXtaw
+ )
+ !nextaw? (
+ || ( x11-libs/libXaw virtual/x11 )
+ )
+ )
+ )
+ )"