summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-10-29 10:36:45 +0000
committerBen de Groot <yngwin@gentoo.org>2012-10-29 10:36:45 +0000
commit4efcf587d3cebaed810b0d702640eb786a71392a (patch)
tree316a1ed0405ef1bd9aa0236f13a2b5032f34d7dc /app-editors/qxmledit
parentSo long saxon. (diff)
downloadgentoo-2-4efcf587d3cebaed810b0d702640eb786a71392a.tar.gz
gentoo-2-4efcf587d3cebaed810b0d702640eb786a71392a.tar.bz2
gentoo-2-4efcf587d3cebaed810b0d702640eb786a71392a.zip
Version bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-editors/qxmledit')
-rw-r--r--app-editors/qxmledit/ChangeLog7
-rw-r--r--app-editors/qxmledit/qxmledit-0.8.3.1.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/app-editors/qxmledit/ChangeLog b/app-editors/qxmledit/ChangeLog
index c334c9f0f832..64deffacd5a4 100644
--- a/app-editors/qxmledit/ChangeLog
+++ b/app-editors/qxmledit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/qxmledit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/ChangeLog,v 1.34 2012/09/27 20:09:19 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/ChangeLog,v 1.35 2012/10/29 10:36:45 yngwin Exp $
+
+*qxmledit-0.8.3.1 (29 Oct 2012)
+
+ 29 Oct 2012; Ben de Groot <yngwin@gentoo.org> +qxmledit-0.8.3.1.ebuild:
+ Version bump
*qxmledit-0.8.3 (27 Sep 2012)
diff --git a/app-editors/qxmledit/qxmledit-0.8.3.1.ebuild b/app-editors/qxmledit/qxmledit-0.8.3.1.ebuild
new file mode 100644
index 000000000000..67c5dc76b182
--- /dev/null
+++ b/app-editors/qxmledit/qxmledit-0.8.3.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/qxmledit-0.8.3.1.ebuild,v 1.1 2012/10/29 10:36:45 yngwin Exp $
+
+EAPI=4
+
+inherit multilib eutils qt4-r2
+
+MY_P="qxmledit-${PV}-src"
+
+DESCRIPTION="Qt4 XML Editor"
+HOMEPAGE="http://code.google.com/p/qxmledit/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tgz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND=">=x11-libs/qt-core-4.7:4
+ >=x11-libs/qt-gui-4.7:4
+ >=x11-libs/qt-sql-4.7:4
+ >=x11-libs/qt-svg-4.7:4
+ >=x11-libs/qt-xmlpatterns-4.7:4"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS NEWS README ROADMAP TODO"
+
+src_prepare() {
+ # fix doc dir
+ sed -i "/INST_DOC_DIR = / s|/opt/${PN}|/usr/share/doc/${PF}|" \
+ src/QXmlEdit{,Widget}.pro src/sessions/QXmlEditSessions.pro || \
+ die "failed to fix doc installation path"
+ # fix binary installation path
+ sed -i "/INST_DIR = / s|/opt/${PN}|/usr/bin|" \
+ src/QXmlEdit{,Widget}.pro src/sessions/QXmlEditSessions.pro || \
+ die "failed to fix binary installation path"
+ # fix helper libraries installation path
+ sed -i "/INST_LIB_DIR = / s|/opt/${PN}|/usr/$(get_libdir)|" \
+ src/QXmlEdit{,Widget}.pro \
+ src/sessions/QXmlEditSessions.pro || \
+ die "failed to fix library installation path"
+ # fix translations
+ sed -i "/INST_DATA_DIR = / s|/opt|/usr/share|" src/QXmlEdit{,Widget}.pro \
+ src/sessions/QXmlEditSessions.pro || \
+ die "failed to fix translations"
+ # fix include
+ sed -i "/INST_INCLUDE_DIR = / s|/opt|/usr/share|" src/QXmlEditWidget.pro \
+ || die "failed to fix include directory"
+
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ newicon src/images/icon.png ${PN}.png
+ make_desktop_entry QXmlEdit QXmlEdit ${PN} "Qt;Utility;TextEditor"
+}