summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-03-15 19:10:04 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-03-15 19:10:04 +0000
commita4f13fd7774276942176501e0ed80b91fa6f3376 (patch)
treeb614745a35bc0b5442efde1afe737767696de11b /app-editors/qxmledit
parentVersion bump. (diff)
downloadgentoo-2-a4f13fd7774276942176501e0ed80b91fa6f3376.tar.gz
gentoo-2-a4f13fd7774276942176501e0ed80b91fa6f3376.tar.bz2
gentoo-2-a4f13fd7774276942176501e0ed80b91fa6f3376.zip
Version bump
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'app-editors/qxmledit')
-rw-r--r--app-editors/qxmledit/ChangeLog7
-rw-r--r--app-editors/qxmledit/qxmledit-0.8.5.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/app-editors/qxmledit/ChangeLog b/app-editors/qxmledit/ChangeLog
index fdf82d4aea13..1e751e76878a 100644
--- a/app-editors/qxmledit/ChangeLog
+++ b/app-editors/qxmledit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/qxmledit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/ChangeLog,v 1.39 2013/03/02 19:22:03 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/ChangeLog,v 1.40 2013/03/15 19:10:04 hwoarang Exp $
+
+*qxmledit-0.8.5 (15 Mar 2013)
+
+ 15 Mar 2013; Markos Chandras <hwoarang@gentoo.org> +qxmledit-0.8.5.ebuild:
+ Version bump
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> qxmledit-0.8.2.ebuild,
qxmledit-0.8.3.1.ebuild, qxmledit-0.8.4.ebuild:
diff --git a/app-editors/qxmledit/qxmledit-0.8.5.ebuild b/app-editors/qxmledit/qxmledit-0.8.5.ebuild
new file mode 100644
index 000000000000..d0771b822cfe
--- /dev/null
+++ b/app-editors/qxmledit/qxmledit-0.8.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/qxmledit-0.8.5.ebuild,v 1.1 2013/03/15 19:10:04 hwoarang Exp $
+
+EAPI=5
+
+inherit multilib eutils qt4-r2
+
+MY_P="qxmledit-${PV}-src"
+
+DESCRIPTION="Qt4 XML Editor"
+HOMEPAGE="http://code.google.com/p/qxmledit/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tgz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND=">=dev-qt/qtcore-4.7:4
+ >=dev-qt/qtgui-4.7:4
+ >=dev-qt/qtsql-4.7:4
+ >=dev-qt/qtsvg-4.7:4
+ >=dev-qt/qtxmlpatterns-4.7:4"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS NEWS README ROADMAP TODO"
+
+src_prepare() {
+ # fix doc dir
+ sed -i "/INST_DOC_DIR = / s|/opt/${PN}|/usr/share/doc/${PF}|" \
+ src/QXmlEdit{,Widget}.pro src/sessions/QXmlEditSessions.pro || \
+ die "failed to fix doc installation path"
+ # fix binary installation path
+ sed -i "/INST_DIR = / s|/opt/${PN}|/usr/bin|" \
+ src/QXmlEdit{,Widget}.pro src/sessions/QXmlEditSessions.pro || \
+ die "failed to fix binary installation path"
+ # fix helper libraries installation path
+ sed -i "/INST_LIB_DIR = / s|/opt/${PN}|/usr/$(get_libdir)|" \
+ src/QXmlEdit{,Widget}.pro \
+ src/sessions/QXmlEditSessions.pro || \
+ die "failed to fix library installation path"
+ # fix translations
+ sed -i "/INST_DATA_DIR = / s|/opt|/usr/share|" src/QXmlEdit{,Widget}.pro \
+ src/sessions/QXmlEditSessions.pro || \
+ die "failed to fix translations"
+ # fix include
+ sed -i "/INST_INCLUDE_DIR = / s|/opt|/usr/share|" src/QXmlEditWidget.pro \
+ || die "failed to fix include directory"
+
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ newicon src/images/icon.png ${PN}.png
+ make_desktop_entry QXmlEdit QXmlEdit ${PN} "Qt;Utility;TextEditor"
+}