summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-09-03 14:03:25 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-09-03 14:03:25 +0000
commit4329e6fa35f68d3e76946b2d4fa224562ecccb4b (patch)
tree97f7dfe24b8b202877b1d9e8c09177393d7663d4 /app-editors/tea
parentx86 stable, fix bug #219907 (diff)
downloadgentoo-2-4329e6fa35f68d3e76946b2d4fa224562ecccb4b.tar.gz
gentoo-2-4329e6fa35f68d3e76946b2d4fa224562ecccb4b.tar.bz2
gentoo-2-4329e6fa35f68d3e76946b2d4fa224562ecccb4b.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-editors/tea')
-rw-r--r--app-editors/tea/ChangeLog7
-rw-r--r--app-editors/tea/tea-17.6.6.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/app-editors/tea/ChangeLog b/app-editors/tea/ChangeLog
index 5da3cba2b10c..7e03c644a20e 100644
--- a/app-editors/tea/ChangeLog
+++ b/app-editors/tea/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/tea
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.39 2008/09/03 13:49:45 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.40 2008/09/03 14:03:25 armin76 Exp $
+
+*tea-17.6.6 (03 Sep 2008)
+
+ 03 Sep 2008; Raúl Porcel <armin76@gentoo.org> +tea-17.6.6.ebuild:
+ Version bump
03 Sep 2008; Raúl Porcel <armin76@gentoo.org> tea-17.6.3.ebuild:
x86 stable, fix bug #219907
diff --git a/app-editors/tea/tea-17.6.6.ebuild b/app-editors/tea/tea-17.6.6.ebuild
new file mode 100644
index 000000000000..d010bb5ef6a5
--- /dev/null
+++ b/app-editors/tea/tea-17.6.6.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/tea-17.6.6.ebuild,v 1.1 2008/09/03 14:03:25 armin76 Exp $
+
+EAPI="1"
+inherit autotools eutils
+
+MY_P=${P/tea/teagtk}
+
+DESCRIPTION="Small, lightweight GTK+ text editor"
+HOMEPAGE="http://tea-editor.sourceforge.net"
+SRC_URI="mirror://sourceforge/tea-editor/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86 ~x86-fbsd"
+IUSE="enchant gnome hacking ipv6 spell"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libX11
+ gnome? ( x11-libs/gtksourceview:2.0
+ gnome-base/gnome-vfs )"
+DEPEND="${RDEPEND}
+ net-misc/curl
+ spell? ( app-text/aspell )
+ enchant? ( app-text/enchant )
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-17.5.4-forced-cflags-and-compiler-warnings.patch
+ eautoreconf
+}
+
+src_compile() {
+ local myconf
+
+ if use hacking; then
+ myconf="${myconf} --enable-hacking"
+ fi
+ if ! use gnome; then
+ myconf="${myconf} --enable-legacy"
+ fi
+ if use enchant; then
+ myconf="${myconf} --enable-enchant"
+ fi
+
+ econf \
+ $(use_enable ipv6) \
+ ${myconf} || die "econf failed!"
+
+ emake || die "emake failed!"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed!"
+
+ make_desktop_entry teagtk Tea /usr/share/tea/pixmaps/tea_icon_v2.png Development
+
+# insinto /usr/share/doc/tea/
+# doins AUTHORS COPYING NEWS README TODO ChangeLog doc/*
+
+# insinto /usr/share/pixmaps/
+# doins pixmaps/*
+}
+
+pkg_postinst() {
+ if use spell ; then
+ elog "To get full spellchecking functuality, ensure that you install"
+ elog "the relevant language pack(s)"
+ fi
+}