summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-08-03 13:20:37 +0000
committerLars Wendler <polynomial-c@gentoo.org>2015-08-03 13:20:37 +0000
commit7ef527387def5f12221d43aaf23d7067ccf23391 (patch)
tree7bb2a4a09208c4987d0859c7d1f5779398137ae9 /app-editors
parentRemove old. (diff)
downloadgentoo-2-7ef527387def5f12221d43aaf23d7067ccf23391.tar.gz
gentoo-2-7ef527387def5f12221d43aaf23d7067ccf23391.tar.bz2
gentoo-2-7ef527387def5f12221d43aaf23d7067ccf23391.zip
Version bump (bug #544212)
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 981CA6FC)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/joe/ChangeLog7
-rw-r--r--app-editors/joe/joe-4.0.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/app-editors/joe/ChangeLog b/app-editors/joe/ChangeLog
index dd9d4f1210cb..e68f56d58d3f 100644
--- a/app-editors/joe/ChangeLog
+++ b/app-editors/joe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/joe
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/ChangeLog,v 1.87 2015/06/09 09:50:44 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/ChangeLog,v 1.88 2015/08/03 13:20:37 polynomial-c Exp $
+
+*joe-4.0 (03 Aug 2015)
+
+ 03 Aug 2015; Lars Wendler <polynomial-c@gentoo.org> +joe-4.0.ebuild:
+ Version bump (bug #544212).
09 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Updating remote-id in metadata.xml
diff --git a/app-editors/joe/joe-4.0.ebuild b/app-editors/joe/joe-4.0.ebuild
new file mode 100644
index 000000000000..51f960feaab3
--- /dev/null
+++ b/app-editors/joe/joe-4.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-4.0.ebuild,v 1.1 2015/08/03 13:20:37 polynomial-c Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A free ASCII-Text Screen Editor for UNIX"
+HOMEPAGE="http://sourceforge.net/projects/joe-editor/"
+SRC_URI="mirror://sourceforge/joe-editor/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="xterm"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+RDEPEND="xterm? ( >=x11-terms/xterm-239 )"
+
+DOCS=( README.md NEWS.md docs/hacking.md docs/man.md )
+
+src_prepare() {
+ # Enable xterm mouse support in the rc files
+ if use xterm; then
+ cd "${S}"/rc
+ for i in *rc*.in; do
+ sed -e 's/^ -\(mouse\|joexterm\)/-\1/' -i "${i}" || die "sed failed"
+ done
+ fi
+}
+
+src_configure() {
+ econf \
+ --docdir="/usr/share/doc/${PF}"
+}
+
+pkg_postinst() {
+ if use xterm; then
+ elog "To enable full xterm clipboard you need to set the allowWindowOps"
+ elog "resources to true. This is usually found in /etc/X11/app-defaults/XTerm"
+ elog "This is false by default due to potential security problems on some"
+ elog "architectures (see bug #91453)."
+ fi
+}