summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-11-08 23:53:28 +0000
committerUlrich Müller <ulm@gentoo.org>2009-11-08 23:53:28 +0000
commita837d37cefe1bd6b1c030377068068455c4d5de5 (patch)
tree12b0019afbe81beff95cada34b0e5f4432c8806d /app-editors
parentDrop KDE 4.3.2 (diff)
downloadgentoo-2-a837d37cefe1bd6b1c030377068068455c4d5de5.tar.gz
gentoo-2-a837d37cefe1bd6b1c030377068068455c4d5de5.tar.bz2
gentoo-2-a837d37cefe1bd6b1c030377068068455c4d5de5.zip
Fix updating of menus with GTK+ 2.18, bug 292007.
(Portage version: 2.2_rc49/cvs/Linux i686)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/ChangeLog12
-rw-r--r--app-editors/emacs/emacs-22.3-r3.ebuild257
-rw-r--r--app-editors/emacs/emacs-23.1-r2.ebuild (renamed from app-editors/emacs/emacs-23.1-r1.ebuild)10
-rw-r--r--app-editors/emacs/emacs-23.1.ebuild9
-rw-r--r--app-editors/emacs/files/emacs-23.0.94-handle-xz-suffix.patch16
-rw-r--r--app-editors/emacs/files/emacs-23.1-backspace.patch54
6 files changed, 278 insertions, 80 deletions
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
index a87f475819f1..11099201611f 100644
--- a/app-editors/emacs/ChangeLog
+++ b/app-editors/emacs/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-editors/emacs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.342 2009/10/28 19:38:52 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.343 2009/11/08 23:53:27 ulm Exp $
+
+*emacs-23.1-r2 (08 Nov 2009)
+*emacs-22.3-r3 (08 Nov 2009)
+
+ 08 Nov 2009; Ulrich Mueller <ulm@gentoo.org> +emacs-22.3-r3.ebuild,
+ -files/emacs-23.0.94-handle-xz-suffix.patch, emacs-23.1.ebuild,
+ -emacs-23.1-r1.ebuild, +emacs-23.1-r2.ebuild,
+ -files/emacs-23.1-backspace.patch:
+ Fix updating of menus with GTK+ 2.18, bug 292007. Patchsets for Emacs 23
+ moved to Gentoo mirrors.
*emacs-23.1-r1 (28 Oct 2009)
diff --git a/app-editors/emacs/emacs-22.3-r3.ebuild b/app-editors/emacs/emacs-22.3-r3.ebuild
new file mode 100644
index 000000000000..fc8effeea292
--- /dev/null
+++ b/app-editors/emacs/emacs-22.3-r3.ebuild
@@ -0,0 +1,257 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-22.3-r3.ebuild,v 1.1 2009/11/08 23:53:27 ulm Exp $
+
+EAPI=2
+
+inherit autotools elisp-common eutils flag-o-matic
+
+DESCRIPTION="The extensible, customizable, self-documenting real-time display editor"
+HOMEPAGE="http://www.gnu.org/software/emacs/"
+SRC_URI="mirror://gnu/emacs/${P}.tar.gz
+ mirror://gentoo/${P}-patches-2.tar.bz2"
+
+LICENSE="GPL-3 FDL-1.2 BSD as-is X11"
+SLOT="22"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="alsa gif gtk gzip-el hesiod jpeg kerberos motif png sound source tiff toolkit-scroll-bars X Xaw3d +xpm"
+RESTRICT="strip"
+
+RDEPEND="sys-libs/ncurses
+ >=app-admin/eselect-emacs-1.2
+ net-libs/liblockfile
+ hesiod? ( net-dns/hesiod )
+ kerberos? ( virtual/krb5 )
+ alsa? ( media-libs/alsa-lib )
+ X? (
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-misc/xbitmaps
+ gif? ( media-libs/giflib )
+ jpeg? ( media-libs/jpeg )
+ tiff? ( media-libs/tiff )
+ png? ( media-libs/libpng )
+ xpm? ( x11-libs/libXpm )
+ gtk? ( x11-libs/gtk+:2 )
+ !gtk? (
+ Xaw3d? ( x11-libs/Xaw3d )
+ !Xaw3d? ( motif? ( x11-libs/openmotif ) )
+ )
+ )"
+
+DEPEND="${RDEPEND}
+ alsa? ( dev-util/pkgconfig )
+ X? ( gtk? ( dev-util/pkgconfig ) )
+ gzip-el? ( app-arch/gzip )"
+
+RDEPEND="${RDEPEND}
+ !<app-editors/emacs-cvs-22.1
+ >=app-emacs/emacs-common-gentoo-1[X?]"
+
+# FULL_VERSION keeps the full version number, which is needed in order to
+# determine some path information correctly for copy/move operations later on
+FULL_VERSION="${PV}"
+SITEFILE="20${PN}-${SLOT}-gentoo.el"
+
+src_prepare() {
+ EPATCH_SUFFIX=patch epatch
+
+ sed -i -e "s:/usr/lib/crtbegin.o:$(`tc-getCC` -print-file-name=crtbegin.o):g" \
+ -e "s:/usr/lib/crtend.o:$(`tc-getCC` -print-file-name=crtend.o):g" \
+ "${S}"/src/s/freebsd.h || die "unable to sed freebsd.h settings"
+
+ if ! use alsa; then
+ # ALSA is detected even if not requested by its USE flag.
+ # Suppress it by supplying pkg-config with a wrong library name.
+ sed -i -e "/ALSA_MODULES=/s/alsa/DiSaBlEaLsA/" configure.in \
+ || die "unable to sed configure.in"
+ fi
+ if ! use gzip-el; then
+ # Emacs' build system automatically detects the gzip binary and
+ # compresses el files. We don't want that so confuse it with a
+ # wrong binary name
+ sed -i -e "s/ gzip/ PrEvEnTcOmPrEsSiOn/" configure.in \
+ || die "unable to sed configure.in"
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ ALLOWED_FLAGS=""
+ strip-flags
+ #unset LDFLAGS
+ if use hppa; then # bug #193703
+ replace-flags -O[2-9] -O
+ else
+ replace-flags -O[3-9] -O2
+ fi
+ sed -i -e "s/-lungif/-lgif/g" configure* src/Makefile* || die
+
+ local myconf
+
+ if use alsa && ! use sound; then
+ echo
+ einfo "Although sound USE flag is disabled you chose to have alsa,"
+ einfo "so sound is switched on anyway."
+ echo
+ myconf="${myconf} --with-sound"
+ else
+ myconf="${myconf} $(use_with sound)"
+ fi
+
+ if use X; then
+ myconf="${myconf} --with-x"
+ myconf="${myconf} $(use_with toolkit-scroll-bars)"
+ myconf="${myconf} $(use_with jpeg) $(use_with tiff)"
+ myconf="${myconf} $(use_with gif) $(use_with png)"
+ myconf="${myconf} $(use_with xpm)"
+
+ # GTK+ is the default toolkit if USE=gtk is chosen with other
+ # possibilities. Emacs upstream thinks this should be standard
+ # policy on all distributions
+ if use gtk; then
+ einfo "Configuring to build with GIMP Toolkit (GTK+)"
+ myconf="${myconf} --with-x-toolkit=gtk"
+ elif use Xaw3d; then
+ einfo "Configuring to build with Xaw3d (Athena/Lucid) toolkit"
+ myconf="${myconf} --with-x-toolkit=athena"
+ myconf="${myconf} --without-gtk"
+ elif use motif; then
+ einfo "Configuring to build with Motif toolkit"
+ myconf="${myconf} --with-x-toolkit=motif"
+ myconf="${myconf} --without-gtk"
+ else
+ einfo "Configuring to build with no toolkit"
+ myconf="${myconf} --with-x-toolkit=no"
+ myconf="${myconf} --without-gtk"
+ fi
+
+ local f tk=
+ for f in gtk Xaw3d motif; do
+ use ${f} || continue
+ [ "${tk}" ] \
+ && ewarn "USE flag \"${f}\" ignored (superseded by \"${tk}\")"
+ tk="${tk}${tk:+ }${f}"
+ done
+ else
+ myconf="${myconf} --without-x"
+ fi
+
+ myconf="${myconf} $(use_with hesiod)"
+ myconf="${myconf} $(use_with kerberos) $(use_with kerberos kerberos5)"
+
+ econf \
+ --program-suffix=-emacs-${SLOT} \
+ --infodir=/usr/share/info/emacs-${SLOT} \
+ --without-carbon \
+ ${myconf} || die "econf emacs failed"
+}
+
+src_compile() {
+ export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install () {
+ local i m
+
+ emake install DESTDIR="${D}" || die "make install failed"
+
+ rm "${D}"/usr/bin/emacs-${FULL_VERSION}-emacs-${SLOT} \
+ || die "removing duplicate emacs executable failed"
+ mv "${D}"/usr/bin/emacs-emacs-${SLOT} "${D}"/usr/bin/emacs-${SLOT} \
+ || die "moving Emacs executable failed"
+
+ # move info documentation to the correct place
+ for i in "${D}"/usr/share/info/emacs-${SLOT}/*; do
+ mv "${i}" "${i}.info" || die "mv info failed"
+ done
+
+ # move man pages to the correct place
+ for m in "${D}"/usr/share/man/man1/* ; do
+ mv "${m}" "${m%.1}-emacs-${SLOT}.1" || die "mv man failed"
+ done
+
+ # avoid collision between slots, see bug #169033 e.g.
+ rm "${D}"/usr/share/emacs/site-lisp/subdirs.el
+ rm "${D}"/var/lib/games/emacs/{snake,tetris}-scores
+ keepdir /var/lib/games/emacs
+
+ local c=";;"
+ if use source; then
+ insinto /usr/share/emacs/${FULL_VERSION}/src
+ # This is not meant to install all the source -- just the
+ # C source you might find via find-function
+ doins src/*.[ch]
+ c=""
+ fi
+
+ sed 's/^X//' >"${SITEFILE}" <<-EOF
+ X
+ ;;; ${PN}-${SLOT} site-lisp configuration
+ X
+ (when (string-match "\\\\\`${FULL_VERSION//./\\\\.}\\\\>" emacs-version)
+ X ${c}(setq find-function-C-source-directory
+ X ${c} "/usr/share/emacs/${FULL_VERSION}/src")
+ X (let ((path (getenv "INFOPATH"))
+ X (dir "/usr/share/info/emacs-${SLOT}")
+ X (re "\\\\\`/usr/share/info\\\\>"))
+ X (and path
+ X ;; move Emacs Info dir before anything else in /usr/share/info
+ X (let* ((p (cons nil (split-string path ":" t))) (q p))
+ X (while (and (cdr q) (not (string-match re (cadr q))))
+ X (setq q (cdr q)))
+ X (setcdr q (cons dir (delete dir (cdr q))))
+ X (setq Info-directory-list (prune-directory-list (cdr p)))))))
+ EOF
+ elisp-site-file-install "${SITEFILE}" || die
+
+ dodoc AUTHORS BUGS CONTRIBUTE README || die "dodoc failed"
+}
+
+emacs-infodir-rebuild() {
+ # Depending on the Portage version, the Info dir file is compressed
+ # or removed. It is only rebuilt by Portage if our directory is in
+ # INFOPATH, which is not guaranteed. So we rebuild it ourselves.
+
+ local infodir=/usr/share/info/emacs-${SLOT} f
+ [ -d "${ROOT}"${infodir} ] || return # may occur with FEATURES=noinfo
+ einfo "Regenerating Info directory index in ${infodir} ..."
+ rm -f "${ROOT}"${infodir}/dir{,.*}
+ for f in "${ROOT}"${infodir}/*.info*; do
+ [[ ${f##*/} != *[0-9].info* && -e ${f} ]] \
+ && install-info --info-dir="${ROOT}"${infodir} "${f}" &>/dev/null
+ done
+ rmdir "${ROOT}"${infodir} 2>/dev/null # remove dir if it is empty
+ echo
+}
+
+pkg_postinst() {
+ local f
+ for f in "${ROOT}"/var/lib/games/emacs/{snake,tetris}-scores; do
+ [ -e "${f}" ] || touch "${f}"
+ done
+
+ elisp-site-regen
+ emacs-infodir-rebuild
+
+ if [[ $(readlink "${ROOT}"/usr/bin/emacs) == emacs.emacs-${SLOT}* ]]; then
+ # transition from pre-eselect revision
+ eselect emacs set emacs-${SLOT}
+ else
+ eselect emacs update ifunset
+ fi
+
+ echo
+ elog "You can set the version to be started by /usr/bin/emacs through"
+ elog "the Emacs eselect module, which also redirects man and info pages."
+ elog "Therefore, several Emacs versions can be installed at the same time."
+ elog "\"man emacs.eselect\" for details."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+ emacs-infodir-rebuild
+ eselect emacs update ifunset
+}
diff --git a/app-editors/emacs/emacs-23.1-r1.ebuild b/app-editors/emacs/emacs-23.1-r2.ebuild
index 86a84bc34547..371289c955ce 100644
--- a/app-editors/emacs/emacs-23.1-r1.ebuild
+++ b/app-editors/emacs/emacs-23.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-23.1-r1.ebuild,v 1.1 2009/10/28 19:38:52 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-23.1-r2.ebuild,v 1.1 2009/11/08 23:53:27 ulm Exp $
EAPI=2
@@ -16,7 +16,8 @@ if [ "${PV##*.}" = "9999" ]; then
SRC_URI=""
S="${WORKDIR}/${ECVS_LOCALNAME}"
else
- SRC_URI="mirror://gnu/emacs/${P}.tar.bz2"
+ SRC_URI="mirror://gnu/emacs/${P}.tar.bz2
+ mirror://gentoo/${P}-patches-2.tar.bz2"
# FULL_VERSION keeps the full version number, which is needed in
# order to determine some path information correctly for copy/move
# operations later on
@@ -90,11 +91,10 @@ src_prepare() {
[ "${FULL_VERSION%.*}" = ${PV%.*} ] \
|| die "Upstream version number changed to ${FULL_VERSION}"
echo
+ else
+ EPATCH_SUFFIX=patch epatch
fi
- epatch "${FILESDIR}/${PN}-23.0.94-handle-xz-suffix.patch"
- epatch "${FILESDIR}/${P}-backspace.patch"
-
sed -i -e "s:/usr/lib/crtbegin.o:$(`tc-getCC` -print-file-name=crtbegin.o):g" \
-e "s:/usr/lib/crtend.o:$(`tc-getCC` -print-file-name=crtend.o):g" \
"${S}"/src/s/freebsd.h || die "unable to sed freebsd.h settings"
diff --git a/app-editors/emacs/emacs-23.1.ebuild b/app-editors/emacs/emacs-23.1.ebuild
index cc5d2e536ac8..5d7673d5aefb 100644
--- a/app-editors/emacs/emacs-23.1.ebuild
+++ b/app-editors/emacs/emacs-23.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-23.1.ebuild,v 1.12 2009/10/12 16:34:24 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-23.1.ebuild,v 1.13 2009/11/08 23:53:27 ulm Exp $
EAPI=2
@@ -16,7 +16,8 @@ if [ "${PV##*.}" = "9999" ]; then
SRC_URI=""
S="${WORKDIR}/${ECVS_LOCALNAME}"
else
- SRC_URI="mirror://gnu/emacs/${P}.tar.bz2"
+ SRC_URI="mirror://gnu/emacs/${P}.tar.bz2
+ mirror://gentoo/${P}-patches-1.tar.bz2"
# FULL_VERSION keeps the full version number, which is needed in
# order to determine some path information correctly for copy/move
# operations later on
@@ -90,10 +91,10 @@ src_prepare() {
[ "${FULL_VERSION%.*}" = ${PV%.*} ] \
|| die "Upstream version number changed to ${FULL_VERSION}"
echo
+ else
+ EPATCH_SUFFIX=patch epatch
fi
- epatch "${FILESDIR}/emacs-23.0.94-handle-xz-suffix.patch"
-
sed -i -e "s:/usr/lib/crtbegin.o:$(`tc-getCC` -print-file-name=crtbegin.o):g" \
-e "s:/usr/lib/crtend.o:$(`tc-getCC` -print-file-name=crtend.o):g" \
"${S}"/src/s/freebsd.h || die "unable to sed freebsd.h settings"
diff --git a/app-editors/emacs/files/emacs-23.0.94-handle-xz-suffix.patch b/app-editors/emacs/files/emacs-23.0.94-handle-xz-suffix.patch
deleted file mode 100644
index 9345ceaabbd4..000000000000
--- a/app-editors/emacs/files/emacs-23.0.94-handle-xz-suffix.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Automatically handle .xz suffix (XZ-compressed files)
-From Jim Meyering <meyering@redhat.com> on emacs-devel
-
---- a/lisp/jka-cmpr-hook.el
-+++ b/lisp/jka-cmpr-hook.el
-@@ -219,6 +219,10 @@ options through Custom does this automatically."
- "compressing" "gzip" ("-c" "-q")
- "uncompressing" "gzip" ("-c" "-q" "-d")
- t t "\037\213"]
-+ ["\\.xz\\(~\\|\\.~[0-9]+~\\)?\\'"
-+ "XZ compressing" "xz" ("-c" "-q")
-+ "XZ uncompressing" "xz" ("-c" "-q" "-d")
-+ t t "\3757zXZ\0"]
- ;; dzip is gzip with random access. Its compression program can't
- ;; read/write stdin/out, so .dz files can only be viewed without
- ;; saving, having their contents decompressed with gzip.
diff --git a/app-editors/emacs/files/emacs-23.1-backspace.patch b/app-editors/emacs/files/emacs-23.1-backspace.patch
deleted file mode 100644
index bc547af8a27b..000000000000
--- a/app-editors/emacs/files/emacs-23.1-backspace.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-2009-10-22 Stefan Monnier <monnier@iro.umontreal.ca>
-
- * simple.el (normal-erase-is-backspace-mode): Use input-decode-map
- rather than fiddling with global-map bindings, since it should only
- affect per-terminal settings.
- See http://bugs.gentoo.org/show_bug.cgi?id=289709.
-
---- emacs-23.1-orig/lisp/simple.el
-+++ emacs-23.1/lisp/simple.el
-@@ -6269,31 +6269,27 @@
- (let* ((bindings
- `(([M-delete] [M-backspace])
- ([C-M-delete] [C-M-backspace])
-- (,esc-map
-- [C-delete] [C-backspace])))
-+ ([?\e C-delete] [?\e C-backspace])))
- (old-state (lookup-key local-function-key-map [delete])))
-
- (if enabled
- (progn
- (define-key local-function-key-map [delete] [?\C-d])
- (define-key local-function-key-map [kp-delete] [?\C-d])
-- (define-key local-function-key-map [backspace] [?\C-?]))
-+ (define-key local-function-key-map [backspace] [?\C-?])
-+ (dolist (b bindings)
-+ ;; Not sure if input-decode-map is really right, but
-+ ;; keyboard-translate-table (used below) only works
-+ ;; for integer events, and key-translation-table is
-+ ;; global (like the global-map, used earlier).
-+ (define-key input-decode-map (car b) nil)
-+ (define-key input-decode-map (cadr b) nil)))
- (define-key local-function-key-map [delete] [?\C-?])
- (define-key local-function-key-map [kp-delete] [?\C-?])
-- (define-key local-function-key-map [backspace] [?\C-?]))
--
-- ;; Maybe swap bindings of C-delete and C-backspace, etc.
-- (unless (equal old-state (lookup-key local-function-key-map [delete]))
-- (dolist (binding bindings)
-- (let ((map global-map))
-- (when (keymapp (car binding))
-- (setq map (car binding) binding (cdr binding)))
-- (let* ((key1 (nth 0 binding))
-- (key2 (nth 1 binding))
-- (binding1 (lookup-key map key1))
-- (binding2 (lookup-key map key2)))
-- (define-key map key1 binding2)
-- (define-key map key2 binding1)))))))
-+ (define-key local-function-key-map [backspace] [?\C-?])
-+ (dolist (b bindings)
-+ (define-key input-decode-map (car b) (cadr b))
-+ (define-key input-decode-map (cadr b) (car b))))))
- (t
- (if enabled
- (progn