summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2012-07-02 03:47:52 +0000
committerRyan Hill <dirtyepic@gentoo.org>2012-07-02 03:47:52 +0000
commitc2f683120af5955227f47d663c46b0f02dc55b29 (patch)
tree9eacefc9d76504f5a997a00903b3fadffc0408ce /app-editors
parentPer request from Bug 396253, took over maintainership of media-video/makemkv.... (diff)
downloadgentoo-2-c2f683120af5955227f47d663c46b0f02dc55b29.tar.gz
gentoo-2-c2f683120af5955227f47d663c46b0f02dc55b29.tar.bz2
gentoo-2-c2f683120af5955227f47d663c46b0f02dc55b29.zip
Version bump, bug #407161. Remove old.
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/wxhexeditor/ChangeLog11
-rw-r--r--app-editors/wxhexeditor/files/wxhexeditor-0.09-gcc45.patch37
-rw-r--r--app-editors/wxhexeditor/files/wxhexeditor-0.20-makefile.patch108
-rw-r--r--app-editors/wxhexeditor/wxhexeditor-0.20.ebuild (renamed from app-editors/wxhexeditor/wxhexeditor-0.09.ebuild)23
4 files changed, 130 insertions, 49 deletions
diff --git a/app-editors/wxhexeditor/ChangeLog b/app-editors/wxhexeditor/ChangeLog
index 008d49481364..deb0748b5816 100644
--- a/app-editors/wxhexeditor/ChangeLog
+++ b/app-editors/wxhexeditor/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/wxhexeditor
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/wxhexeditor/ChangeLog,v 1.2 2011/08/19 04:44:27 dirtyepic Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/wxhexeditor/ChangeLog,v 1.3 2012/07/02 03:47:52 dirtyepic Exp $
+
+*wxhexeditor-0.20 (02 Jul 2012)
+
+ 02 Jul 2012; Ryan Hill <dirtyepic@gentoo.org> -wxhexeditor-0.09.ebuild,
+ -files/wxhexeditor-0.09-gcc45.patch, +wxhexeditor-0.20.ebuild,
+ +files/wxhexeditor-0.20-makefile.patch:
+ Version bump, bug #407161. Remove old.
*wxhexeditor-0.11 (19 Aug 2011)
diff --git a/app-editors/wxhexeditor/files/wxhexeditor-0.09-gcc45.patch b/app-editors/wxhexeditor/files/wxhexeditor-0.09-gcc45.patch
deleted file mode 100644
index c49e8a2452ca..000000000000
--- a/app-editors/wxhexeditor/files/wxhexeditor-0.09-gcc45.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-http://wxhexeditor.svn.sourceforge.net/viewvc/wxhexeditor/trunk/src/HexEditor.cpp?r1=132&r2=145
-
---- a/src/HexEditor.cpp
-+++ b/src/HexEditor.cpp
-@@ -102,7 +102,7 @@ bool HexEditor::FileOpen(wxFileName& myfilename ){
- wxLogError(_("Critical Error. File pointer is not empty!"));
- return false;
- }
-- else if(myfilename.IsFileReadable()){ //IsFileReadable
-+ else if( myfilename.IsFileReadable() ){ //IsFileReadable
- if ( myfilename.GetSize( ) < 50*MB && myfilename.IsFileWritable() )
- myfile = new FileDifference( myfilename, FileDifference::ReadWrite );
- else
-@@ -869,20 +869,20 @@ void HexEditor::OnMouseTest( wxMouseEvent& event ){
- }
-
- void HexEditor::FindDialog( void ){
-- class FindDialog *myfind = new FindDialog::FindDialog( this, myfile );
-+ ::FindDialog *myfind = new ::FindDialog( this, myfile );
- myfind->ShowModal();
- myfind->Destroy();
- }
-
- void HexEditor::ReplaceDialog( void ){
-- class ReplaceDialog *myfind = new ReplaceDialog::ReplaceDialog( this, myfile );
-+ ::ReplaceDialog *myfind = new ::ReplaceDialog( this, myfile );
- myfind->ShowModal();
- myfind->Destroy();
- }
-
- void HexEditor::GotoDialog( void ){
- uint64_t newoffset;
-- class GotoDialog *mygoto = new GotoDialog::GotoDialog( this, newoffset, CursorOffset(), FileLength(), myDialogVector );
-+ ::GotoDialog *mygoto = new ::GotoDialog( this, newoffset, CursorOffset(), FileLength(), myDialogVector );
- if( mygoto->ShowModal() == wxID_OK ){
- Goto( newoffset );
- }
diff --git a/app-editors/wxhexeditor/files/wxhexeditor-0.20-makefile.patch b/app-editors/wxhexeditor/files/wxhexeditor-0.20-makefile.patch
new file mode 100644
index 000000000000..b4d97b2ec25c
--- /dev/null
+++ b/app-editors/wxhexeditor/files/wxhexeditor-0.20-makefile.patch
@@ -0,0 +1,108 @@
+--- a/makefile
++++ b/makefile
+@@ -1,8 +1,8 @@
+ WXCONFIG = wx-config
+ CC = `$(WXCONFIG) --cc`
+ CPP = `$(WXCONFIG) --cxx`
+-CXXFLAGS= `$(WXCONFIG) --cxxflags` -Iudis86 -Imhash/include -MMD -O2 -c ${OPTFLAGS}
+-LDFLAGS = `$(WXCONFIG) --libs`
++WXCXXFLAGS= `$(WXCONFIG) --cxxflags` -MMD -c ${OPTFLAGS} -fopenmp ${CXXFLAGS}
++WXLDFLAGS = `$(WXCONFIG) --libs` -fopenmp ${LDFLAGS}
+ RC = `$(WXCONFIG) --rescomp`
+ #RC = x86_64-w64-mingw32-windres --define WX_CPU_AMD64
+ RCFLAGS = `$(WXCONFIG) --cxxflags | sed s/' '-m.*//g;`
+@@ -19,7 +19,7 @@ SOURCES= src/HexEditorGui.cpp \
+ src/HexEditorCtrl/wxHexCtrl/Tag.cpp\
+ src/HexEditorCtrl/HexEditorCtrlGui.cpp\
+ src/HexEditorFrame.cpp
+-LIBS = udis86/libudis86/.libs/libudis86.a mhash/lib/.libs/libmhash.a
++LIBS = -lmhash -ludis86
+ OBJECTS=$(SOURCES:.cpp=.o)
+ DEPENDS=$(OBJECTS:.o=.d)
+ RESOURCES= resources/resource.rc
+@@ -28,43 +28,35 @@ EXECUTABLE=wxHexEditor
+ EXECUTABLE_WIN=$(EXECUTABLE).exe
+ EXECUTABLE_DIR_MAC=$(EXECUTABLE).app
+
+-PREFIX = /usr/local
++DESTDIR =
++PREFIX = $(DESTDIR)/usr
+ BINDIR = $(PREFIX)/bin
+ DATADIR = $(PREFIX)/share
+ LOCALEDIR = $(DATADIR)/locale
+
+-VERSION = 0.12 Beta
++VERSION = 0.20
+
+ all: $(EXECUTABLE)
+
+-$(OBJECTS): $(LIBS) $(SOURCES)
++$(OBJECTS): $(SOURCES)
+
+ $(EXECUTABLE): $(OBJECTS)
+- $(CPP) $(OBJECTS) $(LIBS) $(LDFLAGS) -lgomp -o $@
++ $(CPP) $(OBJECTS) $(LIBS) $(WXLDFLAGS) ${CXXFLAGS} -o $@
+
+-.cpp.o: $(LIBS)
+- $(CPP) $(CXXFLAGS) $< -o $@
++.cpp.o:
++ $(CPP) $(WXCXXFLAGS) $< -o $@
+
+ %.o : %.rc
+ $(RC) $(RCFLAGS) $< -o $@
+
+-udis86/libudis86/.libs/libudis86.a:
+- cd udis86;./autogen.sh
+- cd udis86;./configure --host=$(HOST)
+- cd udis86/libudis86; $(MAKE) $(MFLAGS)
+-
+-mhash/lib/.libs/libmhash.a:
+- cd mhash; ./configure --host=$(HOST)
+- cd mhash; $(MAKE) $(MFLAGS)
+-
+ win: $(RESOURCES) $(EXECUTABLE_WIN)
+
+ #Stack override required for file comparison function...
+ $(EXECUTABLE_WIN): $(OBJECTS) $(RESOURCE_OBJ)
+- $(CPP) $(OBJECTS) $(RESOURCE_OBJ) $(LIBS) $(LDFLAGS) -static-libgcc -static-libstdc++ -Wl,--stack,32000000 -o $@
++ $(CPP) $(OBJECTS) $(RESOURCE_OBJ) $(LIBS) ${CXXFLAGS} $(WXLDFLAGS) -static-libgcc -static-libstdc++ -Wl,--stack,32000000 -o $@
+
+ maclink: $(OBJECTS)
+- $(CPP) $(OBJECTS) $(LIBS) $(LDFLAGS) -lexpat -Wl,-stack_size,0x2000000 -o $(EXECUTABLE)
++ $(CPP) $(OBJECTS) $(LIBS) ${CXXFLAGS} $(WXLDFLAGS) -lexpat -Wl,-stack_size,0x2000000 -o $(EXECUTABLE)
+
+ mac: maclink
+ mkdir -p $(EXECUTABLE_DIR_MAC)/Contents
+--- a/src/HexDialogs.cpp
++++ b/src/HexDialogs.cpp
+@@ -24,7 +24,7 @@
+ #define NANINT 0xFFFFFFFFFFFFFFFFLL
+ #include "HexDialogs.h"
+ #include <wx/progdlg.h>
+-#include "../mhash/include/mhash.h"
++#include <mhash.h>
+
+ #ifdef _OPENMP
+ #include <omp.h>
+--- a/src/HexEditor.h
++++ b/src/HexEditor.h
+@@ -25,7 +25,7 @@
+ #ifndef _wxHexEditor_h_
+ #define _wxHexEditor_h_
+
+-#include "../mhash/include/mhash.h"
++#include <mhash.h>
+
+ #include <wx/ffile.h>
+ #include <wx/clipbrd.h>
+--- a/src/HexPanels.h
++++ b/src/HexPanels.h
+@@ -27,7 +27,7 @@
+ #include "HexEditorFrame.h"
+ #include "HexEditorCtrl/HexEditorCtrl.h"
+ #include "HexEditorCtrl/wxHexCtrl/wxHexCtrl.h"
+-#include "../udis86/udis86.h"
++#include <udis86.h>
+
+ #ifdef WX_GCH
+ #include <wx_pch.h>
diff --git a/app-editors/wxhexeditor/wxhexeditor-0.09.ebuild b/app-editors/wxhexeditor/wxhexeditor-0.20.ebuild
index 1cbe530d35a4..0e12813473b0 100644
--- a/app-editors/wxhexeditor/wxhexeditor-0.09.ebuild
+++ b/app-editors/wxhexeditor/wxhexeditor-0.20.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/wxhexeditor/wxhexeditor-0.09.ebuild,v 1.1 2010/08/31 04:16:58 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/wxhexeditor/wxhexeditor-0.20.ebuild,v 1.1 2012/07/02 03:47:52 dirtyepic Exp $
-EAPI=3
-WX_GTK_VER=2.8
+EAPI="4"
+WX_GTK_VER="2.8"
-inherit eutils wxwidgets
+inherit eutils toolchain-funcs wxwidgets
MY_PN="wxHexEditor"
@@ -18,15 +18,18 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="x11-libs/wxGTK:2.8[X]"
+DEPEND="app-crypt/mhash
+ dev-libs/udis86
+ x11-libs/wxGTK:2.8[X]"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_PN}"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc45.patch
+pkg_pretend() {
+ tc-has-openmp \
+ || die "${PN} uses OpenMP libraries. Please use an OpenMP-capable compiler."
}
-src_install() {
- emake DESTDIR="${D}" install || die
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
}