summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-12-16 21:13:21 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-12-16 21:13:21 +0000
commitec3acf7bf19b4687abd48917149d9505b97f221d (patch)
treea961b199fcd99334d3d287921f6c9d713cb086d7 /app-editors
parentTweaked cscope option (diff)
downloadgentoo-2-ec3acf7bf19b4687abd48917149d9505b97f221d.tar.gz
gentoo-2-ec3acf7bf19b4687abd48917149d9505b97f221d.tar.bz2
gentoo-2-ec3acf7bf19b4687abd48917149d9505b97f221d.zip
removed without-x. Fixes #11221. Submitted by Jason Rhinelander.
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim/ChangeLog5
-rw-r--r--app-editors/vim/vim-6.1-r17.ebuild11
2 files changed, 13 insertions, 3 deletions
diff --git a/app-editors/vim/ChangeLog b/app-editors/vim/ChangeLog
index ce6ad44b9e54..79dea44f729f 100644
--- a/app-editors/vim/ChangeLog
+++ b/app-editors/vim/ChangeLog
@@ -1,12 +1,15 @@
# ChangeLog for app-editors/vim
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.32 2002/12/16 21:08:15 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.33 2002/12/16 21:13:21 rphillips Exp $
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
*vim-6.1-r17.ebuild (06 Dec 2002)
16 Dec 2002; Ryan Phillips <rphillips@gentoo.org> vim-6.1-r17.ebuild :
+ Took out --without-x. See bug #11221
+
+ 16 Dec 2002; Ryan Phillips <rphillips@gentoo.org> vim-6.1-r17.ebuild :
tweaked cscope configure option.
15 Dec 2002; Ryan Phillips <rphillips@gentoo.org> vim-6.1-r17.ebuild :
diff --git a/app-editors/vim/vim-6.1-r17.ebuild b/app-editors/vim/vim-6.1-r17.ebuild
index 6725c5025cfd..0ca76679a1cd 100644
--- a/app-editors/vim/vim-6.1-r17.ebuild
+++ b/app-editors/vim/vim-6.1-r17.ebuild
@@ -1,6 +1,6 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.1-r17.ebuild,v 1.9 2002/12/16 21:08:15 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.1-r17.ebuild,v 1.10 2002/12/16 21:13:21 rphillips Exp $
VIMPATCH="vimpatch-1-263.tar.bz2"
inherit vim
@@ -16,10 +16,11 @@ DEPEND="app-editors/vim-core
python? ( dev-lang/python )
ruby? ( >=dev-lang/ruby-1.6.4 )"
# tcltk? ( dev-lang/tcl )"
+IUSE="nls perl python ruby tcltk gpm X"
src_compile() {
local myconf
- myconf="--without-x --with-features=big --enable-multibyte"
+ myconf="--with-features=big --enable-multibyte"
use nls && myconf="$myconf --enable-multibyte"
use nls || myconf="$myconf --disable-nls"
use perl && myconf="$myconf --enable-perlinterp"
@@ -32,6 +33,12 @@ src_compile() {
# Added back gpm for temporary will remove if necessary, I think that I have
# fixed most of gpm so it should be fine.
use gpm || myconf="$myconf --disable-gpm"
+
+ # the console vim will change the caption of a terminal in X.
+ # the configure script should autodetect X being installed, so
+ # we'll specifically turn it off if X is not in the USE vars.
+ # -rphillips
+ use X && myconf="$myconf --without-x"
# This should fix a sandbox violation.
addwrite "${SSH_TTY}"