summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-09-23 05:30:24 +0000
committerMamoru Komachi <usata@gentoo.org>2004-09-23 05:30:24 +0000
commitc26b209500ea25b5afe9beb0c3af78b46b6af599 (patch)
treea05d611e0380b4a82ebba6538477f6427b6a796b /app-emacs/ecb/ecb-2.27.ebuild
parentBlocks app-emacs/cedet. Removed old ebuilds. (Manifest recommit) (diff)
downloadgentoo-2-c26b209500ea25b5afe9beb0c3af78b46b6af599.tar.gz
gentoo-2-c26b209500ea25b5afe9beb0c3af78b46b6af599.tar.bz2
gentoo-2-c26b209500ea25b5afe9beb0c3af78b46b6af599.zip
Version bumped. Added app-emacs/cedet as an alternative to speedbar, eieio and semantic; bug #64395.
Diffstat (limited to 'app-emacs/ecb/ecb-2.27.ebuild')
-rw-r--r--app-emacs/ecb/ecb-2.27.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-emacs/ecb/ecb-2.27.ebuild b/app-emacs/ecb/ecb-2.27.ebuild
new file mode 100644
index 000000000000..eedb49963c48
--- /dev/null
+++ b/app-emacs/ecb/ecb-2.27.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ecb/ecb-2.27.ebuild,v 1.1 2004/09/23 05:30:24 usata Exp $
+
+inherit elisp
+
+DESCRIPTION="ECB is a source code browser for Emacs"
+HOMEPAGE="http://ecb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ecb/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="java"
+DEPEND="virtual/emacs
+ || (
+ ( >=app-emacs/speedbar-0.14_beta4
+ >=app-emacs/semantic-1.4
+ >=app-emacs/eieio-0.17
+ )
+ app-emacs/cedet
+ )
+ java? ( app-emacs/jde )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e "s%./info-help%../../../info%" \
+ -e "s%./html-help%../../../doc/${P}/html%" \
+ -e "/defconst/s%ecb.info%ecb.info.gz%" \
+ ecb-help.el
+}
+
+src_compile() {
+ local my_loadpath="${SITELISP}/semantic ${SITELISP}/eieio"
+ use java \
+ && my_loadpath="${my_loadpath} ${SITELISP}/elib ${SITELISP}/jde/lisp"
+
+ if has_version "app-emacs/cedet" ; then
+ CEDET="${SITELISP}/cedet"
+ fi
+ make ${CEDET} \
+ LOADPATH="${my_loadpath}" \
+ || die "make failed"
+ make online-help \
+ LOADPATH="${my_loadpath}" \
+ || die "make online-help failed"
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/70ecb-gentoo.el
+ dodoc NEWS README RELEASE_NOTES
+ doinfo info-help/ecb.info*
+ dohtml html-help/*.html
+}