summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-05-29 21:42:29 +0000
committerUlrich Müller <ulm@gentoo.org>2007-05-29 21:42:29 +0000
commitf73f36810d945fd1d668a860a9c0e445ba0e4dba (patch)
treefa1553cca0ea39fe786b5f39c72bc5fc0fbf3091 /app-emacs/gnuserv-programs/gnuserv-programs-3.12.7.ebuild
parentalpha stable wrt #175560 (diff)
downloadgentoo-2-f73f36810d945fd1d668a860a9c0e445ba0e4dba.tar.gz
gentoo-2-f73f36810d945fd1d668a860a9c0e445ba0e4dba.tar.bz2
gentoo-2-f73f36810d945fd1d668a860a9c0e445ba0e4dba.zip
Initial import. Split off from gnuserv, bug #177936.
(Portage version: 2.1.2.7)
Diffstat (limited to 'app-emacs/gnuserv-programs/gnuserv-programs-3.12.7.ebuild')
-rw-r--r--app-emacs/gnuserv-programs/gnuserv-programs-3.12.7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-emacs/gnuserv-programs/gnuserv-programs-3.12.7.ebuild b/app-emacs/gnuserv-programs/gnuserv-programs-3.12.7.ebuild
new file mode 100644
index 000000000000..a8ff4e9990be
--- /dev/null
+++ b/app-emacs/gnuserv-programs/gnuserv-programs-3.12.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gnuserv-programs/gnuserv-programs-3.12.7.ebuild,v 1.1 2007/05/29 21:42:29 ulm Exp $
+
+DESCRIPTION="Binary programs for app-emacs/gnuserv"
+HOMEPAGE="http://meltin.net/hacks/emacs/"
+SRC_URI="http://meltin.net/hacks/emacs/src/gnuserv-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X"
+
+DEPEND="!app-editors/xemacs
+ X? ( x11-libs/libXau )"
+RDEPEND="${DEPEND}"
+PDEPEND="~app-emacs/gnuserv-${PV}"
+
+S="${WORKDIR}/gnuserv-${PV}"
+
+src_compile() {
+ # bug #83112
+ unset LDFLAGS
+
+ econf $(use_enable X xauth) \
+ --x-includes=/usr/X11R6/include \
+ --x-libraries=/usr/X11R6/lib || die "econf failed"
+ emake ELC="" || die "emake failed"
+}
+
+src_install() {
+ emake -j1 ELC="" \
+ prefix="${D}"/usr \
+ man1dir="${D}"/usr/share/man/man1 \
+ install || die "emake install failed"
+}