summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-01-31 12:34:37 +0000
committerUlrich Müller <ulm@gentoo.org>2010-01-31 12:34:37 +0000
commit8bf8bec866609e16c6ddee329ba18f9834118885 (patch)
tree3239f05419d915c061aa7034ae56cea7544d9214 /app-emacs/imaxima
parentadd patch from fedora to build with poppler-0.12.3 wrt bug #301250 (diff)
downloadgentoo-2-8bf8bec866609e16c6ddee329ba18f9834118885.tar.gz
gentoo-2-8bf8bec866609e16c6ddee329ba18f9834118885.tar.bz2
gentoo-2-8bf8bec866609e16c6ddee329ba18f9834118885.zip
Add prefix keywords, change EAPI to 3.
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'app-emacs/imaxima')
-rw-r--r--app-emacs/imaxima/ChangeLog9
-rw-r--r--app-emacs/imaxima/imaxima-1.0-r1.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/app-emacs/imaxima/ChangeLog b/app-emacs/imaxima/ChangeLog
index ff4db0800282..ec0f770c5108 100644
--- a/app-emacs/imaxima/ChangeLog
+++ b/app-emacs/imaxima/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/imaxima
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/imaxima/ChangeLog,v 1.31 2009/12/26 19:20:00 pva Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/imaxima/ChangeLog,v 1.32 2010/01/31 12:34:37 ulm Exp $
+
+*imaxima-1.0-r1 (31 Jan 2010)
+
+ 31 Jan 2010; Ulrich Mueller <ulm@gentoo.org> +imaxima-1.0-r1.ebuild:
+ Add prefix keywords, change EAPI to 3.
26 Dec 2009; Peter Volkov <pva@gentoo.org> imaxima-1.0.ebuild:
virtual/ghostscript->app-text/ghostscript-gpl: ghostscript-gpl is the only
diff --git a/app-emacs/imaxima/imaxima-1.0-r1.ebuild b/app-emacs/imaxima/imaxima-1.0-r1.ebuild
new file mode 100644
index 000000000000..49621abe3b38
--- /dev/null
+++ b/app-emacs/imaxima/imaxima-1.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/imaxima/imaxima-1.0-r1.ebuild,v 1.1 2010/01/31 12:34:37 ulm Exp $
+
+EAPI=3
+
+inherit elisp
+
+MY_P="${PN}-imath-${PV/_}"
+DESCRIPTION="Imaxima enables graphical output in Maxima sessions with emacs"
+HOMEPAGE="http://sites.google.com/site/imaximaimath/"
+SRC_URI="http://members3.jcom.home.ne.jp/imaxima/Site/Download_and_Install_files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="virtual/latex-base
+ app-text/ghostscript-gpl
+ dev-tex/mh
+ sci-mathematics/maxima"
+
+S="${WORKDIR}/${MY_P}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ econf --with-lispdir="${EPREFIX}${SITELISP}/${PN}"
+}
+
+# This is NOT redundant, elisp.eclass redefines src_compile
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ dodoc ChangeLog NEWS README || die
+
+ if use examples; then
+ docinto imath-example
+ dodoc imath-example/*.txt || die
+ dohtml -r imath-example/. || die
+ fi
+}