summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-04-16 18:36:09 +0000
committerUlrich Müller <ulm@gentoo.org>2007-04-16 18:36:09 +0000
commitf862640f9d6aa9cccf07ba403c0e248843bf6079 (patch)
tree956e25db8a8bbd040dbcebd36ed6305f0f82dd73 /app-emacs/table
parentRevbump: generate Emacs autoloads. (diff)
downloadgentoo-2-f862640f9d6aa9cccf07ba403c0e248843bf6079.tar.gz
gentoo-2-f862640f9d6aa9cccf07ba403c0e248843bf6079.tar.bz2
gentoo-2-f862640f9d6aa9cccf07ba403c0e248843bf6079.zip
Revbump, generate emacs autoloads.
(Portage version: 2.1.2.4)
Diffstat (limited to 'app-emacs/table')
-rw-r--r--app-emacs/table/ChangeLog8
-rw-r--r--app-emacs/table/files/51table-gentoo.el6
-rw-r--r--app-emacs/table/files/digest-table-1.5.54-r13
-rw-r--r--app-emacs/table/table-1.5.54-r1.ebuild22
4 files changed, 38 insertions, 1 deletions
diff --git a/app-emacs/table/ChangeLog b/app-emacs/table/ChangeLog
index 1918f7e7d1f8..f8059ca17ea2 100644
--- a/app-emacs/table/ChangeLog
+++ b/app-emacs/table/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/table
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/table/ChangeLog,v 1.12 2007/03/08 09:45:41 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/table/ChangeLog,v 1.13 2007/04/16 18:36:09 ulm Exp $
+
+*table-1.5.54-r1 (16 Apr 2007)
+
+ 16 Apr 2007; Ulrich Mueller <ulm@gentoo.org> +files/51table-gentoo.el,
+ +table-1.5.54-r1.ebuild:
+ Generate autoload file for package initialisation.
08 Mar 2007; Christian Faulhammer <opfer@gentoo.org>
files/50table-gentoo.el:
diff --git a/app-emacs/table/files/51table-gentoo.el b/app-emacs/table/files/51table-gentoo.el
new file mode 100644
index 000000000000..7eeb2fcb6a43
--- /dev/null
+++ b/app-emacs/table/files/51table-gentoo.el
@@ -0,0 +1,6 @@
+
+;;; table site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(load "table-autoloads" nil t)
+(add-hook 'text-mode-hook 'table-recognize)
diff --git a/app-emacs/table/files/digest-table-1.5.54-r1 b/app-emacs/table/files/digest-table-1.5.54-r1
new file mode 100644
index 000000000000..5624fb376706
--- /dev/null
+++ b/app-emacs/table/files/digest-table-1.5.54-r1
@@ -0,0 +1,3 @@
+MD5 bf610808fa37ec0c6393e841d99defd9 table-1.5.54.el.gz 58136
+RMD160 da7312476e92bc298fc997f7940910a924507f8c table-1.5.54.el.gz 58136
+SHA256 af7f3337e1dc517bcb9f5683103d5e32a34dcf311f1187a02660fc3642089cba table-1.5.54.el.gz 58136
diff --git a/app-emacs/table/table-1.5.54-r1.ebuild b/app-emacs/table/table-1.5.54-r1.ebuild
new file mode 100644
index 000000000000..fbf32f36835d
--- /dev/null
+++ b/app-emacs/table/table-1.5.54-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/table/table-1.5.54-r1.ebuild,v 1.1 2007/04/16 18:36:09 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Table editor for Emacs"
+HOMEPAGE="http://table.sourceforge.net/"
+SRC_URI="mirror://sourceforge/table/${P}.el.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+SITEFILE=51${PN}-gentoo.el
+SIMPLE_ELISP=t
+
+src_compile() {
+ elisp-compile *.el || die "elisp-compile failed"
+ elisp-make-autoload-file || die "elisp-make-autoload-file failed"
+}