summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-01-19 17:37:03 +0000
committerUlrich Müller <ulm@gentoo.org>2011-01-19 17:37:03 +0000
commit713972acddd94516031a371ebe9d2b5ecead8a95 (patch)
treea7c5ecf9dea5735fdbee80adda10adefc2798059 /app-emacs
parentDisable tcmalloc switch until fixed by upstream. Fixes #351032. Thanks to xar... (diff)
downloadgentoo-2-713972acddd94516031a371ebe9d2b5ecead8a95.tar.gz
gentoo-2-713972acddd94516031a371ebe9d2b5ecead8a95.tar.bz2
gentoo-2-713972acddd94516031a371ebe9d2b5ecead8a95.zip
Version bump. Remove intermediate version.
(Portage version: 2.1.9.33/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/ocaml-mode/ChangeLog11
-rw-r--r--app-emacs/ocaml-mode/files/50ocaml-mode-gentoo.el3
-rw-r--r--app-emacs/ocaml-mode/ocaml-mode-3.11.2.ebuild (renamed from app-emacs/ocaml-mode/ocaml-mode-3.11.0.ebuild)8
-rw-r--r--app-emacs/ocaml-mode/ocaml-mode-3.12.0.ebuild22
4 files changed, 36 insertions, 8 deletions
diff --git a/app-emacs/ocaml-mode/ChangeLog b/app-emacs/ocaml-mode/ChangeLog
index b5e95b66e09f..33d97068707a 100644
--- a/app-emacs/ocaml-mode/ChangeLog
+++ b/app-emacs/ocaml-mode/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emacs/ocaml-mode
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/ocaml-mode/ChangeLog,v 1.39 2009/05/04 14:43:44 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ocaml-mode/ChangeLog,v 1.40 2011/01/19 17:37:03 ulm Exp $
+
+*ocaml-mode-3.12.0 (19 Jan 2011)
+*ocaml-mode-3.11.2 (19 Jan 2011)
+
+ 19 Jan 2011; Ulrich Mueller <ulm@gentoo.org> -ocaml-mode-3.11.0.ebuild,
+ +ocaml-mode-3.11.2.ebuild, +ocaml-mode-3.12.0.ebuild:
+ Version bump. Remove intermediate version.
*ocaml-mode-3.11.0 (04 May 2009)
diff --git a/app-emacs/ocaml-mode/files/50ocaml-mode-gentoo.el b/app-emacs/ocaml-mode/files/50ocaml-mode-gentoo.el
index 7d1b8f0e3be5..8f45033a3fce 100644
--- a/app-emacs/ocaml-mode/files/50ocaml-mode-gentoo.el
+++ b/app-emacs/ocaml-mode/files/50ocaml-mode-gentoo.el
@@ -1,6 +1,3 @@
-
-;;; ocaml-mode site-lisp configuration
-
(add-to-list 'load-path "@SITELISP@")
(add-to-list 'auto-mode-alist '("\\.ml[iylp]?\\'" . caml-mode))
(autoload 'caml-mode "caml" "Major mode for editing Caml code." t)
diff --git a/app-emacs/ocaml-mode/ocaml-mode-3.11.0.ebuild b/app-emacs/ocaml-mode/ocaml-mode-3.11.2.ebuild
index 764497baa796..40ae029ef762 100644
--- a/app-emacs/ocaml-mode/ocaml-mode-3.11.0.ebuild
+++ b/app-emacs/ocaml-mode/ocaml-mode-3.11.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/ocaml-mode/ocaml-mode-3.11.0.ebuild,v 1.1 2009/05/04 14:43:44 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ocaml-mode/ocaml-mode-3.11.2.ebuild,v 1.1 2011/01/19 17:37:03 ulm Exp $
+
+EAPI=3
inherit elisp
@@ -16,5 +18,5 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE=""
S="${WORKDIR}/${MY_P}/emacs"
-SITEFILE=50${PN}-gentoo.el
+SITEFILE="50${PN}-gentoo.el"
DOCS="README README.itz"
diff --git a/app-emacs/ocaml-mode/ocaml-mode-3.12.0.ebuild b/app-emacs/ocaml-mode/ocaml-mode-3.12.0.ebuild
new file mode 100644
index 000000000000..c5cb7eab5a8c
--- /dev/null
+++ b/app-emacs/ocaml-mode/ocaml-mode-3.12.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ocaml-mode/ocaml-mode-3.12.0.ebuild,v 1.1 2011/01/19 17:37:03 ulm Exp $
+
+EAPI=3
+
+inherit elisp
+
+MY_P=${P/-mode/}
+
+DESCRIPTION="Emacs mode for OCaml"
+HOMEPAGE="http://www.ocaml.org/"
+SRC_URI="http://caml.inria.fr/distrib/${MY_P%.*}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}/emacs"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README README.itz"