summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-08-08 04:58:27 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-08-08 04:58:27 +0000
commita304476acc8d5b73e723faf68bd2c18f10be42fb (patch)
tree9ee00ab1fc7848c39282f0a0a4dbd7d33cd59bf9 /app-emacs
parentversion bump from upstream (diff)
downloadgentoo-2-a304476acc8d5b73e723faf68bd2c18f10be42fb.tar.gz
gentoo-2-a304476acc8d5b73e723faf68bd2c18f10be42fb.tar.bz2
gentoo-2-a304476acc8d5b73e723faf68bd2c18f10be42fb.zip
New upstream version; Resolves Bug #142422 and also Bug #125617.
(Portage version: 2.1.1_pre4-r3)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/color-theme/ChangeLog8
-rw-r--r--app-emacs/color-theme/color-theme-6.6.0.ebuild27
-rw-r--r--app-emacs/color-theme/files/51color-theme-gentoo.el121
-rw-r--r--app-emacs/color-theme/files/digest-color-theme-6.6.03
4 files changed, 158 insertions, 1 deletions
diff --git a/app-emacs/color-theme/ChangeLog b/app-emacs/color-theme/ChangeLog
index 4dbcbdd50254..c739f41888ab 100644
--- a/app-emacs/color-theme/ChangeLog
+++ b/app-emacs/color-theme/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/color-theme
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/color-theme/ChangeLog,v 1.20 2006/06/26 23:06:40 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/color-theme/ChangeLog,v 1.21 2006/08/08 04:58:27 mkennedy Exp $
+
+*color-theme-6.6.0 (08 Aug 2006)
+
+ 08 Aug 2006; Matthew Kennedy <mkennedy@gentoo.org>
+ +files/51color-theme-gentoo.el, +color-theme-6.6.0.ebuild:
+ New upstream version; Resolves Bug #142422 and also Bug #125617.
26 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
color-theme-6.5.5.ebuild:
diff --git a/app-emacs/color-theme/color-theme-6.6.0.ebuild b/app-emacs/color-theme/color-theme-6.6.0.ebuild
new file mode 100644
index 000000000000..c74682dd7f6a
--- /dev/null
+++ b/app-emacs/color-theme/color-theme-6.6.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/color-theme/color-theme-6.6.0.ebuild,v 1.1 2006/08/08 04:58:27 mkennedy Exp $
+
+inherit elisp eutils
+
+IUSE=""
+
+DESCRIPTION="Install color themes (includes many themes and allows you to share your own with the world)"
+HOMEPAGE="http://www.emacswiki.org/cgi-bin/wiki.pl?ColorTheme"
+SRC_URI="http://download.gna.org/color-theme/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~sparc ~x86 ~x86-fbsd"
+
+SITEFILE="51${PN}-gentoo.el"
+
+src_unpack() {
+ unpack ${A}
+ rm ${S}/*.elc ${S}/color-theme-autoloads*
+}
+
+src_install() {
+ elisp_src_install
+ insinto /usr/share/emacs/site-lisp/color-theme/themes
+ doins themes/*
+}
diff --git a/app-emacs/color-theme/files/51color-theme-gentoo.el b/app-emacs/color-theme/files/51color-theme-gentoo.el
new file mode 100644
index 000000000000..3889219409d8
--- /dev/null
+++ b/app-emacs/color-theme/files/51color-theme-gentoo.el
@@ -0,0 +1,121 @@
+
+;;; color-theme site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+
+;;;### (autoloads (color-theme-initialize color-theme-submit color-theme-install
+;;;;;; color-theme-compare color-theme-make-snapshot color-theme-analyze-defun
+;;;;;; color-theme-print color-theme-install-at-point-for-current-frame
+;;;;;; color-theme-install-at-mouse color-theme-describe color-theme-select)
+;;;;;; "color-theme" "color-theme.el" (17529 41105))
+;;; Generated autoloads from color-theme.el
+
+(autoload (quote color-theme-select) "color-theme" "\
+Displays a special buffer for selecting and installing a color theme.
+With optional prefix ARG, this buffer will include color theme libraries
+as well. A color theme library is in itself not complete, it must be
+used as part of another color theme to be useful. Thus, color theme
+libraries are mainly useful for color theme authors." t nil)
+
+(autoload (quote color-theme-describe) "color-theme" "\
+Describe color theme listed at point.
+This shows the documentation of the value of text-property color-theme
+at point. The text-property color-theme should be a color theme
+function. See `color-themes'." t nil)
+
+(autoload (quote color-theme-install-at-mouse) "color-theme" "\
+Install color theme clicked upon using the mouse.
+First argument EVENT is used to set point. Then
+`color-theme-install-at-point' is called." t nil)
+
+(autoload (quote color-theme-install-at-point-for-current-frame) "color-theme" "\
+Install color theme at point for current frame only.
+Binds `color-theme-is-global' to nil and calls
+`color-theme-install-at-point'." t nil)
+
+(autoload (quote color-theme-print) "color-theme" "\
+Print the current color theme function.
+
+You can contribute this function to <URL:news:gnu.emacs.sources> or
+paste it into your .emacs file and call it. That should recreate all
+the settings necessary for your color theme.
+
+Example:
+
+ (require 'color-theme)
+ (defun my-color-theme ()
+ \"Color theme by Alex Schroeder, created 2000-05-17.\"
+ (interactive)
+ (color-theme-install
+ '(...
+ ...
+ ...)))
+ (my-color-theme)
+
+If you want to use a specific color theme function, you can call the
+color theme function in your .emacs directly.
+
+Example:
+
+ (require 'color-theme)
+ (color-theme-gnome2)" t nil)
+
+(autoload (quote color-theme-analyze-defun) "color-theme" "\
+Once you have a color-theme printed, check for missing faces.
+This is used by maintainers who receive a color-theme submission
+and want to make sure it follows the guidelines by the color-theme
+author." t nil)
+
+(autoload (quote color-theme-make-snapshot) "color-theme" "\
+Return the definition of the current color-theme.
+The function returned will recreate the color-theme in use at the moment." nil nil)
+
+(autoload (quote color-theme-compare) "color-theme" "\
+Compare two color themes.
+This will print the differences between installing THEME-A and
+installing THEME-B. Note that the order is important: If a face is
+defined in THEME-A and not in THEME-B, then this will not show up as a
+difference, because there is no reset before installing THEME-B. If a
+face is defined in THEME-B and not in THEME-A, then this will show up as
+a difference." t nil)
+
+(autoload (quote color-theme-install) "color-theme" "\
+Install a color theme defined by frame parameters, variables and faces.
+
+The theme is installed for all present and future frames; any missing
+faces are created. See `color-theme-install-faces'.
+
+THEME is a color theme definition. See below for more information.
+
+If you want to install a color theme from your .emacs, use the output
+generated by `color-theme-print'. This produces color theme function
+which you can copy to your .emacs.
+
+A color theme definition is a list:
+\([FUNCTION] FRAME-PARAMETERS VARIABLE-SETTINGS FACE-DEFINITIONS)
+
+FUNCTION is the color theme function which called `color-theme-install'.
+This is no longer used. There was a time when this package supported
+automatic factoring of color themes. This has been abandoned.
+
+FRAME-PARAMETERS is an alist of frame parameters. These are installed
+with `color-theme-install-frame-params'. These are installed last such
+that any changes to the default face can be changed by the frame
+parameters.
+
+VARIABLE-DEFINITIONS is an alist of variable settings. These are
+installed with `color-theme-install-variables'.
+
+FACE-DEFINITIONS is an alist of face definitions. These are installed
+with `color-theme-install-faces'.
+
+If `color-theme-is-cumulative' is nil, a color theme will undo face and
+frame-parameter settings of previous color themes." nil nil)
+
+(autoload (quote color-theme-submit) "color-theme" "\
+Submit your color-theme to the maintainer." t nil)
+
+(autoload (quote color-theme-initialize) "color-theme" "\
+Initialize the color theme package by loading color-theme-libraries." t nil)
+
+;;;***
diff --git a/app-emacs/color-theme/files/digest-color-theme-6.6.0 b/app-emacs/color-theme/files/digest-color-theme-6.6.0
new file mode 100644
index 000000000000..338406db2166
--- /dev/null
+++ b/app-emacs/color-theme/files/digest-color-theme-6.6.0
@@ -0,0 +1,3 @@
+MD5 a4de73c236a6af11ab378bfe18dabcca color-theme-6.6.0.tar.gz 124858
+RMD160 82a2c75a65f50f9c5e6d5193c3f768824c6c1549 color-theme-6.6.0.tar.gz 124858
+SHA256 56d35f02dc4c8dd386a7242007432adc458466c8a48d0d680eda1826197ca17b color-theme-6.6.0.tar.gz 124858