summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2013-05-23 18:34:31 +0000
committerUlrich Müller <ulm@gentoo.org>2013-05-23 18:34:31 +0000
commite507ca8000c6d60d5e5b5e190cae28f5c13fc231 (patch)
tree065d991bc802e0e782d5fda2834eabba87797ec9 /app-emacs
parentFix Info reader to support Info files created by makeinfo 5, bug 464368. (diff)
downloadgentoo-2-e507ca8000c6d60d5e5b5e190cae28f5c13fc231.tar.gz
gentoo-2-e507ca8000c6d60d5e5b5e190cae28f5c13fc231.tar.bz2
gentoo-2-e507ca8000c6d60d5e5b5e190cae28f5c13fc231.zip
Version bump, bug 458350.
(Portage version: 2.1.12.1/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/sml-mode/ChangeLog8
-rw-r--r--app-emacs/sml-mode/sml-mode-4.1.ebuild28
-rw-r--r--app-emacs/sml-mode/sml-mode-6.4.ebuild24
3 files changed, 31 insertions, 29 deletions
diff --git a/app-emacs/sml-mode/ChangeLog b/app-emacs/sml-mode/ChangeLog
index c03a4b128c49..e8f86f643f52 100644
--- a/app-emacs/sml-mode/ChangeLog
+++ b/app-emacs/sml-mode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/sml-mode
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/sml-mode/ChangeLog,v 1.31 2013/01/20 10:51:32 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/sml-mode/ChangeLog,v 1.32 2013/05/23 18:34:31 ulm Exp $
+
+*sml-mode-6.4 (23 May 2013)
+
+ 23 May 2013; Ulrich Müller <ulm@gentoo.org> -sml-mode-4.1.ebuild,
+ +sml-mode-6.4.ebuild:
+ Version bump, bug 458350.
20 Jan 2013; Agostino Sarubbo <ago@gentoo.org> sml-mode-6.1-r1.ebuild:
Stable for alpha, wrt bug #451050
diff --git a/app-emacs/sml-mode/sml-mode-4.1.ebuild b/app-emacs/sml-mode/sml-mode-4.1.ebuild
deleted file mode 100644
index 1e37e11c8e2b..000000000000
--- a/app-emacs/sml-mode/sml-mode-4.1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/sml-mode/sml-mode-4.1.ebuild,v 1.6 2012/11/01 14:42:24 ulm Exp $
-
-inherit elisp
-
-DESCRIPTION="Emacs major mode for editing Standard ML"
-HOMEPAGE="http://www.iro.umontreal.ca/~monnier/elisp/"
-SRC_URI="http://www.iro.umontreal.ca/~monnier/elisp/${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="alpha amd64 ppc x86"
-IUSE=""
-RESTRICT="test"
-
-SITEFILE="50${PN}-gentoo.el"
-
-src_compile() {
- emake || die "emake failed"
-}
-
-src_install() {
- elisp-install ${PN} *.el *.elc || die
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
- doinfo *.info* || die
- dodoc BUGS ChangeLog NEWS README TODO || die
-}
diff --git a/app-emacs/sml-mode/sml-mode-6.4.ebuild b/app-emacs/sml-mode/sml-mode-6.4.ebuild
new file mode 100644
index 000000000000..15fcb4903454
--- /dev/null
+++ b/app-emacs/sml-mode/sml-mode-6.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/sml-mode/sml-mode-6.4.ebuild,v 1.1 2013/05/23 18:34:31 ulm Exp $
+
+EAPI=5
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Emacs major mode for editing Standard ML"
+HOMEPAGE="http://www.iro.umontreal.ca/~monnier/elisp/"
+# taken from http://elpa.gnu.org/packages/${P}.el
+SRC_URI="mirror://gentoo/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+
+SITEFILE="50${PN}-gentoo-6.1.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}