summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2013-05-02 19:30:49 +0000
committerRichard Yao <ryao@gentoo.org>2013-05-02 19:30:49 +0000
commit372e6bbafe714cfd77c1e4ff4d45f1773d07b146 (patch)
tree679daeebb9077936288dbc52817fcc2ae858cb36 /app-emulation/crossover-bin
parentRemoved package mask on net-proxy/swiftiply, see bug #198500. (diff)
downloadgentoo-2-372e6bbafe714cfd77c1e4ff4d45f1773d07b146.tar.gz
gentoo-2-372e6bbafe714cfd77c1e4ff4d45f1773d07b146.tar.bz2
gentoo-2-372e6bbafe714cfd77c1e4ff4d45f1773d07b146.zip
Version bump to 12.2.0
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 0xBEE84C64)
Diffstat (limited to 'app-emulation/crossover-bin')
-rw-r--r--app-emulation/crossover-bin/ChangeLog7
-rw-r--r--app-emulation/crossover-bin/crossover-bin-12.2.0.ebuild140
2 files changed, 146 insertions, 1 deletions
diff --git a/app-emulation/crossover-bin/ChangeLog b/app-emulation/crossover-bin/ChangeLog
index c58997eccf13..b4e873bc9184 100644
--- a/app-emulation/crossover-bin/ChangeLog
+++ b/app-emulation/crossover-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/crossover-bin
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-bin/ChangeLog,v 1.3 2013/04/22 18:05:45 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-bin/ChangeLog,v 1.4 2013/05/02 19:30:49 ryao Exp $
+
+*crossover-bin-12.2.0 (02 May 2013)
+
+ 02 May 2013; Richard Yao <ryao@gentoo.org> +crossover-bin-12.2.0.ebuild:
+ Version bump to 12.2.0
22 Apr 2013; Michał Górny <mgorny@gentoo.org> crossover-bin-12.1.2.ebuild:
Support multilib libraries alternatively to emul-linux-x86-xlibs.
diff --git a/app-emulation/crossover-bin/crossover-bin-12.2.0.ebuild b/app-emulation/crossover-bin/crossover-bin-12.2.0.ebuild
new file mode 100644
index 000000000000..4a59f7466c86
--- /dev/null
+++ b/app-emulation/crossover-bin/crossover-bin-12.2.0.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-bin/crossover-bin-12.2.0.ebuild,v 1.1 2013/05/02 19:30:49 ryao Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+PYTHON_REQ_USE="threads"
+
+inherit python-single-r1 unpacker
+
+DESCRIPTION="Commercial version of app-emulation/wine with paid support."
+HOMEPAGE="http://www.codeweavers.com/products/crossover/"
+SRC_URI="install-crossover-${PV}.bin"
+
+LICENSE="CROSSOVER-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="+capi +cups doc +gphoto2 +gsm +jpeg +lcms +ldap +mp3 +nls +openal +opengl +png +scanner +ssl +v4l"
+RESTRICT="fetch test"
+QA_FLAGS_IGNORED="opt/cxoffice/.*"
+QA_PRESTRIPPED="opt/cxoffice/lib/.*
+ opt/cxoffice/bin/cxburner
+ opt/cxoffice/bin/cxntlm_auth
+ opt/cxoffice/bin/wineserver
+ opt/cxoffice/bin/unrar
+ opt/cxoffice/bin/wine-preloader
+ opt/cxoffice/bin/cxdiag
+ opt/cxoffice/bin/cxgettext
+ opt/cxoffice/bin/wineloader
+ "
+S="${WORKDIR}"
+
+MLIB_DEPS="amd64? (
+ openal? ( app-emulation/emul-linux-x86-sdl )
+ opengl? ( app-emulation/emul-linux-x86-opengl )
+ scanner? ( app-emulation/emul-linux-x86-medialibs )
+ v4l? ( app-emulation/emul-linux-x86-medialibs )
+ app-emulation/emul-linux-x86-baselibs
+ app-emulation/emul-linux-x86-soundlibs
+ app-emulation/emul-linux-x86-xlibs
+)"
+
+X86_DEPS="x86? (
+ capi? ( net-dialup/capi4k-utils )
+ cups? ( net-print/cups )
+ gsm? ( media-sound/gsm )
+ jpeg? ( virtual/jpeg )
+ lcms? ( media-libs/lcms:0 )
+ ldap? ( net-nds/openldap )
+ gphoto2? ( media-libs/libgphoto2 )
+ mp3? ( >=media-sound/mpg123-1.5.0 )
+ nls? ( sys-devel/gettext )
+ openal? ( media-libs/openal )
+ opengl? (
+ virtual/glu
+ virtual/opengl
+ )
+ png? ( media-libs/libpng:0 )
+ scanner? ( media-gfx/sane-backends )
+ ssl? ( dev-libs/openssl:0 )
+ v4l? ( media-libs/libv4l )
+ media-libs/alsa-lib
+ >=media-libs/freetype-2.0.0
+ media-libs/mesa
+ sys-apps/util-linux
+ sys-libs/zlib
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXxf86vm
+ x11-libs/libxcb
+ )"
+
+DEPEND="dev-lang/perl
+ app-arch/unzip"
+
+RDEPEND="${DEPEND}
+ !prefix? ( sys-libs/glibc )
+ >=dev-python/pygtk-2.10
+ dev-util/desktop-file-utils
+ sys-apps/dbus
+ !app-emulation/crossover-office-pro-bin
+ !app-emulation/crossover-office-bin
+ ${MLIB_DEPS}
+ ${X86_DEPS}
+ "
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE}"
+ einfo "and place ${A} in ${DISTDIR}"
+}
+
+src_unpack() {
+ # self unpacking zip archive; unzip warns about the exe stuff
+ unpack_zip ${A}
+}
+
+src_prepare() {
+ python_fix_shebang .
+ sed -e 's:/usr/local/etc/xdg /etc/xdg::' -i "${WORKDIR}/bin/locate_gui.sh" \
+ || die "Could not patch ${WORKDIR}/bin/locate_gui.sh"
+
+ # Remove unnecessary files
+ rm -r license.txt guis/ || die "Could not remove files"
+ use doc || rm -r doc/ || die "Could not remove files"
+}
+
+src_install() {
+ # Install documentation
+ dodoc README changelog.txt
+ rm README changelog.txt || die "Could not remove README and changelog.txt"
+
+ # Install files
+ dodir /opt/cxoffice
+ cp -r ./* "${ED}opt/cxoffice" \
+ || die "Could not install into ${ED}opt/cxoffice"
+
+ # Install configuration file
+ insinto /opt/cxoffice/etc
+ doins share/crossover/data/cxoffice.conf
+
+ # Install requisite directories for menus
+ dodir "/usr/share/applications"
+ dodir "/etc/xdg/menus/applications-merged"
+
+ # Install menus
+ XDG_CONFIG_DIRS="${ED}etc/xdg" \
+ XDG_DATA_DIRS="${ED}usr/share" \
+ "${ED}opt/cxoffice/bin/cxmenu" --crossover --install \
+ || die "Could not install menus"
+
+ # Fix menus
+ sed -e "s:${ED}:/:" -i "${ED}usr/share/applications/"* \
+ || die "Could not fix menus"
+}