summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-19 22:35:30 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-19 22:35:30 +0000
commit4fdae48e66b57f93a5d75f0065dd265b5636d773 (patch)
treeefc14b151e0a15e7b590d4768d2b24ec5e1dc063 /app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-4.2.ebuild
parentRemove retired developer from metadata.xml. (diff)
downloadgentoo-2-4fdae48e66b57f93a5d75f0065dd265b5636d773.tar.gz
gentoo-2-4fdae48e66b57f93a5d75f0065dd265b5636d773.tar.bz2
gentoo-2-4fdae48e66b57f93a5d75f0065dd265b5636d773.zip
initial import #84163
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-4.2.ebuild')
-rw-r--r--app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-4.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-4.2.ebuild b/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-4.2.ebuild
new file mode 100644
index 000000000000..40d25ff972a9
--- /dev/null
+++ b/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-4.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/crossover-office-pro-bin/crossover-office-pro-bin-4.2.ebuild,v 1.1 2005/04/19 22:35:30 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="specialized version of wine for MS Office"
+HOMEPAGE="http://www.codeweavers.com/site/products/cxoffice/"
+SRC_URI="install-crossover-pro-${PV}.sh"
+
+LICENSE="CROSSOVER"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE=""
+RESTRICT="fetch nostrip"
+
+RDEPEND="virtual/x11
+ virtual/libc"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE}"
+ einfo "and place ${A} in ${DISTDIR}"
+}
+
+pkg_setup() {
+ ! built_with_use dev-lang/perl ithreads \
+ && die "you need to have perl built with USE=ithreads"
+}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ dodir /opt/cxoffice
+ cp -r * "${D}"/opt/cxoffice || die "cp failed"
+ rm -r "${D}"/opt/cxoffice/setup.{sh,data}
+ insinto /opt/cxoffice/etc
+ doins support/templates/cxoffice.conf
+}