summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-02-06 13:40:32 +0000
committerHanno Böck <hanno@gentoo.org>2009-02-06 13:40:32 +0000
commitd9ed1ee6a2f96a884be576bfeb990418181821e8 (patch)
tree9785ce36d9ba9b026c89cf13b20817f284f6172a /app-emulation/dosemu
parentVersion bump (diff)
downloadgentoo-2-d9ed1ee6a2f96a884be576bfeb990418181821e8.tar.gz
gentoo-2-d9ed1ee6a2f96a884be576bfeb990418181821e8.tar.bz2
gentoo-2-d9ed1ee6a2f96a884be576bfeb990418181821e8.zip
dosemu: fix compilation with gcc 4.3.3
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/dosemu')
-rw-r--r--app-emulation/dosemu/ChangeLog8
-rw-r--r--app-emulation/dosemu/dosemu-1.4.0.1.ebuild5
-rw-r--r--app-emulation/dosemu/files/dosemu-1.4.0.1-gcc433.diff11
3 files changed, 20 insertions, 4 deletions
diff --git a/app-emulation/dosemu/ChangeLog b/app-emulation/dosemu/ChangeLog
index c6a925e9aaa9..8aadd1df537f 100644
--- a/app-emulation/dosemu/ChangeLog
+++ b/app-emulation/dosemu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/dosemu
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/ChangeLog,v 1.49 2008/11/21 12:39:15 hanno Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/ChangeLog,v 1.50 2009/02/06 13:40:32 hanno Exp $
+
+ 06 Feb 2009; Hanno Boeck <hanno@gentoo.org>
+ +files/dosemu-1.4.0.1-gcc433.diff, dosemu-1.4.0.1.ebuild:
+ Patch from upstream svn to fix compilation with gcc 4.3.3.
21 Nov 2008; Hanno Boeck <hanno@gentoo.org> dosemu-1.4.0.1.ebuild:
xf86dgaproto is only a build-time dep.
diff --git a/app-emulation/dosemu/dosemu-1.4.0.1.ebuild b/app-emulation/dosemu/dosemu-1.4.0.1.ebuild
index a4c59f28f801..6566b90c3fdf 100644
--- a/app-emulation/dosemu/dosemu-1.4.0.1.ebuild
+++ b/app-emulation/dosemu/dosemu-1.4.0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/dosemu-1.4.0.1.ebuild,v 1.2 2008/11/21 12:39:15 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/dosemu-1.4.0.1.ebuild,v 1.3 2009/02/06 13:40:32 hanno Exp $
inherit flag-o-matic eutils
@@ -38,6 +38,7 @@ src_unpack() {
epatch "${DISTDIR}/patch-${PV}.gz"
epatch "${FILESDIR}"/dosemu-1.3.4-shm.diff
+ epatch "${FILESDIR}/${P}-gcc433.diff"
}
src_compile() {
diff --git a/app-emulation/dosemu/files/dosemu-1.4.0.1-gcc433.diff b/app-emulation/dosemu/files/dosemu-1.4.0.1-gcc433.diff
new file mode 100644
index 000000000000..8b0ca77df6c0
--- /dev/null
+++ b/app-emulation/dosemu/files/dosemu-1.4.0.1-gcc433.diff
@@ -0,0 +1,11 @@
+--- trunk/src/tools/periph/dexeconfig.c 2008/03/28 14:01:17 1854
++++ trunk/src/tools/periph/dexeconfig.c 2008/03/30 22:58:55 1855
+@@ -238,7 +238,7 @@
+ exit(1);
+ }
+ close(fd);
+- fc = open(cfile, O_WRONLY | O_CREAT | O_TRUNC);
++ fc = creat(cfile, S_IWUSR | S_IRUSR);
+ if (fc < 0) {
+ perror("cannot open config file");
+ exit(1);