summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-06-03 02:53:20 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-06-03 02:53:20 +0000
commite6086baf08a56b8bc47632d7ac4203bd413d2ab5 (patch)
treebd0d30a582abc1dfaabbc8c3b4da4f714107902d /app-emulation/epsxe
parentdependency fix (diff)
downloadgentoo-2-e6086baf08a56b8bc47632d7ac4203bd413d2ab5.tar.gz
gentoo-2-e6086baf08a56b8bc47632d7ac4203bd413d2ab5.tar.bz2
gentoo-2-e6086baf08a56b8bc47632d7ac4203bd413d2ab5.zip
New package. Fixes #3266-#3274
Diffstat (limited to 'app-emulation/epsxe')
-rw-r--r--app-emulation/epsxe/ChangeLog13
-rw-r--r--app-emulation/epsxe/epsxe-1.5.2.ebuild43
-rw-r--r--app-emulation/epsxe/files/digest-epsxe-1.5.21
-rw-r--r--app-emulation/epsxe/files/epsxe30
4 files changed, 87 insertions, 0 deletions
diff --git a/app-emulation/epsxe/ChangeLog b/app-emulation/epsxe/ChangeLog
new file mode 100644
index 000000000000..7bbebc8e9b98
--- /dev/null
+++ b/app-emulation/epsxe/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-emulation/epsxe
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/epsxe/ChangeLog,v 1.1 2002/06/03 02:53:20 rphillips Exp $
+
+*epsxe-1.5.2 (2 June 2002)
+
+ 2 June 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-emulation/epsxe/epsxe-1.5.2.ebuild b/app-emulation/epsxe/epsxe-1.5.2.ebuild
new file mode 100644
index 000000000000..ed3007599cc7
--- /dev/null
+++ b/app-emulation/epsxe/epsxe-1.5.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Per Wigren <wigren@home.se>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/epsxe/epsxe-1.5.2.ebuild,v 1.1 2002/06/03 02:53:20 rphillips Exp $
+
+S=${WORKDIR}
+DESCRIPTION="ePSXe Playstation Emulator"
+HOMEPAGE="http://www.epsxe.com"
+LICENSE="Freeware"
+
+use opengl && GLDEPEND="app-emulation/psemu-gpupetemesagl"
+use opengl || GLDEPEND="app-emulation/psemu-peopssoftgpu"
+
+DEPEND="app-arch/unzip"
+RDEPEND="=dev-libs/glib-1.2
+ =x11-libs/gtk+-1.2*
+ =sys-libs/ncurses-5*
+ =sys-libs/zlib-1*
+ net-misc/wget
+ app-emulation/psemu-peopsspu
+ ${GLDEPEND}"
+
+SRC_URI="http://download.epsxe.com/files/epsxe152lin.zip"
+
+# For some strange reason, strip truncates the whole file
+RESTRICT="nostrip"
+
+src_unpack() {
+ unzip ${DISTDIR}/${A}
+}
+
+src_install () {
+ dobin ${FILESDIR}/epsxe
+
+ insinto /opt/epsxe
+ doins epsxe
+ chmod 755 ${D}/opt/epsxe/epsxe
+
+ insinto /usr/lib/psemu/cheats
+ doins cheats/*
+
+ dodoc docs/*
+}
diff --git a/app-emulation/epsxe/files/digest-epsxe-1.5.2 b/app-emulation/epsxe/files/digest-epsxe-1.5.2
new file mode 100644
index 000000000000..cc22445f82b5
--- /dev/null
+++ b/app-emulation/epsxe/files/digest-epsxe-1.5.2
@@ -0,0 +1 @@
+MD5 5834f34cb904b08d95abda057eff3981 epsxe152lin.zip 166559
diff --git a/app-emulation/epsxe/files/epsxe b/app-emulation/epsxe/files/epsxe
new file mode 100644
index 000000000000..d433ba6d37a7
--- /dev/null
+++ b/app-emulation/epsxe/files/epsxe
@@ -0,0 +1,30 @@
+#!/bin/sh
+
+if [ ! -f ~/.epsxe ]; then
+ echo You are running ePSXe for the first time.
+ echo Setting up your ePSXe environment... Please wait...
+
+ mkdir -p $HOME/.epsxe
+ cd $HOME/.epsxe
+ mkdir memcards bios cfg cheats snap sstates patches plugins
+
+ ln -s /usr/lib/psemu/plugins/* plugins/
+ ln -s /opt/epsxe/epsxe epsxe
+
+ cd bios
+ if [ -f /usr/lib/psemu/bios/scph1001.bin ]; then
+ ln -s /usr/lib/psemu/bios/scph1001.bin .
+ else
+ wget http://aral3uz.tripod.com/sc.zip
+ unzip -L sc.zip
+ rm -f sc.zip
+ fi
+fi
+
+cd $HOME/.epsxe
+
+ln -s /usr/lib/psemu/plugins/* plugins/
+ln -s /usr/lib/psemu/cfg/* cfg/
+ln -s /usr/lib/psemu/cheats/* cheats/
+
+./epsxe