summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-06-24 21:18:41 +0000
committerMike Frysinger <vapier@gentoo.org>2007-06-24 21:18:41 +0000
commitcf0806d58bfec0fa71aa5b181aa570b38d25e14f (patch)
treeb4a9c7ab90747d8c3092d439b63ab86b95ae2c58 /app-emulation/hercules/hercules-3.05.ebuild
parentarm/s390/sh stable (diff)
downloadgentoo-2-cf0806d58bfec0fa71aa5b181aa570b38d25e14f.tar.gz
gentoo-2-cf0806d58bfec0fa71aa5b181aa570b38d25e14f.tar.bz2
gentoo-2-cf0806d58bfec0fa71aa5b181aa570b38d25e14f.zip
Version bump #183079 by Jay Maynard.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'app-emulation/hercules/hercules-3.05.ebuild')
-rw-r--r--app-emulation/hercules/hercules-3.05.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emulation/hercules/hercules-3.05.ebuild b/app-emulation/hercules/hercules-3.05.ebuild
new file mode 100644
index 000000000000..073e94352142
--- /dev/null
+++ b/app-emulation/hercules/hercules-3.05.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/hercules-3.05.ebuild,v 1.1 2007/06/24 21:18:41 vapier Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Hercules System/370, ESA/390 and zArchitecture Mainframe Emulator"
+HOMEPAGE="http://www.hercules-390.org/"
+SRC_URI="http://www.hercules-390.org/${P}.tar.gz"
+
+LICENSE="QPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="custom-cflags"
+
+src_compile() {
+ use custom-cflags || strip-flags
+ econf \
+ --enable-cckd-bzip2 \
+ --enable-het-bzip2 \
+ --enable-setuid-hercifc \
+ --enable-custom="Gentoo Linux ${PF}.ebuild" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die
+ dohtml -r html/
+ insinto /usr/share/hercules
+ doins hercules.cnf
+ dodoc README.* RELEASE.NOTES CHANGES
+}