summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-11-24 17:24:50 +0000
committerMike Frysinger <vapier@gentoo.org>2003-11-24 17:24:50 +0000
commitcc257805626f24cb1c7ef98ac11f5601bda4fc52 (patch)
tree70bb5b070f5152185ba55b0522f178f1c88891b3 /app-emulation/libspectrum/libspectrum-0.2.0.1-r1.ebuild
parentAdding media-video/mpeg4ip (diff)
downloadgentoo-2-cc257805626f24cb1c7ef98ac11f5601bda4fc52.tar.gz
gentoo-2-cc257805626f24cb1c7ef98ac11f5601bda4fc52.tar.bz2
gentoo-2-cc257805626f24cb1c7ef98ac11f5601bda4fc52.zip
handle glib better #34050
Diffstat (limited to 'app-emulation/libspectrum/libspectrum-0.2.0.1-r1.ebuild')
-rw-r--r--app-emulation/libspectrum/libspectrum-0.2.0.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-emulation/libspectrum/libspectrum-0.2.0.1-r1.ebuild b/app-emulation/libspectrum/libspectrum-0.2.0.1-r1.ebuild
new file mode 100644
index 000000000000..def37a0d10e9
--- /dev/null
+++ b/app-emulation/libspectrum/libspectrum-0.2.0.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libspectrum/libspectrum-0.2.0.1-r1.ebuild,v 1.1 2003/11/24 17:24:50 vapier Exp $
+
+DESCRIPTION="Spectrum emulation library"
+HOMEPAGE="http://www.srcf.ucam.org/~pak21/spectrum/libspectrum.html"
+SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="gnome"
+
+DEPEND="gnome? ( =dev-libs/glib-1* )
+ dev-libs/libgcrypt
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use gnome || epatch ${FILESDIR}/${PV}-no-gnome.patch
+}
+
+src_compile() {
+ econf `use_with gnome glib` || die
+ emake -j1 || die "libspectrum make failed!"
+}
+
+src_install() {
+ emake install DESTDIR=${D} || die
+ dodoc AUTHORS ChangeLog README THANKS doc/*.txt *.txt
+}