summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2012-01-15 04:26:54 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2012-01-15 04:26:54 +0000
commit8e8adc217a691e68871be395816c3ecc9f2a7d20 (patch)
tree9be12e68dc07dd139800996661da7f8e9f3faac5 /app-emulation/libvirt-glib
parentVersion bump. (diff)
downloadgentoo-2-8e8adc217a691e68871be395816c3ecc9f2a7d20.tar.gz
gentoo-2-8e8adc217a691e68871be395816c3ecc9f2a7d20.tar.bz2
gentoo-2-8e8adc217a691e68871be395816c3ecc9f2a7d20.zip
Bump to 0.0.4
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/libvirt-glib')
-rw-r--r--app-emulation/libvirt-glib/ChangeLog10
-rw-r--r--app-emulation/libvirt-glib/libvirt-glib-0.0.4.ebuild42
2 files changed, 50 insertions, 2 deletions
diff --git a/app-emulation/libvirt-glib/ChangeLog b/app-emulation/libvirt-glib/ChangeLog
index ccc4e3f557ba..5c588a096980 100644
--- a/app-emulation/libvirt-glib/ChangeLog
+++ b/app-emulation/libvirt-glib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/libvirt-glib
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/ChangeLog,v 1.5 2011/12/19 15:24:47 nirbheek Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/ChangeLog,v 1.6 2012/01/15 04:26:54 nirbheek Exp $
+
+*libvirt-glib-0.0.4 (15 Jan 2012)
+
+ 15 Jan 2012; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +libvirt-glib-0.0.4.ebuild:
+ Bump to 0.0.4
*libvirt-glib-0.0.3 (19 Dec 2011)
diff --git a/app-emulation/libvirt-glib/libvirt-glib-0.0.4.ebuild b/app-emulation/libvirt-glib/libvirt-glib-0.0.4.ebuild
new file mode 100644
index 000000000000..a66db85d7980
--- /dev/null
+++ b/app-emulation/libvirt-glib/libvirt-glib-0.0.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/libvirt-glib-0.0.4.ebuild,v 1.1 2012/01/15 04:26:54 nirbheek Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 python
+
+DESCRIPTION="GLib and GObject mappings for libvirt"
+HOMEPAGE="http://libvirt.org/git/?p=libvirt-glib.git"
+SRC_URI="ftp://libvirt.org/libvirt/glib/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +introspection python +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+# 0.9.8 is needed for VIR_DOMAIN_EVENT_SHUTDOWN
+RDEPEND="
+ dev-libs/libxml2:2
+ >=app-emulation/libvirt-0.9.8
+ >=dev-libs/glib-2.10:2
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.10 )
+ vala? ( dev-lang/vala:0.14 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ G2CONF="--disable-test-coverage
+ VAPIGEN=$(type -P vapigen-0.14)
+ $(use_enable introspection)
+ $(use_enable vala)
+ $(use_with python)"
+
+ python_set_active_version 2
+ python_pkg_setup
+}