summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-08-24 15:37:59 +0000
committerMike Gilbert <floppym@gentoo.org>2013-08-24 15:37:59 +0000
commit6bf21338da35eccab941693824381f5a3fb94446 (patch)
tree086068eb9159f1a05c2af9eb83539b8e1e22ea6f /app-emulation/open-vm-tools-kmod
parentremove texlive-2013 mask, bug #475124 (diff)
downloadgentoo-2-6bf21338da35eccab941693824381f5a3fb94446.tar.gz
gentoo-2-6bf21338da35eccab941693824381f5a3fb94446.tar.bz2
gentoo-2-6bf21338da35eccab941693824381f5a3fb94446.zip
Add patch from vmware-modules to fix vmblock under linux-3.10, bug 482256 by Serge.
(Portage version: 2.2.0_p8/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'app-emulation/open-vm-tools-kmod')
-rw-r--r--app-emulation/open-vm-tools-kmod/ChangeLog8
-rw-r--r--app-emulation/open-vm-tools-kmod/files/1098359-vmblock-3.10.0.patch24
-rw-r--r--app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2013.04.16.1098359.ebuild3
3 files changed, 33 insertions, 2 deletions
diff --git a/app-emulation/open-vm-tools-kmod/ChangeLog b/app-emulation/open-vm-tools-kmod/ChangeLog
index 36fc480b9c5c..53a0813634d7 100644
--- a/app-emulation/open-vm-tools-kmod/ChangeLog
+++ b/app-emulation/open-vm-tools-kmod/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/open-vm-tools-kmod
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools-kmod/ChangeLog,v 1.33 2013/06/22 23:27:33 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools-kmod/ChangeLog,v 1.34 2013/08/24 15:37:59 floppym Exp $
+
+ 24 Aug 2013; Mike Gilbert <floppym@gentoo.org>
+ +files/1098359-vmblock-3.10.0.patch,
+ open-vm-tools-kmod-2013.04.16.1098359.ebuild:
+ Add patch from vmware-modules to fix vmblock under linux-3.10, bug 482256 by
+ Serge.
*open-vm-tools-kmod-2013.04.16.1098359 (22 Jun 2013)
diff --git a/app-emulation/open-vm-tools-kmod/files/1098359-vmblock-3.10.0.patch b/app-emulation/open-vm-tools-kmod/files/1098359-vmblock-3.10.0.patch
new file mode 100644
index 000000000000..040d5145e9e2
--- /dev/null
+++ b/app-emulation/open-vm-tools-kmod/files/1098359-vmblock-3.10.0.patch
@@ -0,0 +1,24 @@
+--- a/modules/linux/vmblock/linux/control.c
++++ b/modules/linux/vmblock/linux/control.c
+@@ -208,9 +208,10 @@
+ VMBlockSetProcEntryOwner(controlProcMountpoint);
+
+ /* Create /proc/fs/vmblock/dev */
+- controlProcEntry = create_proc_entry(VMBLOCK_CONTROL_DEVNAME,
+- VMBLOCK_CONTROL_MODE,
+- controlProcDirEntry);
++ controlProcEntry = proc_create(VMBLOCK_CONTROL_DEVNAME,
++ VMBLOCK_CONTROL_MODE,
++ controlProcDirEntry,
++ &ControlFileOps);
+ if (!controlProcEntry) {
+ Warning("SetupProcDevice: could not create " VMBLOCK_DEVICE "\n");
+ remove_proc_entry(VMBLOCK_CONTROL_MOUNTPOINT, controlProcDirEntry);
+@@ -218,7 +219,6 @@
+ return -EINVAL;
+ }
+
+- controlProcEntry->proc_fops = &ControlFileOps;
+ return 0;
+ }
+
diff --git a/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2013.04.16.1098359.ebuild b/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2013.04.16.1098359.ebuild
index 7b3da1332228..2ce2ce5124d7 100644
--- a/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2013.04.16.1098359.ebuild
+++ b/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2013.04.16.1098359.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2013.04.16.1098359.ebuild,v 1.1 2013/06/22 23:27:33 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2013.04.16.1098359.ebuild,v 1.2 2013/08/24 15:37:59 floppym Exp $
EAPI="4"
@@ -60,6 +60,7 @@ src_prepare() {
|| die "Sed failed."
epatch "${FILESDIR}/frozen.patch"
epatch "${FILESDIR}/putname.patch"
+ epatch "${FILESDIR}/1098359-3.10.0.patch"
epatch_user
}