summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Kuznetsov <vadimk@gentoo.org>2012-12-09 14:12:28 +0000
committerVadim Kuznetsov <vadimk@gentoo.org>2012-12-09 14:12:28 +0000
commite5f7304942b165ba2922847fc3c129eca5196cb5 (patch)
tree989e138a452ceb34b69ae74a463b79d64738f9dc /app-emulation/open-vm-tools
parentversion bump. bug 438110 (diff)
downloadgentoo-2-e5f7304942b165ba2922847fc3c129eca5196cb5.tar.gz
gentoo-2-e5f7304942b165ba2922847fc3c129eca5196cb5.tar.bz2
gentoo-2-e5f7304942b165ba2922847fc3c129eca5196cb5.zip
version bump
(Portage version: 2.1.11.34/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-emulation/open-vm-tools')
-rw-r--r--app-emulation/open-vm-tools/ChangeLog11
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-2012.10.14.874563.ebuild (renamed from app-emulation/open-vm-tools/open-vm-tools-2012.03.13.651368.ebuild)2
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-9.2.2.893683.ebuild117
3 files changed, 127 insertions, 3 deletions
diff --git a/app-emulation/open-vm-tools/ChangeLog b/app-emulation/open-vm-tools/ChangeLog
index 8b4866cabab1..04d82984b165 100644
--- a/app-emulation/open-vm-tools/ChangeLog
+++ b/app-emulation/open-vm-tools/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/open-vm-tools
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.66 2012/06/02 15:03:01 vadimk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.67 2012/12/09 14:12:28 vadimk Exp $
+
+*open-vm-tools-9.2.2.893683 (09 Dec 2012)
+*open-vm-tools-2012.10.14.874563 (09 Dec 2012)
+
+ 09 Dec 2012; Vadim Kuznetsov vadimk@gentoo.org
+ +open-vm-tools-2012.10.14.874563.ebuild, +open-vm-tools-9.2.2.893683.ebuild,
+ -open-vm-tools-2012.03.13.651368.ebuild:
+ version bump
02 Jun 2012; Vadim Kuznetsov vadimk@gentoo.org
open-vm-tools-2012.05.21.724730.ebuild:
@@ -406,4 +414,3 @@
+open-vm-tools-0.0.20071121.64693.ebuild:
Initial commit. This should be usable for both ESX server, workstation,
player and normal server.
-
diff --git a/app-emulation/open-vm-tools/open-vm-tools-2012.03.13.651368.ebuild b/app-emulation/open-vm-tools/open-vm-tools-2012.10.14.874563.ebuild
index 855f9508b926..b8b36cf29982 100644
--- a/app-emulation/open-vm-tools/open-vm-tools-2012.03.13.651368.ebuild
+++ b/app-emulation/open-vm-tools/open-vm-tools-2012.10.14.874563.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-2012.03.13.651368.ebuild,v 1.3 2012/05/31 23:06:14 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-2012.10.14.874563.ebuild,v 1.1 2012/12/09 14:12:28 vadimk Exp $
EAPI="4"
diff --git a/app-emulation/open-vm-tools/open-vm-tools-9.2.2.893683.ebuild b/app-emulation/open-vm-tools/open-vm-tools-9.2.2.893683.ebuild
new file mode 100644
index 000000000000..52abb6075794
--- /dev/null
+++ b/app-emulation/open-vm-tools/open-vm-tools-9.2.2.893683.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-9.2.2.893683.ebuild,v 1.1 2012/12/09 14:12:28 vadimk Exp $
+
+EAPI="4"
+
+inherit eutils multilib pam user versionator
+
+MY_PV="$(replace_version_separator 3 '-')"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Opensourced tools for VMware guests"
+HOMEPAGE="http://open-vm-tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X doc fuse icu +pic unity xinerama"
+
+RDEPEND="app-emulation/open-vm-tools-kmod
+ dev-libs/glib:2
+ dev-libs/libdnet
+ sys-apps/ethtool
+ sys-process/procps
+ virtual/pam
+ X? (
+ dev-cpp/gtkmm:2.4
+ x11-base/xorg-server
+ x11-drivers/xf86-input-vmmouse
+ x11-drivers/xf86-video-vmware
+ x11-libs/gtk+:2
+ x11-libs/libnotify
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+ fuse? ( sys-fs/fuse )
+ icu? ( dev-libs/icu )
+ unity? (
+ dev-libs/uriparser
+ media-libs/libpng:1.2
+ x11-libs/libXScrnSaver
+ )
+ xinerama? ( x11-libs/libXinerama )
+ "
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig
+ virtual/linux-sources
+ sys-apps/findutils
+ "
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use unity && ! use X && die 'The Unity USE flag requires "X" USE flag as well'
+ use unity && ! use xinerama && die 'The Unity USE flag requires xinerame USE="xinerama" as well'
+
+ enewgroup vmware
+}
+
+src_prepare() {
+ # Do not filter out Werror
+ # Upstream Bug http://sourceforge.net/tracker/?func=detail&aid=2959749&group_id=204462&atid=989708
+ # sed -i -e 's/CFLAGS=.*Werror/#&/g' configure || die "sed comment out Werror failed"
+ sed -i -e 's:\(TEST_PLUGIN_INSTALLDIR=\).*:\1\$libdir/open-vm-tools/plugins/tests:g' configure || die "sed test_plugin_installdir failed"
+}
+
+src_configure() {
+ econf \
+ --with-procps \
+ --with-dnet \
+ --without-kernel-modules \
+ $(use_enable doc docs) \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_with X x) \
+ $(use_with X gtk2) \
+ $(use_with X gtkmm) \
+ $(use_with icu) \
+ $(use_with pic) \
+ $(use_enable unity) \
+ $(use_enable xinerama multimon)
+
+ # Bugs 260878, 326761
+ find ./ -name Makefile | xargs sed -i -e 's/-Werror//g' || die "sed out Werror failed"
+}
+
+src_install() {
+ default
+
+ rm "${D}"/etc/pam.d/vmtoolsd
+ pamd_mimic_system vmtoolsd auth account
+
+ rm "${D}"/usr/$(get_libdir)/*.la
+ rm "${D}"/usr/$(get_libdir)/open-vm-tools/plugins/common/*.la
+
+ newinitd "${FILESDIR}/open-vm-tools.initd" vmware-tools
+ newconfd "${FILESDIR}/open-vm-tools.confd" vmware-tools
+
+ exeinto /etc/vmware-tools/scripts/vmware/
+ doexe "${FILESDIR}"/network
+
+ if use X;
+ then
+ fperms 4755 "/usr/bin/vmware-user-suid-wrapper"
+
+ dobin "${S}"/scripts/common/vmware-xdg-detect-de
+
+ insinto /etc/xdg/autostart
+ doins "${FILESDIR}/open-vm-tools.desktop"
+
+ elog "To be able to use the drag'n'drop feature of VMware for file"
+ elog "exchange, please add the users to the 'vmware' group."
+ fi
+ elog "Add 'vmware-tools' service to the default runlevel."
+}