summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-14 06:35:28 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-14 06:35:28 +0000
commitedccd4b8ede833d914d593121f150431bc88ff4a (patch)
tree12a73dc1dab3847eee33cd9bb1081cf6d69909ac /app-emulation/point2play
parentStable on x86 for bug #51585. (Manifest recommit) (diff)
downloadgentoo-2-edccd4b8ede833d914d593121f150431bc88ff4a.tar.gz
gentoo-2-edccd4b8ede833d914d593121f150431bc88ff4a.tar.bz2
gentoo-2-edccd4b8ede833d914d593121f150431bc88ff4a.zip
ver bump #60014
Diffstat (limited to 'app-emulation/point2play')
-rw-r--r--app-emulation/point2play/ChangeLog8
-rw-r--r--app-emulation/point2play/files/1.3.1-fix-sound-test.patch20
-rw-r--r--app-emulation/point2play/files/digest-point2play-1.3.11
-rw-r--r--app-emulation/point2play/point2play-1.3.1.ebuild40
4 files changed, 68 insertions, 1 deletions
diff --git a/app-emulation/point2play/ChangeLog b/app-emulation/point2play/ChangeLog
index 7385c1782202..1ac1042f02d2 100644
--- a/app-emulation/point2play/ChangeLog
+++ b/app-emulation/point2play/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/point2play
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/ChangeLog,v 1.13 2004/06/25 11:56:00 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/ChangeLog,v 1.14 2004/08/14 06:35:28 vapier Exp $
+
+*point2play-1.3.1 (14 Aug 2004)
+
+ 14 Aug 2004; Mike Frysinger <vapier@gentoo.org>
+ +files/1.3.1-fix-sound-test.patch, +point2play-1.3.1.ebuild:
+ Version bump for #60014 by Alex Rostovtsev.
*point2play-1.3b (24 Jun 2004)
diff --git a/app-emulation/point2play/files/1.3.1-fix-sound-test.patch b/app-emulation/point2play/files/1.3.1-fix-sound-test.patch
new file mode 100644
index 000000000000..4cfcdcd2b06b
--- /dev/null
+++ b/app-emulation/point2play/files/1.3.1-fix-sound-test.patch
@@ -0,0 +1,20 @@
+--- /var/tmp/portage/point2play-1.3.1/work/usr/lib/transgaming_point2play/tests/test_sound.py.orig 2004-08-14 01:22:11.956853792 -0400
++++ /var/tmp/portage/point2play-1.3.1/work/usr/lib/transgaming_point2play/tests/test_sound.py 2004-08-14 01:22:20.241594320 -0400
+@@ -40,15 +40,13 @@
+ # OSS Portion of the test
+ #
+ try:
+- audio_out = ossaudiodev.open('/dev/dsp', 'w')
++ audio_out = ossaudiodev.open('w')
+ except IOError, e:
+ OSSResult = ((_('OSS Sound Support'), _('Unable to open /dev/dsp'), 'red'))
+
+ if audio_out:
+ try:
+- audio_out.setparameters(TestSound1.getframerate(), 16,
+- TestSound1.getnchannels(), ossaudiodev.AFMT_S16_LE, False)
+- #FIXME: use getsampwidth for 16 and AFMT_S16_LE
++ audio_out.setparameters(ossaudiodev.AFMT_S16_LE, TestSound1.getnchannels(), TestSound1.getframerate())
+ except:
+ audio_out.close()
+ OSSResult = ((_('OSS Sound Support'), _('Unable to play sound, your\nSound card may not be configured correctly'), 'red'))
diff --git a/app-emulation/point2play/files/digest-point2play-1.3.1 b/app-emulation/point2play/files/digest-point2play-1.3.1
new file mode 100644
index 000000000000..d92489a1f037
--- /dev/null
+++ b/app-emulation/point2play/files/digest-point2play-1.3.1
@@ -0,0 +1 @@
+MD5 010f033c1a80165959939e9d2f1dd5f5 point2play-small-1.3.1.tgz 822911
diff --git a/app-emulation/point2play/point2play-1.3.1.ebuild b/app-emulation/point2play/point2play-1.3.1.ebuild
new file mode 100644
index 000000000000..6c4874c19690
--- /dev/null
+++ b/app-emulation/point2play/point2play-1.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/point2play-1.3.1.ebuild,v 1.1 2004/08/14 06:35:28 vapier Exp $
+
+inherit eutils
+
+MY_P=${PN}-small-${PV}
+DESCRIPTION="graphical frontend for WineX"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="point2play"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RESTRICT="fetch"
+
+RDEPEND="virtual/x11
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-1.99.16
+ >=x11-themes/gtk-engines-metal-2.2.0"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please download the appropriate Point2Play archive (${MY_P}.tgz)"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ echo
+ einfo "The archive should then be placed into ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-fix-sound-test.patch
+}
+
+src_install() {
+ mv usr ${D}/
+ mv etc/X11/applnk ${D}/usr/share
+}