summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2005-07-25 22:50:50 +0000
committerLuca Barbato <lu_zero@gentoo.org>2005-07-25 22:50:50 +0000
commit78c6888664af25d7967395c70e81869d878569b2 (patch)
treecc20e9846dfaa6273635278dcf94edfcf24fd85b /app-emulation/qemu-user
parentStable on x86 and fixed SRC_URI (diff)
downloadgentoo-2-78c6888664af25d7967395c70e81869d878569b2.tar.gz
gentoo-2-78c6888664af25d7967395c70e81869d878569b2.tar.bz2
gentoo-2-78c6888664af25d7967395c70e81869d878569b2.zip
New version
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-emulation/qemu-user')
-rw-r--r--app-emulation/qemu-user/ChangeLog7
-rw-r--r--app-emulation/qemu-user/Manifest6
-rw-r--r--app-emulation/qemu-user/files/digest-qemu-user-0.7.11
-rw-r--r--app-emulation/qemu-user/qemu-user-0.7.1.ebuild85
4 files changed, 96 insertions, 3 deletions
diff --git a/app-emulation/qemu-user/ChangeLog b/app-emulation/qemu-user/ChangeLog
index 7bbbc700a278..6e6f4af963df 100644
--- a/app-emulation/qemu-user/ChangeLog
+++ b/app-emulation/qemu-user/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/qemu-user
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.1 2005/06/18 11:59:55 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.2 2005/07/25 22:48:45 lu_zero Exp $
+
+*qemu-user-0.7.1 (25 Jul 2005)
+
+ 25 Jul 2005; Luca Barbato <lu_zero@gentoo.org> +qemu-user-0.7.1.ebuild:
+ New version
*qemu-user-0.7.0-r1 (18 Jun 2005)
diff --git a/app-emulation/qemu-user/Manifest b/app-emulation/qemu-user/Manifest
index 7fe929a18cfa..6f68a794b573 100644
--- a/app-emulation/qemu-user/Manifest
+++ b/app-emulation/qemu-user/Manifest
@@ -1,5 +1,7 @@
-MD5 898131aae735c3477ff2f9c6882f1178 metadata.xml 223
-MD5 b3885f4c930c2d6847f573a5d33bcd8e ChangeLog 422
MD5 431458f4c01ad6238f20d77302e4b871 qemu-user-0.7.0-r1.ebuild 2250
+MD5 b3885f4c930c2d6847f573a5d33bcd8e ChangeLog 422
+MD5 21e7c936965f73ba5f94287407075d4b qemu-user-0.7.1.ebuild 2212
+MD5 898131aae735c3477ff2f9c6882f1178 metadata.xml 223
MD5 4fac7d5e68ef58489e7734f5dccb2918 files/digest-qemu-user-0.7.0-r1 63
+MD5 36d599117f12a2bf8edc47c1daeff3a6 files/digest-qemu-user-0.7.1 63
MD5 3202f7445799cce82ccaac9749e1443d files/qemu-user-0.7.0-errno.patch 487
diff --git a/app-emulation/qemu-user/files/digest-qemu-user-0.7.1 b/app-emulation/qemu-user/files/digest-qemu-user-0.7.1
new file mode 100644
index 000000000000..530b0668f236
--- /dev/null
+++ b/app-emulation/qemu-user/files/digest-qemu-user-0.7.1
@@ -0,0 +1 @@
+MD5 b0c80d2c082049a5b8ccbc7f55fe165b qemu-0.7.1.tar.gz 1338521
diff --git a/app-emulation/qemu-user/qemu-user-0.7.1.ebuild b/app-emulation/qemu-user/qemu-user-0.7.1.ebuild
new file mode 100644
index 000000000000..bb2f5cf2ee26
--- /dev/null
+++ b/app-emulation/qemu-user/qemu-user-0.7.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-0.7.1.ebuild,v 1.1 2005/07/25 22:48:45 lu_zero Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Multi-platform & multi-targets cpu emulator and dynamic translator"
+HOMEPAGE="http://fabrice.bellard.free.fr/qemu/"
+SRC_URI="http://fabrice.bellard.free.fr/qemu/${P/-user}.tar.gz"
+#qvm86? ( http://dev.gentoo.org/~lu_zero/distfiles/qvm86-20050409.tar.bz2 )"
+#kqemu? ( http://fabrice.bellard.free.fr/qemu/kqemu-${PV%.*}-1.tar.gz )
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc -alpha -sparc ~amd64"
+IUSE="" #qvm86 debug nptl qemu-fast nptlonly"
+RESTRICT="nostrip"
+
+DEPEND="virtual/libc
+ app-text/texi2html
+ !<=app-emulation/qemu-0.7.0"
+RDEPEND=""
+
+S="${WORKDIR}/${P/-user}"
+
+set_target_list() {
+ TARGET_LIST="arm-user armeb-user i386-user ppc-user sparc-user"
+ export TARGET_LIST
+}
+
+pkg_setup() {
+ if [ "$(gcc-major-version)" == "4" ]; then
+ ewarn "Qemu could not build with GCC 4"
+ fi
+}
+
+#RUNTIME_PATH="/emul/gnemul/"
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ # Alter target makefiles to accept CFLAGS set via flag-o.
+ sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
+ Makefile Makefile.target tests/Makefile
+ # Ensure mprotect restrictions are relaxed for emulator binaries
+ [[ -x /sbin/paxctl ]] && \
+ sed -i 's/^VL_LDFLAGS=$/VL_LDFLAGS=-Wl,-z,execheap/' \
+ Makefile.target
+ # Prevent install of kernel module by qemu's makefile
+ sed -i 's/\(.\/install.sh\)/#\1/' Makefile
+}
+
+src_compile() {
+ #Let the application set its cflags
+ unset CFLAGS
+
+ # Switch off hardened tech
+ filter-flags -fpie -fstack-protector
+
+ myconf=""
+ set_target_list
+# --interp-prefix=${RUNTIME_PATH}/qemu-%M
+ ./configure \
+ --prefix=/usr \
+ --target-list="${TARGET_LIST}" \
+ --enable-slirp \
+ --kernel-path=${KV_DIR} \
+ ${myconf} \
+ || die "could not configure"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make install \
+ prefix=${D}/usr \
+ bindir=${D}/usr/bin \
+ datadir=${D}/usr/share/qemu \
+ docdir=${D}/usr/share/doc/${P} \
+ mandir=${D}/usr/share/man || die
+
+ rm -fR ${D}/usr/share/{man,qemu}
+ rm -fR ${D}/usr/bin/qemu-img
+}