summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2005-08-06 14:15:36 +0000
committerLuca Barbato <lu_zero@gentoo.org>2005-08-06 14:15:36 +0000
commit860b9dd6189d476a57af10d9c9a8188fdfbad1e4 (patch)
tree4ea7ad0698e48850db43b85ee8c7fafd7d0776fb /app-emulation/qemu-user
parentRe-added ~mips for bug 99915. (diff)
downloadgentoo-2-860b9dd6189d476a57af10d9c9a8188fdfbad1e4.tar.gz
gentoo-2-860b9dd6189d476a57af10d9c9a8188fdfbad1e4.tar.bz2
gentoo-2-860b9dd6189d476a57af10d9c9a8188fdfbad1e4.zip
Ugly workaround
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-emulation/qemu-user')
-rw-r--r--app-emulation/qemu-user/ChangeLog7
-rw-r--r--app-emulation/qemu-user/Manifest7
-rw-r--r--app-emulation/qemu-user/files/qemu-ppc-dirty-hack.patch12
-rw-r--r--app-emulation/qemu-user/qemu-user-0.7.1.ebuild4
4 files changed, 24 insertions, 6 deletions
diff --git a/app-emulation/qemu-user/ChangeLog b/app-emulation/qemu-user/ChangeLog
index 6e6f4af963df..dfd3ede5b880 100644
--- a/app-emulation/qemu-user/ChangeLog
+++ b/app-emulation/qemu-user/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/qemu-user
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.2 2005/07/25 22:48:45 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.3 2005/08/06 14:15:36 lu_zero Exp $
+
+ 06 Aug 2005; Luca Barbato <lu_zero@gentoo.org>
+ +files/qemu-ppc-dirty-hack.patch, qemu-user-0.7.1.ebuild:
+ Workaround to make it build with newer binutils, thanks to Andrew de Quincey
+ <adq_dvb@lidskialf.net>
*qemu-user-0.7.1 (25 Jul 2005)
diff --git a/app-emulation/qemu-user/Manifest b/app-emulation/qemu-user/Manifest
index 2230c38539d1..718d3f5308aa 100644
--- a/app-emulation/qemu-user/Manifest
+++ b/app-emulation/qemu-user/Manifest
@@ -1,7 +1,8 @@
-MD5 898131aae735c3477ff2f9c6882f1178 metadata.xml 223
-MD5 d45d30a90e764df90d8a66fee1db7d37 qemu-user-0.7.1.ebuild 2209
MD5 73a2605efc2c7d4c17b767af8eb82310 ChangeLog 543
MD5 431458f4c01ad6238f20d77302e4b871 qemu-user-0.7.0-r1.ebuild 2250
+MD5 898131aae735c3477ff2f9c6882f1178 metadata.xml 223
+MD5 1451d033523afc81de7b92e80c97c684 qemu-user-0.7.1.ebuild 2242
+MD5 3202f7445799cce82ccaac9749e1443d files/qemu-user-0.7.0-errno.patch 487
+MD5 297287b50341a53d302b58ab9ee73a5f files/qemu-ppc-dirty-hack.patch 422
MD5 4fac7d5e68ef58489e7734f5dccb2918 files/digest-qemu-user-0.7.0-r1 63
MD5 36d599117f12a2bf8edc47c1daeff3a6 files/digest-qemu-user-0.7.1 63
-MD5 3202f7445799cce82ccaac9749e1443d files/qemu-user-0.7.0-errno.patch 487
diff --git a/app-emulation/qemu-user/files/qemu-ppc-dirty-hack.patch b/app-emulation/qemu-user/files/qemu-ppc-dirty-hack.patch
new file mode 100644
index 000000000000..7895fc8571fb
--- /dev/null
+++ b/app-emulation/qemu-user/files/qemu-ppc-dirty-hack.patch
@@ -0,0 +1,12 @@
+diff -Nau qemu-0.7.1.orig/ppc.ld qemu-0.7.1/ppc.ld
+--- qemu-0.7.1.orig/ppc.ld 2005-07-24 19:52:08.000000000 +0100
++++ qemu-0.7.1/ppc.ld 2005-08-06 01:03:46.000000000 +0100
+@@ -8,7 +8,7 @@
+ SECTIONS
+ {
+ /* Read-only sections, merged into text segment: */
+- . = 0x60000000 + SIZEOF_HEADERS;
++ . = 0x60000000 + 0x400;
+ .interp : { *(.interp) }
+ .hash : { *(.hash) }
+ .dynsym : { *(.dynsym) }
diff --git a/app-emulation/qemu-user/qemu-user-0.7.1.ebuild b/app-emulation/qemu-user/qemu-user-0.7.1.ebuild
index bb2f5cf2ee26..35216047212a 100644
--- a/app-emulation/qemu-user/qemu-user-0.7.1.ebuild
+++ b/app-emulation/qemu-user/qemu-user-0.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-0.7.1.ebuild,v 1.1 2005/07/25 22:48:45 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-0.7.1.ebuild,v 1.2 2005/08/06 14:15:36 lu_zero Exp $
inherit eutils flag-o-matic
@@ -39,7 +39,7 @@ src_unpack() {
unpack ${A}
cd ${S}
-
+ epatch ${FILESDIR}/qemu-ppc-dirty-hack.patch
# Alter target makefiles to accept CFLAGS set via flag-o.
sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
Makefile Makefile.target tests/Makefile