summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-06-08 15:58:05 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-06-08 15:58:05 +0000
commitc0802c8857c11a63e0098e73a9aeeb081f56552f (patch)
tree7c035c4183b02f86d0fe12045f482aafeace0d4e /app-emulation/qtemu/qtemu-1.0.5.ebuild
parentNon-Maintainer Commit: Applying patch for CVE-2008-5371, bug 250476. (diff)
downloadgentoo-2-c0802c8857c11a63e0098e73a9aeeb081f56552f.tar.gz
gentoo-2-c0802c8857c11a63e0098e73a9aeeb081f56552f.tar.bz2
gentoo-2-c0802c8857c11a63e0098e73a9aeeb081f56552f.zip
Initial commit. Fixes bug 184112
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/qtemu/qtemu-1.0.5.ebuild')
-rw-r--r--app-emulation/qtemu/qtemu-1.0.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emulation/qtemu/qtemu-1.0.5.ebuild b/app-emulation/qtemu/qtemu-1.0.5.ebuild
new file mode 100644
index 000000000000..38ff3c3c40d2
--- /dev/null
+++ b/app-emulation/qtemu/qtemu-1.0.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qtemu/qtemu-1.0.5.ebuild,v 1.1 2009/06/08 15:58:04 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils qt4 cmake-utils
+
+DESCRIPTION="A graphical user interface for QEMU written in Qt4."
+HOMEPAGE="http://qtemu.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1 CCPL-Attribution-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}
+ app-emulation/qemu"
+
+DOCS="ChangeLog README"
+PATCHES=(
+ "${FILESDIR}/${PV}-help_and_translation_paths.patch"
+)
+
+src_install() {
+ cmake-utils_src_install
+ doicon "${S}/images/${PN}.ico"
+ make_desktop_entry "qtemu" "QtEmu" "${PN}.ico" "Qt;Utility;Emulator"
+}