summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2010-07-16 21:58:41 +0000
committerDoug Goldstein <cardoe@gentoo.org>2010-07-16 21:58:41 +0000
commit9513a3c70e30cd78e1a4296afd6886257ddbd07f (patch)
tree9b0390044c617c4d68cdf6badc73035a26f0f36e /app-emulation/virt-what/files
parentStable on amd64 wrt bug #328423 (diff)
downloadgentoo-2-9513a3c70e30cd78e1a4296afd6886257ddbd07f.tar.gz
gentoo-2-9513a3c70e30cd78e1a4296afd6886257ddbd07f.tar.bz2
gentoo-2-9513a3c70e30cd78e1a4296afd6886257ddbd07f.zip
Add initial version to Gentoo
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/virt-what/files')
-rw-r--r--app-emulation/virt-what/files/virt-what-1.2-bin-to-sbin.patch21
-rw-r--r--app-emulation/virt-what/files/virt-what-1.2-vmware-cpuid-check.patch48
2 files changed, 69 insertions, 0 deletions
diff --git a/app-emulation/virt-what/files/virt-what-1.2-bin-to-sbin.patch b/app-emulation/virt-what/files/virt-what-1.2-bin-to-sbin.patch
new file mode 100644
index 000000000000..9a1cff921617
--- /dev/null
+++ b/app-emulation/virt-what/files/virt-what-1.2-bin-to-sbin.patch
@@ -0,0 +1,21 @@
+From: Richard Jones <rjones@redhat.com>
+Date: Wed, 30 Dec 2009 12:15:25 +0000 (+0000)
+Subject: Install virt-what in $sbindir since the script should only be run by root (suggested...
+X-Git-Url: http://git.annexia.org/?p=virt-what.git;a=commitdiff_plain;h=25ec46454ca3aec7886d45ee4d99d7db330c34f7
+
+Install virt-what in $sbindir since the script should only be run by root (suggested by Laurent Léonard)
+---
+
+diff --git a/Makefile.am b/Makefile.am
+index 8efacb9..5f76d8f 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -21,7 +21,7 @@ CLEANFILES = virt-what.1 virt-what.txt
+
+ AM_CPPFLAGS = -Wall
+
+-bin_SCRIPTS = virt-what
++sbin_SCRIPTS = virt-what
+ libexec_PROGRAMS = virt-what-cpuid-helper
+
+ man_MANS = virt-what.1
diff --git a/app-emulation/virt-what/files/virt-what-1.2-vmware-cpuid-check.patch b/app-emulation/virt-what/files/virt-what-1.2-vmware-cpuid-check.patch
new file mode 100644
index 000000000000..2326e6298d9e
--- /dev/null
+++ b/app-emulation/virt-what/files/virt-what-1.2-vmware-cpuid-check.patch
@@ -0,0 +1,48 @@
+diff --git a/virt-what.in b/virt-what.in
+index 11ca772..313cd06 100644
+--- a/virt-what.in
++++ b/virt-what.in
+@@ -70,14 +70,26 @@ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+ PATH=@libexecdir@:/sbin:/usr/sbin:$PATH
+
++# Many fullvirt hypervisors give an indication through CPUID. Use the
++# helper program to get this information.
++
++cpuid=`virt-what-cpuid-helper`
++
+ # Check for various products in the BIOS information.
+
+ dmi=`dmidecode 2>&1`
+
+-if echo "$dmi" | grep -q 'Manufacturer: VMware'; then
++# Check for VMware.
++# cpuid check added by Chetan Loke.
++
++if [ "$cpuid" = "VMwareVMware" ]; then
++ echo vmware
++elif echo "$dmi" | grep -q 'Manufacturer: VMware'; then
+ echo vmware
+ fi
+
++# Check for VirtualPC.
++
+ if echo "$dmi" | grep -q 'Manufacturer: Microsoft Corporation'; then
+ echo virtualpc
+ fi
+@@ -101,14 +113,9 @@ fi
+ # Check for UML.
+ # Added by Laurent Léonard.
+ if grep -q 'UML' /proc/cpuinfo; then
+-    echo uml
++ echo uml
+ fi
+
+-# To tell if it is Xen and KVM HVM (fully virtualized) we can use this
+-# helper C program.
+-
+-cpuid=`virt-what-cpuid-helper`
+-
+ # Check for Xen.
+
+ if [ "$cpuid" = "XenVMMXenVMM" ]; then